BGE non fonctionnel sous mac

Posté par Sharlie le 29/11/2017 18:28:57
Au secours !

J'ai l'impression d'avoir tout essayer, j'ai été tout l'après midi sur ce problème sans succès.

Je suis sous Mac Os Sierra (pour l'instant parce qu'en désespoir de cause je fais la mies à jour vers High Sierra sur l'autre ordi)

ça fait un certain temps que je constate que lorsque j'installe une mise à jour blender (depuis 2.77) et lorsque je clique sur Standalone player > Start des version suivante (2.78, 2.79) j'ai le message suivant :

[img]https://photos-4.dropbox.com/t/2/AAAxG-tI3eGnAdpNYqjoqXqY_01XnYSPfpSKzR1H_Us5sQ/12/278921983/jpeg/32x32/1/_/1/2/Capture%20d’écran%202017-11-29%20à%2016.39.33.jpg/EKWlgIsCGM5CIAcoBw/XjcfCYbDFgsbdwnWPc_TjP4DWSRLSogjiypidtWvNMw?size=1280x960&size_mode=3[/img]

( Ici si ça ne marche pas : https://www.dropbox.com/s/uyh9rklxh3gcdlm/Capture%20d%E2%80%99%C3%A9cran%202017-11-29%20%C3%A0%2016.39.33.jpg?dl=0 )

Bon alors du coup jusqu'à présent j'utilisais la 2.77 n'ayant pas un besoin absolue de passer aux versions suivantes. Problème, y a un Bug précis dans le BGE depuis la version 2.75 que Matpy a découvert, donc je dois utiliser la version 2.75 de blender pour le programme qu'on est en train de developper ensemble. Je la télécharge et même soucis qu'avec les versions postérieurs.

Concernant les renseignement pris, le chemin en question mène à un dossier caché AppTranslocation dans lequel apparait à l'ouverture de blender un dossier temporaire dont le nom est différent à chaque fois dans lequel il y a un dossier "d" avec dedans l'application blender mais pas l'application blenderplayer donc forcément il ne la trouve pas. J'ai tout essayé j'ai l'impression : ajouter l'exe blenderplayer dans l'application blender, ouvrir en ligne de commande, ajouter blenderplayer dans le dossier amovible manuellement n'est pas possible, supprimer toutes les versions, recharger, vider tous les caches d'appli...

J'ai constaté que la version qui fonctionne (qui est d'ailleurs différente sur mes 2 ordi 2.77 sur l'un 2.78a sur l'autre (donc le soucis ne vient pas de l'application blender en soi), est dans les deux cas la seule de toutes les versions installées sur les 2 ordi qui ne crée pas de dossier temporaire dans le dossier caché AppTranslocation ... Donc je me dis que ça doit être une histoire de conflit...

Je trouve pas, je suis bloquée, et comme j'ai tout viré sur l'un de mes ordi j'ai même plus rien qui fonctionne en matière de BGE.

Je fais donc la mise à jour vers High Sierra sait-on jamais. Si quelqu'un a la solution parce que je suis vraiment dans la berdouille...

Cette contribution était de : http://blenderclan.tuxfamily.org/html/newbb/viewtopic.php?forum=21&topic_id=47884&post_id=569353