Expérience sur les versions du BGE.

Posté par Redstar le 25/9/2016 9:11:31
Bonjour à toutes et à tous,

Aujourd'hui, je souhaiterai faire une expérience avec la compatibilité du BGE pour Windows 10 et Mac Osx.

Le but est double: vérifier ma théorie et déterminer la bonne version pour le bon OS.

Voici ma théorie: Sur Windows 10, j'avais déjà fait testé mon jeu (la dernière version, Blender 2.77, je crois) à une personne tiers et elle m'a rapportée que ça fonctionnait bien chez elle, ce qui n'était pas le cas chez moi...

Du coup, j'aimerai tenter de déterminer une version compatible QUE pour Win 10 et QUE pour Mac OSX

Donc ça veux dire que je vais avoir 3-4 voire 5 versions du BGE compilé, pour les 3 OS. C'est un peu tordu mais j'ai exploré toutes les solutions sauf celle-ci.

Donc j'ai besoin de 4 personnes (2 Win 10 et 2 Mac OS) qui puissent prendre le temps de tester chaque versions du bge de blender de 2.77 à 2.70 (pour Win 10, c'est de 2.73-2.74 min, vous pouvez le vérifier en cherchant après "SDL2.dll " dans le dossier racine de Blender).

Voici un tout petit blend de test

Voilà comment ça marche:
Quand vous allez tester une version, vous allez avoir deux possibilités:

- Soit le dome "clignote", ce qui signifie que c'est pas bon (en gros, si je passe les détails)
- Soit vous ne distinguez rien d'anormal, ce qui veux dire qu'il y a des chances que ce soit la bonne version.

Il faut absolument que les deux testeurs de l'OS aient le même résultat !!! Cela signifiera que ça fonctionnera chez les autres aussi (forcément ).

Une fois la version déterminée, je vous ferai tester, sur la version trouvée, mon jeu beta 0.2, pour m'assurer que ce sera la bonne version du BGE.

Pour terminer, il n'est pas obligatoire d'avoir que 4 personnes. Si plus de monde participe à l’expérience, plus la probabilité d'avoir la bonne version sera grande.

Je pense ne rien avoir oublié.

Cette contribution était de : http://blenderclan.tuxfamily.org/html/newbb/viewtopic.php?forum=3&topic_id=46367&post_id=557719