Re: une forêt de bambou !

Posté par Ludo38 le 7/5/2013 3:38:47
Suite à vos conseils et chouettes encouragements, j'ai recommencé les choses à zéro, et je fais pour le moment un essai sur un tout petit bout de bambou, et j'ai enfin osé l'UV mapping !!

(dans la "vraie vie" je suis aussi artisan bambou, du coup j'ai des tonnes de photos de gros plans sur des bambous! )




Comme vous le voyez sur cette dernière capture, j'ai 3 problèmes principaux :

1) je ne sais pas pourquoi, mais je n'obtenir vraiment ce que je veux avec le nœud du bambou... J'ai modélisé le volume du nœud dans le mesh, séparé du reste du volume, comme une sorte d'anneau avançant hors du diamètre du reste du tube du bambou. Cet anneau est tout bête, il comprend 4 rings, dont les 2 centraux vont en renfoncement, bref comme sur un vrai bambou. Et malgré ma bonne préparation de texture sur Gimp (bien vérifié que la teinte, la lumière et le contraste du nœud soit bien en harmonie avec la peau du reste du bambou, ben j'arrive pas à éviter cet effet de différence. Je dois peut-être travailler encore plus précisément sur ma texture...

2) la zone du seam vertical sur le tube du bambou ressort, comme si l'ensemble ne se touchait pas correctement. Est-ce dû à un mauvais calage de mon image texture dans Gimp par rapport au layout ou bien est-ce un problème typique qui se règle dans Blender en changeant un réglage qlq part ?

3) sur le côté gauche de l'image rendue, l'ombre ne rend pas bien sur le bambou, elle fait une ligne droite alors qu'elle devrait être progressive selon la courbe du bambou... J'ai oublié un réglage ?

Finalement c'est pas si dur l'UV mapping :) Mais bon, faut avoir la bonne matière au départ, et puis j'imagine qu'il faut éviter de retoucher sa modélisation ensuite.
Ah, et j'ai remarqué que quand j'enlève ma texture puis je la remet (pour la mettre à jour après une modif dans Gimp), Blender ne la reconnait pas automatiquement. Il continue d'utiliser ma texture précédente. J'ai du coup dû fermer mon .blend, le réouvrir et recharger la texture. Là aussi, j'imagine qu'il y a une manip toute bête. Est-ce que je dois cocher un truc dans la zone texture dans la colonne de droite ?..

Cette contribution était de : http://blenderclan.tuxfamily.org/html/newbb/viewtopic.php?forum=5&topic_id=38724&post_id=474585