(1) 2 »


ultraportable
OverdOzed
Inscrit:
19/04/2007 15:06
Post(s): 484
Bonjour le blenderclan,

ma question est la suivante:

j'ai un cube transparent avec raytransp et un plane en dessous en onlyshadow, l'ombre est bien portée mais pas au travers du cube. dans le cube on voit mon plan en noir alors qu'il ne devrait pas être visible hormis l'ombre portée du cube.

existe t il une solution pour combiner tout ça?

Merci
A+

Edit: voici l'image:

Contribution le : 04/07/2008 14:13
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Je suis pas certain d'avoir bien compris (une image serait plus pratique), mais essaye de cocher 'trashad' dans le shader du plan.

Contribution le : 04/07/2008 14:16
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
OverdOzed
Inscrit:
19/04/2007 15:06
Post(s): 484
au moment ou tu écrivais, j'ai éditer mon message avec une image.. le traceshadow ne résoud pas le pb

Contribution le : 04/07/2008 14:22
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
OverdOzed
Inscrit:
21/03/2005 15:25
De Belgique
Post(s): 527
Salut,

Je vais sans doute dire une bêtise mais le Depth est à combien ? Essaie plus que 2 s'il est à deux. J'imagine que tout le monde y avait déjà pensé... Bon ok, je sors...

Contribution le : 04/07/2008 14:28
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
Ze Grand Manitou
Inscrit:
24/07/2003 14:50
De la Région Parisienne
Post(s): 21822
kan_gourou, envoies ton fichier blend :
http://hostit.warrenberberd.org/

@+

Contribution le : 04/07/2008 14:35
_________________

Mickaël Guédon | Site pro : www.mickaelguedon.com | Fondateur du Blender Clan : www.blenderclan.org
Auteur de Formations Blender chez Elephorm
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
OverdOzed
Inscrit:
19/04/2007 15:06
Post(s): 484
le depth ne change rien..
en utilisant ztrans au lieu de raytransp mais en gardant la valeur du fresnel, ça semble fonctionner:



je vais voir si mais tests s'pplique bien à mon blend en cours

Contribution le : 04/07/2008 14:42
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
OverdOzed
Inscrit:
19/04/2007 15:06
Post(s): 484
non en fait ça résouds le pb mais ça en amène d'autres:

en choisissant ztransp, je n'est plus l' IOR et le raymirror ne s'applique plus correctement..

voici les valeurs du plan et du cube en raytransp:





pour ceux qui désirent connaitre mon travail en cours:


A+

Contribution le : 04/07/2008 15:00
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Une façon de contourner le problème, c'est simplement de ne pas utiliser "OnlyShadow". Remplace ton plan en onlyshadow par un plan "solide" qui s'incurve vers le haut au fond de l'image. Le temps de rendu sera plus long (surtout si tu utilises l'ao), mais ça devrait t'éviter les soucis d'alpha...

Contribution le : 04/07/2008 15:03
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
OverdOzed
Inscrit:
17/09/2007 15:50
De Toulouse
Post(s): 1582
Sinon laisses le plan en onlyshadow et vérifie que TraShadow est enclenché, et augmente la valeur "Tralu" du cube dans ses shaders, en le laissant en RayTransp

Contribution le : 04/07/2008 15:18
_________________
Mon nouveau site
Créer un fichier PDF de la contribution Imprimer


Re: probleme onlyshadow avec un objet en raytransp
OverdOzed
Inscrit:
19/04/2007 15:06
Post(s): 484
bon, en fait j'ai reporté le probleme de plan en onlyshadow avec un objet en raytransp..
j'ai tout éssayé (mais je penses avoir oublié quelque chose mais quoi?)
je suis reparti sur un sol sans onlyshadow peut être plus adapté au rendu que je désire
voici ce que ça donne, rien de définitif



j'ai encore des problemes avec l'écran et la transparence du clavier

A+

PS: Ebrain si tu sens que ça doit être dans la section wip, peux tu le changer stp? merci

<edit> Déplacé par </edit>

Contribution le : 08/07/2008 16:07
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Matériau partiellement transparent 1 24 Aujourd'hui 20:24:46
debutant 
The Blender Clan 'tchat W10 pour le prix d'une cacahuète    [1][2][3] 23 423 Hier 17:29:47
Bibi09 
Hors Sujet !! les tutos de Moonboots    [1][2][3]...[26] 256 30178 Hier 12:26:33
moonboots 
[WIP] et travaux terminés [WIP] La pince à linge    [1][2] 11 239 21/01 18:53:10
meltingman 
Hors Sujet !! Tuto Astraonaute low-poly + rigify en 25mm 3 195 21/01 14:47:47
meltingman 
Questions & Réponses Texture et courbe de Bézier 9 174 21/01 14:19:10
Horemheb 
Questions & Réponses freestyle lineset : ignorer un objet spécifique pour une arrête cachée 0 96754 21/01 08:56:34
yekcim 
[WIP] et travaux terminés Pagani Zonda Barchetta 6 224 20/01 09:03:37
moonboots 
[WIP] et travaux terminés [WIP] La gabarre '' Le Gros Ventre''    [1][2][3]...[12] 112 22228 19/01 17:57:26
Guiu 
Questions & Réponses chemins suivant une déformation de surface 6 170 19/01 12:26:50
meltingman 
Questions & Réponses Vitesse d'une vidéo 4 136 18/01 19:59:42
meltingman 
Questions & Réponses Armature sans parenté? 1 87 18/01 19:38:25
meltingman 
The Blender Clan 'tchat Avenir du blender clan    [1][2][3]...[41] 405 49081 17/01 20:40:59
Rimpotche 
Questions & Réponses texture eyes avec empty 1 91 17/01 13:17:33
Rimpotche 
The Blender Clan 'tchat Progression dans Blender et la 3D    [1][2] 11 574 16/01 17:37:45
Rimpotche 
Questions & Réponses [terminé] Modificateur Mirror sur un Vertex Group 2 134 16/01 15:55:36
Horemheb 
Questions & Réponses Ma caméra me saoule... 5 259 15/01 20:33:23
Lylo 
Hors Sujet !! Appareil Photo Compact, qualité, zoom...    [1][2] 19 529 14/01 14:45:17
lucky 
Questions & Réponses [résolu] Comportement du parentage et du Weight Paint bizarres    [1][2] 14 148012 10/01 15:17:23
Horemheb 
Hors Sujet !! BONNE ANNEE LE BLENDER CLAN    [1][2] 10 451 10/01 13:34:18
Riggelm 

Qui est en ligne
206 utilisateur(s) en ligne (dont 98 sur Forums)

Membre(s): 0
Invité(s): 206


plus...
Nouveaux membres
BlondellGa 2/1/2022
EileenTomk 2/1/2022
RamonaDahl 2/1/2022
SashaBeals 2/1/2022
TroyLightn 2/1/2022
PhillippBu 2/1/2022
LesterHida 2/1/2022
PansyHolm 2/1/2022
YukikoMitt 2/1/2022
Randall318 2/1/2022
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Fev 15
Anniversaire de Dany
Fev 19
Anniversaire de APPGirault123
Fev 23
anniversaire de windspirit
plus 244 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445