« 1 (2)


Re: Problème de halo "hachuré"
OverdOzed
Inscrit:
29/04/2007 19:11
De Nîmes...300 jours de soleil par an, inondations le reste du temps
Post(s): 3774
Chez moi j'ai un effet moiré d'autant plus désagréable (et fatiguant) qu'il est carrément clignotant
Ca semble donc venir du motif de tramage et pas de ton écran...

Contribution le : 24/03/2009 00:09
_________________
|C'est en forgeant qu'on devient forgeron, c'est en mouchant qu'on devient moucheron et c'est en sciant que Léonard devint scie.
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Blendie
Inscrit:
22/03/2009 20:15
Post(s): 29
Effectivement, il y'a aussi chez moi un moiré...

Par contre, je pense a ce que tu disais : dans ce cas, le fait d'enregistrer dans un format raw ou hdr (je crois que blender peut, mais c'est a confirmer hein, j'ai juste apercu une option hdr ) ne corrige pas le truc tout seul ?

Contribution le : 24/03/2009 08:06
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Fou Furieux du Clan
Inscrit:
19/08/2007 15:35
De Toulouse
Post(s): 136
Si tu avais un écran capable d'afficher les niveaux hdr oui. Mais je sais pas si ça existe... et si ça existe ça doit être hors de prix et introuvable. Le format hdr enregistre les couleurs avec beaucoup de niveaux, ça permet d'enregistrer une dynamique plus grande pour faire des trucs 'spéciaux' (global illumination par exemple). Mais au final l'écran n'est capable d'afficher que 256 niveaux de gris : changer le format d'image ne résoud rien puisqu'on est limité par le périphérique d'affichage.

Pour l'effet de clignotement je vais voir si on peut pas l'enlever en changeant le motif de tramage pour un truc plus aléatoire.

Contribution le : 24/03/2009 16:10
_________________
Lorsqu'on regarde un objet en se disant "la mod est nickel, par contre il faudrait revoir les shaders", on se rend compte qu'on a trop utilisé blender ... et que la réalité n'est pas toujours telle qu'on s'attend à la voir
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Blendie
Inscrit:
22/03/2009 20:15
Post(s): 29
Oki, merci pour tes explications et ton investissement :)

Contribution le : 24/03/2009 17:25
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Fou Furieux du Clan
Inscrit:
19/08/2007 15:35
De Toulouse
Post(s): 136
De rien, ces problèmes de dégradés sont un truc récurrent et ça m'énervait de pas avoir de solution. Maintenant il y en a une . J'ai changé les motifs de tramage, j'ai mis un truc plus aléatoire, l'effet de moiré/clignotement disparaît. Voilà :



Pour obtenir l'effet désiré, il faut jouer sur les valeurs des nodes dilate/erode (la valeur idéale étant en principe 1/4 de la largeur des bandes qu'on observe dans l'image originale).

Contribution le : 24/03/2009 19:08
_________________
Lorsqu'on regarde un objet en se disant "la mod est nickel, par contre il faudrait revoir les shaders", on se rend compte qu'on a trop utilisé blender ... et que la réalité n'est pas toujours telle qu'on s'attend à la voir
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Blendie
Inscrit:
22/03/2009 20:15
Post(s): 29
Yep, ca marche bien... Sauf sur l'image que je veux corriger
J'arrive pas (même en modifiant les valeurs de distance des differents noeuds dilate/erode) a lisser mon image...

J'ai fait un rendu du halo seul (c'est uniquement lui qui pose probleme), en transparence :


Si tu arrives a corriger ca... Moi j'y arrive pas du tout...


Histoire d'essayer differentes pistes, je vais peut être demander a des gimpeux si y'a pas moyen d'ameliorer l'image de cette facon. Parce que si c'est possible, il suffit de faire un rendu halo, de le passer dans gimp puis de le reutiliser pour le rendu final.

En tout cas, ton reseaux nodal, quand il marche (), il marche vachement bien

Contribution le : 24/03/2009 22:33
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Fou Furieux du Clan
Inscrit:
19/08/2007 15:35
De Toulouse
Post(s): 136
En mettant 3 pour les nodes Dilate/erode ça marche assez bien :



[edit] Ah zut j'avais pas vu ton image est plus grande que mes trames, en voulant faire à la bonne taille forcément ça marche pas (mais c'est pas un problème il suffit d'agrandir la taille des images qui servent de trame)

[edit2] Voilà j'ai agrandi les trames, maintenant la taille maximale de l'image c'est 4000*3000 pixels. En fait pour ton image, pour la partie en haut à gauche il faut mettre 5 pixels pour lesdilate/erode, mais pour le reste 3 c'est mieux. Alors si tu veux un truc clean, il faudrait enregistrer les deux images (celle avec 3 et celle avec 5) et les "mixer" avec the gimp pour ne garder que le meilleur des deux.

Pour le .blend désolé j'ai une connexion bridée je peux pas uploader des fichiers de plus de 2 méga, ce week-end je pourrais l'envoyer. Voilà l'image que ça donne :


Contribution le : 25/03/2009 09:17
_________________
Lorsqu'on regarde un objet en se disant "la mod est nickel, par contre il faudrait revoir les shaders", on se rend compte qu'on a trop utilisé blender ... et que la réalité n'est pas toujours telle qu'on s'attend à la voir
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Blendie
Inscrit:
22/03/2009 20:15
Post(s): 29
Whaou, ca marche \o/
Impressionant !
En effet, a la lumière de ce problème (trames trop petites), je pige mieux. C'est nikel alors, avec le .blend je vais enfin pouvoir corriger ce gros artefact (et pouvoir finir mon image a peine partisante )

Merci beaucoup pour ton aide, je resoud le sujet

Contribution le : 25/03/2009 18:57
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Fou Furieux du Clan
Inscrit:
19/08/2007 15:35
De Toulouse
Post(s): 136

Contribution le : 29/03/2009 10:10
_________________
Lorsqu'on regarde un objet en se disant "la mod est nickel, par contre il faudrait revoir les shaders", on se rend compte qu'on a trop utilisé blender ... et que la réalité n'est pas toujours telle qu'on s'attend à la voir
Créer un fichier PDF de la contribution Imprimer


Re: Problème de halo "hachuré"
Blendie
Inscrit:
22/03/2009 20:15
Post(s): 29
Merci, ca marche au poil !

Contribution le : 01/04/2009 18:22
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
« 1 (2)




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses [résolu] Transfer simulation cloth en boucle 4 228 Aujourd'hui 02:08:07
Thewada 
Hors Sujet !! Le mal des répondeurs du forum (nouzautr's) 4 85 Aujourd'hui 01:59:56
Thewada 
Questions & Réponses Graph editor: ne peut pas changer le handle type en free ? 8 125 Hier 22:15:05
PounchPounch 
Questions & Réponses [résolu] Pas d'ombre sur l'objet 8 120 Hier 19:37:11
Lylo 
Moteur de jeu GameBlender et alternatives [non résolu] Cs (vaisseau)    [1][2][3]...[57] 562 182668 Hier 19:16:42
sbkodama 
Questions & Réponses Séparer un script en plusieurs add-ons 2 66 Hier 18:11:49
Melodicpinpon 
Questions & Réponses Prb modélisation hache | mirror modifier 3 93 15/05 07:05:53
Rimpotche 
Questions & Réponses [non résolu] Blend4web et Blender version 2.80 ?    [1][2] 16 3094 14/05 09:50:34
blendinfos 
Questions & Réponses export 1000x trop petit 4 83 14/05 07:50:57
Redstar 
Questions & Réponses Je patine avec mon personnage 8 321 14/05 00:37:43
Lylo 
Questions & Réponses [résolu] rendre visible image as plane et wireframe 3 101 13/05 15:54:36
Rimpotche 
Hors Sujet !! FActualités : un petit journal humoristique    [1][2] 11 875 13/05 10:23:37
Redstar 
Graphisme alternatif Logiciel anatomie, bouger un écorcher ? 3 214 12/05 08:55:27
Redstar 
[WIP] et travaux terminés [terminé] Le bouï, mon ^premier moyen métrage, avec des FX et montage Blender :D 2 98553 12/05 06:42:07
Lylo 
Questions & Réponses [résolu] Rendu d'une image sans avoir de flou - cycle 4 258 11/05 10:50:27
Redstar 
Questions & Réponses Du masculin vers le féminin avec lattice 2 193 10/05 20:25:01
Melodicpinpon 
Hors Sujet !! Outils produtifs en animation avec Blender 3 - tutoriel de 15 mm 0 115 10/05 19:52:42
meltingman 
Questions & Réponses Carré gris lors du rendu 2.93 4 189 10/05 16:39:11
Rayden 
Hors Sujet !! Vos habitudes de programmation 5 275 09/05 17:45:04
Bibi09 
Questions & Réponses Solidify-Material offset-problem 2 183 08/05 20:21:19
Melodicpinpon 

Qui est en ligne
148 utilisateur(s) en ligne (dont 86 sur Forums)

Membre(s): 0
Invité(s): 148


plus...
Nouveaux membres
ClaraDarro 17/5/2022
KarlaHely 17/5/2022
ArronMerca 17/5/2022
BrianneBun 17/5/2022
ChloePickr 17/5/2022
RosePurser 17/5/2022
CerysMchen 16/5/2022
RudyStroth 16/5/2022
BernieceBi 16/5/2022
LorettaFun 16/5/2022
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Jui 30
Anniv des Jedi :-D
Jui 9
BUG de Lyon
Jui 23
Anniv du BlenderClan !
plus 238 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445