« 1 ... 38 39 40 (41) 42 43 44 ... 88 »


Re: Questions à mac, en vrac : Comment déplier avec exactitude un UV en vue Camera ?
OverdOzed
Inscrit:
27/07/2005 12:25
De ce petit pays neutre avec des montagnes et du chocolat
Post(s): 4018
Je viens de faire un essai que je trouve surprenant :
- J'ouvre la scène pas défaut, dans la version 2.63a
- Je vire le cube, je met Suzanne, je la tourne un peu
- Je fais un rendu
- Je vais dans les UV, j'ouvre l'image rendue juste avant
- Je place Suzanne en vue Camera, et je déplie en utilisant Unwrap from view

---> Résultat le dépliage est tout écrasé en X

Quelqu'au saurait-il m'expliquer ce particularisme scientifique ?

Contribution le : 27/07/2012 09:57
_________________
Sans difficulté il n'est point de progrès !
Créer un fichier PDF de la contribution Imprimer


Re: Questions à mac, en vrac : Comment déplier avec exactitude un UV en vue Camera ?
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
C'est parce que ton rendu a un ratio différent de 1:1.

Les coordonnées UV sont définies en pourcentages, pas en pixels. C'est ce qui leur permet de s'adapter à des images de taille quelconque. Par défaut si aucune image n'est spécifiée, ils sont affichés dans une zone carrée (de 256px par 256px, me demande pas pourquoi). Ils apparaissent donc écrasés si ils ont été dépliés depuis une caméra au ratio différent.

C'est donc simplement une histoire d'affichage : enregistre ton rendu sur le disque, ouvre le dans l'uveditor, tu verras que ça colle parfaitement

(Au passage, active la View Properties de l'UVeditor : en cochant/décochant Normalized, tu verras tes coordonnées en px ou en %)

Contribution le : 27/07/2012 13:27
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Questions à mac, en vrac : Comment déplier avec exactitude un UV en vue Camera ?
OverdOzed
Inscrit:
27/07/2005 12:25
De ce petit pays neutre avec des montagnes et du chocolat
Post(s): 4018
Citation :

_tibo_ a écrit:
C'est parce que ton rendu a un ratio différent de 1:1.

C'est donc simplement une histoire d'affichage : enregistre ton rendu sur le disque, ouvre le dans l'uveditor, tu verras que ça colle parfaitement

Euh, qu'est-ce qui colle à quoi ? Parce que cette description correspond à mon dernier test de ce matin, et ça ne colle pas du tout.
Mais je dirais que ça réagir selon ton explication précédente, donc je suis un peu embrouillé, du coup.

Cela dit, quand on fait un "Project from view" depuis une vue autre que la caméra,
les proportions du dépliage sont celle de la vue, et pas celle de l'image, non ?

Citation :

(Au passage, active la View Properties de l'UVeditor : en cochant/décochant Normalized, tu verras tes coordonnées en px ou en %)

J'essayerai ça, peut-être que ça peut m'aider.
Le plus étrange c'est que ce matin pendant le petit déj, j'ai refait la manip sur un autre Mesh, et j'ai obtenu
mon dépliage correct, sans savoir comment. Après quoi, plus moyen d'y parvenir.

Contribution le : 27/07/2012 13:48
_________________
Sans difficulté il n'est point de progrès !
Créer un fichier PDF de la contribution Imprimer


Re: Questions à mac, en vrac : Comment déplier avec exactitude un UV en vue Camera ?
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Ah je viens de réessayer en faisant précisément les étapes que tu décris en #401, j'obtiens bien un écrasement.

Par contre :
Citation :

- J'ouvre la scène pas défaut, dans la version 2.63a
- Je vire le cube, je met Suzanne, je la tourne un peu
- Je fais un rendu
- Je place Suzanne en vue Camera, et je déplie en utilisant Unwrap from view
- Je vais dans les UV, j'ouvre l'image rendue juste avant


Là ça marche. Par contre le pourquoi du comment ??

Contribution le : 27/07/2012 14:07
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Questions à mac, en vrac : Comment déplier avec exactitude un UV en vue Camera ?
OverdOzed
Inscrit:
27/07/2005 12:25
De ce petit pays neutre avec des montagnes et du chocolat
Post(s): 4018
Ben si, p'têtr.
Si tu fais le dépliage avant d'ouvrir l'image, il déplie (par défaut) avec un ratio d'image carrée,
et ensuite il étire lorsque tu ouvres la bonne image.
C'est probablement ce que j'ai fait ce matin quand ça a marché.
Mais ensuite dès que tu utilises une image, il déplie avec le ratio des proportions de cette image.
Là je ne peux pas tester tout de suite, mais si c'est ça, alors en mettant un UV Grid Map carrée pour effectuer
le dépliage, alors ça devrait re-fonctionner.

Contribution le : 27/07/2012 14:45
_________________
Sans difficulté il n'est point de progrès !
Créer un fichier PDF de la contribution Imprimer


Re: Questions à mac, en vrac : Comment déplier avec exactitude un UV en vue Camera ?
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
En effet ça parait logique

Citation :
alors en mettant un UV Grid Map carrée pour effectuer
le dépliage, alors ça devrait re-fonctionner.
Ou en ne mettant rien du tout, ça revient au même (c'est "l'image vide" de 256x256 dont je parlais plus haut)

Contribution le : 27/07/2012 15:51
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Questions à mac, en vrac : Comment déplier avec exactitude un UV en vue Camera ?
OverdOzed
Inscrit:
27/07/2005 12:25
De ce petit pays neutre avec des montagnes et du chocolat
Post(s): 4018
Je confirme, c'est bien ça.
Pour déplier les UV en vue caméra, et utiliser l'image de fond comme texture,
il faut d'abord faire un Project from View, sans image, ou avec une image carrée, et ENSUITE, utiliser l'image au bon format.

Soucis résolu, merci _tibo_.

Maintenant, je remonte la question de la pub Saab...
Je cherche dans quel numéro du Computer Arts est paru l'article sur le pub Saab de notre ami CoyHot,
dont il explique le principe ici :
http://coyhot.blogspot.ch/search?updated-max=2011-10-02T16:47:00-07:00&max-results=15

Contribution le : 28/07/2012 17:42
_________________
Sans difficulté il n'est point de progrès !
Créer un fichier PDF de la contribution Imprimer


Questions à mac, en vrac : animer un changement de calque est-il problématique ?
OverdOzed
Inscrit:
27/07/2005 12:25
De ce petit pays neutre avec des montagnes et du chocolat
Post(s): 4018
Je dirais : oui !
J'utilise la 2.63a, je fais une incrustation sur un caméra tracking.
A un moment donné, je dois faire disparaître un objet et en faire apparaître un autre à la place.
J'avais simplement mis des clés de positions, et ça fonctionnait très bien, jusqu'à ce que j'ajoute du Vector Blur.
Ben oui, mauvaise idée.
Alors, je me suis dit : il suffit d'animer le changement de calque pour amener l'objet sur un calque actif au moment
voulu, et hop, c'est réglé. Mais hop non, pas si facile. En fait l'objet qui disparaît a gardé ses clés de position.
Et l'objet qui apparaît change le calque sur lequel il se trouve (ce qui le fait donc apparaître).
Dans la vue 3D, ça fonctionne, mais au rendu, l'objet apparaît une Frame trop tôt, et du coup les deux objets sont
à la même place, et ça fait un rendu parasité avec des faces qui se chevauchent.
J'ai essayé avec cube dans une scène vide et je croyais d'abord que ça fonctionnait, pas pas tout à fait.
En fait si le cube est sur le calque 1 à la frame 1, j'insère une clé avec "I" sur les calques dans le panneau "Relations",
je passe à la Frame 2, de nouveau "I".
En animant (en avant) je constate que le cube est sur le calque 1 à la Frame 1, il est ensuite sur les calques 1 et 2 à la frame 2,
et seulement sur le calque 2 à la frame 3.
En animant (en arrière) je constate que le cube est sur le calque 2 à la Frame 3, il reste sur le calque 2 à la frame 2,
et il finit uniquement sur le calque 1 à la frame 1.

[edit]
La description ci-dessus est observable en animant avec les flèches gauches et droites.
Si on anime en déplaçant la barre dans la Timeline avec la souris, le changement de caque est correct.
Je sens le méchant bug, là, pas vous ?

C'est normal docteur ? En tout cas je ne vois rien de logique là-dedans pour l'instant.
Déjà, le comportement n'est pas le même en animant vers l'avant ou vers l'arrière, ça me parait douteux.

Contribution le : 01/08/2012 19:56
_________________
Sans difficulté il n'est point de progrès !
Créer un fichier PDF de la contribution Imprimer


Re: Questions à mac, en vrac : animer un changement de calque est-il problématique ?
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Salut Mc,

ça m'a tout l'air d'être un bug. Dans le Graph Editor, on voit qu'à la frame 2, les deux courbes sont hautes, ce qui n'a pas de sens normalement.

J'ai bricolé un truc en passant par un troisième calque, masqué, pendant la frame 2. C'est vaguement mieux. Par contre cette fois quand on lit en arrière ça bug





Personnellement je key le Restrict Renderability dans l'outliner, ça fonctionne très bien

Contribution le : 01/08/2012 20:30
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Questions à mac, en vrac : animer un changement de calque est-il problématique ?
OverdOzed
Inscrit:
01/11/2004 21:14
Post(s): 6567
Le vector blur est un effet de post-rendu.
Je penche donc plus pour le cas de figure non envisagé que pour le bug.
M'enfin, tu peux faire un rapport.

Contribution le : 01/08/2012 20:46
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
« 1 ... 38 39 40 (41) 42 43 44 ... 88 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses [physique] patte à modeler 0 5 Aujourd'hui 20:48:17
prometheusx 
[WIP] et travaux terminés [terminé] Imprimante à jet d'encre industrielle 8 2502 Aujourd'hui 20:06:34
dj3dim 
The Blender Clan 'tchat Blender 2.8x : Actus, tests, feedback..    [1][2][3]...[7] 66 37842 Aujourd'hui 19:10:37
lucky 
Questions & Réponses Particules qui tombent puis restent collées à la surface 3 52 Aujourd'hui 13:17:11
Bibi09 
[WIP] et travaux terminés [WIP] BUDY3000 prochain tuto spécial : modélisation semi mécanique 9 216 Aujourd'hui 11:04:13
Guiu 
Questions & Réponses Animation 2D débutant 5 79 Hier 20:18:23
moonboots 
Hors Sujet !! Tutoriels "Bonhomme de neige avec EEVEE" 6 92 Hier 19:34:23
Bibi09 
[WIP] et travaux terminés [WIP] Les wips à Chikin    [1][2] 11 2507 Hier 19:24:49
chikin 
Python & Plugins script python pour dupliquer un objet et fusionner le tout    [1][2] 14 258 Hier 18:15:17
neonclignote 
Questions & Réponses Je perds sans arrêts mes shaders! 9 83 Hier 16:59:53
titisteph 
Questions & Réponses [résolu] Compter les vertices 2 50 Hier 16:15:45
zeromeetsinfinity 
Questions & Réponses Bump map pixellisée    [1][2][3] 21 292 Hier 14:31:41
moonboots 
Questions & Réponses [WIP] Typo 3 136 Hier 12:15:26
moonboots 
Questions & Réponses [non résolu] Mettre du texte sur un sujet 3d    [1][2][3] 21 719 Hier 10:43:08
Lady 
Questions & Réponses Ajouter l'effet de deux shaders? 2 108 Hier 09:07:13
titisteph 
[WIP] et travaux terminés [terminé] Photogrammétrie : Meshroom ! 4 83 30/11 22:43:07
Bibi09 
Hors Sujet !! Tuto rapide - Tips Astuce - mixer des matériaux - créer un marécage 8 125 30/11 19:52:59
meltingman 
Questions & Réponses lampe chinoise effet de lumiere 5 81 30/11 16:24:16
prometheusx 
[WIP] et travaux terminés [WIP] Coming Home (Animation de Noël)    [1][2] 19 488 30/11 16:12:26
Bibi09 
Hors Sujet !! Tuto Tips - Faire des coutures dans Blender - fabriquer un pouf 0 45 30/11 14:59:06
meltingman 

Qui est en ligne
195 utilisateur(s) en ligne (dont 109 sur Forums)

Membre(s): 1
Invité(s): 194


prometheusx, plus...
Nouveaux membres
JennyPhare 2/12/2020
Terrence12 2/12/2020
FrancineTg 2/12/2020
OtiliaGold 2/12/2020
DianLoar77 2/12/2020
kerju2002 2/12/2020
bugsheep 29/11/2020
gto37 29/11/2020
Augustus_Strix 28/11/2020
yocodream 28/11/2020
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Dec 29
Anniversaire d'ebrain
Jan 9
BUG de Lyon
Fev 15
Anniversaire de Dany
plus 263 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445