Bug Cycles sur compilation perso 2.64 (Linux)
Fou Furieux du Clan
Inscrit:
29/10/2008 12:46
Post(s): 170
Bonjour,

Depuis quelques jours, je n'arrive plus à afficher les textures images avec Cycles. Que ce soit dans le viewport ou au rendu.

Dès que je demande image texture, mon cube devient violet et quelque soit l'image choisie rien ne change. Tout fonctionne avec des procédurales par exemple.

J'ai testé avec une version sur Graphicall et tout semble fonctionner. Le problème proviendrait donc de ma compilation.

Des dépendances ou librairies ont-elles récemment changées? Je ne trouve pas d'info sur le sujet.

Personne n'a ce problème?

Build r50974 sur Mint 13 64bits
Cudatoolkit 4.2.9 & NVidia drivers 304.43

Contribution le : 01/10/2012 09:53
_________________
Mon site: Vertex in Polygon
Créer un fichier PDF de la contribution Imprimer


Re: Bug Cycles sur compilation perso 2.64 (Linux)
OverdOzed
Inscrit:
01/11/2004 21:14
Post(s): 6567
J'ai été surpris aussi, la semaine dernière.
Je ne suis pas sûr mais il me semble que le responsable est le commit de mapping blended box qui a fait sauté le mapping automatique pour les images.
Utilises un noeud Texture Coordinate et ça devrait fonctionner.

Contribution le : 01/10/2012 10:38
Créer un fichier PDF de la contribution Imprimer


Re: Bug Cycles sur compilation perso 2.64 (Linux)
Fou Furieux du Clan
Inscrit:
29/10/2008 12:46
Post(s): 170
Salut Zeauro,

Merci pour ton aide, malheureusement j'ai bien le noeud Texture Coordinate. Il n'y a vraiment qu'avec ma compil que ça fait ça...

Après plusieurs tests, il s'avère qu'il n'y a qu'avec les jpeg que cela se produit.

Je viens de trouver la réponse ici:
http://projects.blender.org/tracker/index.php?func=detail&aid=31517&group_id=9&atid=498

C'est donc un bug connu. J'essaye de compiler OIIO et je vous dis si ça fonctionne.

Contribution le : 01/10/2012 13:42
_________________
Mon site: Vertex in Polygon
Créer un fichier PDF de la contribution Imprimer


Re: Bug Cycles sur compilation perso 2.64 (Linux)
Fou Furieux du Clan
Inscrit:
29/10/2008 12:46
Post(s): 170
Bon, c'était donc la solution: compiler soi-même OpenImageIO .

Les sources de librairies officielles semblent poser actuellement problème.

Contribution le : 01/10/2012 21:13
_________________
Mon site: Vertex in Polygon
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
[WIP] et travaux terminés [WIP] La pince à linge 6 91 Aujourd'hui 18:34:15
Rimpotche 
[WIP] et travaux terminés Pagani Zonda Barchetta 5 129 Aujourd'hui 18:25:59
ookka 
[WIP] et travaux terminés [WIP] La gabarre '' Le Gros Ventre''    [1][2][3]...[12] 112 22039 Aujourd'hui 17:57:26
Guiu 
The Blender Clan 'tchat W10 pour le prix d'une cacahuète    [1][2] 12 156 Aujourd'hui 15:07:19
lucky 
Questions & Réponses chemins suivant une déformation de surface 6 109 Aujourd'hui 12:26:50
meltingman 
Questions & Réponses Vitesse d'une vidéo 4 78 Hier 19:59:42
meltingman 
Questions & Réponses Texture et courbe de Bézier 3 55 Hier 19:50:15
meltingman 
Questions & Réponses Armature sans parenté? 1 47 Hier 19:38:25
meltingman 
The Blender Clan 'tchat Avenir du blender clan    [1][2][3]...[41] 405 48792 17/01 20:40:59
Rimpotche 
Questions & Réponses texture eyes avec empty 1 53 17/01 13:17:33
Rimpotche 
The Blender Clan 'tchat Progression dans Blender et la 3D    [1][2] 11 484 16/01 17:37:45
Rimpotche 
Questions & Réponses [terminé] Modificateur Mirror sur un Vertex Group 2 89 16/01 15:55:36
Horemheb 
Questions & Réponses Ma caméra me saoule... 5 221 15/01 20:33:23
Lylo 
Hors Sujet !! Appareil Photo Compact, qualité, zoom...    [1][2] 19 426 14/01 14:45:17
lucky 
Hors Sujet !! Tuto Astraonaute low-poly + rigify en 25mm 1 130 14/01 11:50:21
debutant 
Questions & Réponses [résolu] Comportement du parentage et du Weight Paint bizarres    [1][2] 14 87897 10/01 15:17:23
Horemheb 
Hors Sujet !! BONNE ANNEE LE BLENDER CLAN    [1][2] 10 386 10/01 13:34:18
Riggelm 
Questions & Réponses Limit location constraint-Affect transforms 4 181 09/01 14:33:38
Melodicpinpon 
Questions & Réponses Mon objet suit la courbe à 12 km...    [1][2] 10 554 08/01 01:37:51
Lylo 
Questions & Réponses Mauvais parentage en automatic weights    [1][2] 18 563 07/01 18:55:45
moonboots 

Qui est en ligne
253 utilisateur(s) en ligne (dont 108 sur Forums)

Membre(s): 3
Invité(s): 250


BrandiGsel, JonnaHartl, SZKEzekiel, plus...
Nouveaux membres
BlondellGa 2/1/2022
EileenTomk 2/1/2022
RamonaDahl 2/1/2022
SashaBeals 2/1/2022
TroyLightn 2/1/2022
PhillippBu 2/1/2022
LesterHida 2/1/2022
PansyHolm 2/1/2022
YukikoMitt 2/1/2022
Randall318 2/1/2022
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Fev 15
Anniversaire de Dany
Fev 19
Anniversaire de APPGirault123
Fev 23
anniversaire de windspirit
plus 244 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445