Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
11/11/2005 12:43
De quelque part dans le 57 :P
Post(s): 1674
Hello

Bah voilà, fallait bien que ça arrive. J'ai acheté une NVIDIA GTX 970 pour un de mes pc de rendu. L'OS actuel est Xubuntu 14.04 64 bits. Les installations des pilotes d'affichage et CUDA en manuel se sont bien passées (NVIDIA-Linux-x86_64-343.22.run et cuda_6.5.19_linux_64.run) et Blender 2.71 officielle et 2.72 rc1 reconnaissent bien ma carte mais lorsque je lance un rendu de la vue 3d j'obtiens ce message dans le terminal:

Compiling CUDA kernel ... "/usr/local/cuda/bin/nvcc" -arch=sm_52 -m64 --cubin "/home/jk/Documents/Blender2.72/2.72/scripts/addons/cycles/kernel/kernel.cu" -o "/home/jk/.config/blender/2.72/cache/cycles_kernel_sm52_9DA7CAD125EDEB0BDE16806F490958DF.cubin" --ptxas-options="-v" -I"/home/jk/Documents/Blender2.72/2.72/scripts/addons/cycles/kernel" -DNVCC -D__KERNEL_CUDA_VERSION__=65 /home/jk/Documents/Blender2.72/2.72/scripts/addons/cycles/kernel/kernel.cu:69:2: error: #error "Unknown or unsupported CUDA architecture, can't determine launch bounds" #error "Unknown or unsupported CUDA architecture, can't determine launch bounds" ^ /home/jk/Documents/Blender2.72/2.72/scripts/addons/cycles/kernel/kernel.cu:87:87: error: division by zero in #if #if CUDA_MULTIPRESSOR_MAX_REGISTERS/(CUDA_THREADS_BLOCK_WIDTH*CUDA_THREADS_BLOCK_WIDTH*CUDA_KERNEL_MAX_REGISTERS) > CUDA_MULTIPROCESSOR_MAX_BLOCKS ^ CUDA kernel compilation failed, see console for details. Refer to the Cycles GPU rendering documentation for possible solutions: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/GPU_Rendering

Une idée du problème?

Contribution le : 28/09/2014 15:22
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
06/07/2009 09:22
De Fraggle Rock
Post(s): 5782
j'allais te dire "t'as installé le dernier CUDA Toolkit?"
puis je suis allé sur la page de download https://developer.nvidia.com/cuda-downloads
et j'y vois ça: "If you are developing with CUDA 6.5 on a GeForce GTX980 or GTX970 download CUDA 6.5 Toolkits with support for your GPU here."
et quand on clique here y a les versions windows et linux mais pas de version OSX
edit: tellement l'habitude que tu sois sur OSX bon, ben en installant le CUDA toolkit 6.5 modifié pour ton gpu, ça devrait passer

Contribution le : 28/09/2014 15:57
_________________
ce n'est pas parce que l'on ne se comprend pas qu'il ne faut pas chercher à se faire entendre
Le chat du BUG
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
11/11/2005 12:43
De quelque part dans le 57 :P
Post(s): 1674
J'ai téléchargé la version depuis ce lien pourtant.

J'ai même testé avec les pilotes graphiques fourni dans ce .run (343.19) mais ça ne change rien.

Pour OSX, peut-être que les pilotes vont arriver (pour les anciens MAc Pro par exemple).

edit: le .run que j'ai téléchargé est bien celui pour les GTX 980/970.

Contribution le : 28/09/2014 16:04
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
06/07/2009 09:22
De Fraggle Rock
Post(s): 5782
oui, excuse je suis un peu dans le gaz ce dimanche...

t'as essayé de compiler?

avant, si le kernel CUDA n'était pas présent dans la compile de Blender, ça le compilait sous linux, mais c'est peut-être plus le cas, faut peut-être recompiler tout Blender

Contribution le : 28/09/2014 16:24
_________________
ce n'est pas parce que l'on ne se comprend pas qu'il ne faut pas chercher à se faire entendre
Le chat du BUG
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
01/11/2004 21:14
Post(s): 6567
C'est ça. Les versions officielles de Blender ne sont pas compilées pour ces cartes.

Dans un bugreport, Dingto indique que blender les supportera pour la 2.73. Mais la sortie de la 2.72 était trop proche lorsqu'elles sont sorties.

Cependant,il précise que renommer le fichier kernel_sm_50.cubin dans 2.72/scripts/addon/cycles/lib en kernel_sm_52.cubin devrait suffir.

Contribution le : 28/09/2014 16:34
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
11/11/2005 12:43
De quelque part dans le 57 :P
Post(s): 1674
Merci Zeauro et Edddy, c'était bien cette histoire de fichier à renommer. J'avais lu ça sur BA en plus, mais là avec mes galères d'install (trop de changements entre Xubuntu 13.10 et 14.04 à mon goût), ça m'était sorti de la tête.

Problème résolu mais je vais réinstaller Xubuntu 13.10 et tester depuis cette version.

Contribution le : 28/09/2014 16:42
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
The Blender Clan 'tchat OverdOzed 4 38 Aujourd'hui 00:54:45
meltingman 
Questions & Réponses "Transform" appliqué à plusieurs objets 5 54 Hier 20:18:53
moonboots 
Questions & Réponses [résolu] Entendre les sons dans le Layout 1 35 23/05 16:41:20
Horemheb 
The Blender Clan 'tchat Blender 2.8x : Actus, tests, feedback..    [1][2][3]...[10] 98 59424 22/05 12:03:20
Bibi09 
Questions & Réponses [résolu] Problème pour fermer 2 courbes nurbs 1 44 22/05 09:11:42
blendinfos 
Questions & Réponses rétrécir une face par rapport uniformément à son bord plutôt que par rapport à son centre. 9 19236 22/05 00:06:13
meltingman 
Questions & Réponses APPEL AUX VOLONTAIRES 1 132 21/05 17:09:19
Melodicpinpon 
Questions & Réponses Labels autour de l'objet 2 111 19/05 14:33:09
Redstar 
Questions & Réponses export 1000x trop petit 6 197 19/05 08:25:26
Redstar 
Hors Sujet !! FActualités : un petit journal humoristique    [1][2] 12 1090 18/05 02:06:25
meltingman 
Hors Sujet !! Le mal des répondeurs du forum (nouzautr's) 9 280 18/05 01:52:27
Thewada 
Moteur de jeu GameBlender et alternatives [non résolu] Cs (vaisseau)    [1][2][3]...[57] 565 183211 17/05 20:44:39
Redstar 
Questions & Réponses Séparer un script en plusieurs add-ons 3 173 17/05 13:10:08
Redstar 
Questions & Réponses Graph editor: ne peut pas changer le handle type en free ? 9 249 17/05 12:27:31
Redstar 
Questions & Réponses [résolu] Transfer simulation cloth en boucle 5 317 17/05 12:25:56
Redstar 
Questions & Réponses [résolu] Pas d'ombre sur l'objet 8 238 16/05 19:37:11
Lylo 
Questions & Réponses Prb modélisation hache | mirror modifier 3 176 15/05 07:05:53
Rimpotche 
Questions & Réponses [résolu] Blend4web et Blender version 2.80 ?    [1][2] 16 3245 14/05 09:50:34
blendinfos 
Questions & Réponses Je patine avec mon personnage 8 434 14/05 00:37:43
Lylo 
Questions & Réponses [résolu] rendre visible image as plane et wireframe 3 166 13/05 15:54:36
Rimpotche 

Qui est en ligne
142 utilisateur(s) en ligne (dont 88 sur Forums)

Membre(s): 0
Invité(s): 142


plus...
Nouveaux membres
JacquelynJ 25/5/2022
TinaNangle 24/5/2022
PerryStl83 24/5/2022
RandalDenn 24/5/2022
MichellSwe 24/5/2022
JodieMayga 24/5/2022
MosheShiel 24/5/2022
Vitony 24/5/2022
BetsyCoote 24/5/2022
IsiahBath3 24/5/2022
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Jui 30
Anniv des Jedi :-D
Jui 9
BUG de Lyon
Jui 23
Anniv du BlenderClan !
plus 238 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445