« 1 2 3 4 (5) 6 »


Re: problème d'ombre quand le jeu se lance
Fou Furieux du Clan
Inscrit:
24/08/2015 12:06
Post(s): 119
Ok. Donc j'arrive ca sur chaque élément ou jai un "mouseOver" ???
Parceque c'est ca qui fait ramer.

Quand je bouge pas la souris, tout est bien fluide. Par contre quand je bouge la souris et déclenche des événements "mouseOver" (sur mes fenêtres et portes), tout se met à ramer

Contribution le : 20/06/2016 13:15
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
OverdOzed
Inscrit:
19/03/2016 15:30
De Belgique
Post(s): 1615
Tu dois désactiver le pulse mode (icône "apostrophe") du sensors "always" qui est relié au script-module (ScriptPrincipal.eye). C'est le seul qui est actif.

Oui, en effet, ça fait ramer mais je peux pas t'expliquer pourquoi...

Quand je clique sur vue immersive, ça ne fonctionne pas chez moi.

Peux-tu mettre à nouveau ton blend (le plus récent) à disposition et me dire quelle version tu utilises svp ?

Contribution le : 20/06/2016 15:37
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
Fou Furieux du Clan
Inscrit:
24/08/2015 12:06
Post(s): 119
C'est le meme blend que je t'vais envoyé. Je n'ai pas bossé dessus ce week end.
J'utilise la version 2.77

Contribution le : 20/06/2016 17:19
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
OverdOzed
Inscrit:
19/03/2016 15:30
De Belgique
Post(s): 1615
Ok, j'ai trouvés quelques éléments de réponses:

D'abord, pour ton problème d'ombre, c'est le "sun", le responsable ou plutôt l'option "Frustum size" dans le sous-onglet lumière.

Je ne sais pas ce que c'est, je passe la main à un expert de la lumière.

Ensuite, pour ton problème de lag, c'est bel et bien tes portes et fenêtre et plus précisément les briques logiques (je les ais supprimé pour tester).

Et c'est pas tout !

J'ai remarqué que le process "logic" s'affole quand je place le curseur de la souris là où j'ai entouré, par exemple.

J'ai jamais vu un truc pareil !!!

Je pense vraiment que tu devrai mettre le blend à disposition des autres pour qu'ils puissent regarder car là, je sais plus quoi faire.

Contribution le : 21/06/2016 16:40
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
Fou Furieux du Clan
Inscrit:
28/08/2012 11:13
Post(s): 254
Tu devrais mettre ton "mouse over" sur un plan devant chaque portes et fenêtres, ça réglera tes problèmes . Le sensor mouse over consomme un max quand il y a trop de faces dans les objets.

Contribution le : 21/06/2016 17:26
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
Fou Furieux du Clan
Inscrit:
24/08/2015 12:06
Post(s): 119

Contribution le : 21/06/2016 17:52
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
Fou Furieux du Clan
Inscrit:
24/08/2015 12:06
Post(s): 119
si je place un plan avec mon mouseOver, ca déplacera le problème non ? J'en aurais tout autant ?

Contribution le : 22/06/2016 16:30
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
Fou Furieux du Clan
Inscrit:
07/04/2013 10:31
Post(s): 143
Salut ares,

La solution de tonycheuh devrait résoudre ton problème, car au plus que ton mesh est
lourd au plus que le mouse over consomme de la puissance.

j'ai fait un exemple pour te montrer:
http://www.pasteall.org/blend/42485

le cube de gauche a 100 000 faces et celui de droite en a que 6, quand tu passes ta
souris sur celui de gauche blender a avoir du mal et lagger, alors que sur celui de
droite blender va plus facilement traiter l'action.

Voilà j'espère que ça va répondre à ta problématique.

Contribution le : 22/06/2016 16:53
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
Fou Furieux du Clan
Inscrit:
24/08/2015 12:06
Post(s): 119
donc je peux par exemple faire un plan invisible parenté a ma porte avec les briques logiques dessus ? Ca permettrais d'éviter ce problème ?

Contribution le : 22/06/2016 17:03
Créer un fichier PDF de la contribution Imprimer


Re: problème d'ombre quand le jeu se lance
Fou Furieux du Clan
Inscrit:
07/04/2013 10:31
Post(s): 143
Le plan faudrait qu'il envoie un message à la porte plutôt qu'il soit parenté a la porte.

Blend d'exemple:

http://www.pasteall.org/blend/42486

La porte de gauche à un plan et non celle de droite il y a un léger lag quand on clique sur
la porte de droite.

Contribution le : 22/06/2016 17:21
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
« 1 2 3 4 (5) 6 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses en sculpt mode 5 101 Hier 18:21:10
prometheusx 
Questions & Réponses [résolu] Array circulaire 2 89 Hier 15:22:46
Redstar 
[WIP] et travaux terminés [WIP] Teeny Tiny - Story    [1][2][3]...[5] 40 3747 Hier 07:18:00
Bibi09 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Première version disponible !    [1][2][3]...[58] 576 97646 03/08 11:11:32
Hook 
Questions & Réponses Addon pour textures procedurales 2 99 02/08 20:11:35
Crocodile_13 
Questions & Réponses avis animation marche :)    [1][2][3][4] 34 554 02/08 20:03:14
prometheusx 
[WIP] et travaux terminés [terminé] court métrage 2020    [1][2] 13 782 02/08 15:28:29
flahaut 
Questions & Réponses [résolu] Générique, sous-titres etc 3 102 02/08 09:18:02
Corpia 
Questions & Réponses [résolu] Scène prend la couleur du fond    [1][2] 11 196 02/08 08:20:32
Arielboid 
Questions & Réponses [non résolu] Problele d'addon 0 74 02/08 01:52:30
nayther 
Questions & Réponses Addon pour textures procedurales 1 69 01/08 12:22:52
moonboots 
Questions & Réponses hair densité sélection de polys 9 205 30/07 23:18:21
lenogre 
Questions & Réponses [résolu] graph editor et location key frame 7 158 30/07 16:41:18
math_ 
Questions & Réponses les graphs editor :/ 4 149 30/07 11:19:07
prometheusx 
[WIP] et travaux terminés [WIP] Tutoriel vidéo et création de mon prochain court métrage 2 147 29/07 20:32:46
Bibi09 
Le coin des geeks pc bas prix    [1][2][3][4] 38 1744 28/07 21:14:56
Bibi09 
Questions & Réponses mesh pas assez smooth 3 179 28/07 15:10:12
Zear 
Questions & Réponses Clignotement de l'interface de blender 8 770 28/07 12:15:27
zezer 
Le coin des geeks carte graphique Intel(R) HD Graphics et OpenGL    [1][2][3][4] 31 2419 28/07 10:35:13
gedru 
Questions & Réponses Problème perso qui bouge des 2 côtés qu'avec 1 coté de l'armature et pas de l'autre    [1][2] 10 1434 27/07 19:14:45
Rimpotche 

Qui est en ligne
124 utilisateur(s) en ligne (dont 85 sur Forums)

Membre(s): 0
Invité(s): 124


plus...
Nouveaux membres
AjaA82583 5/8/2020
nayther 2/8/2020
math_ 30/7/2020

Meltingman2
29/7/2020
cloclaud 29/7/2020
fantalie 26/7/2020
lenogre 25/7/2020
Mr_Sim 23/7/2020
Bibouk 21/7/2020
WarMedik 19/7/2020
Dernier Ajout
mirages-preview~0.jpg

Evènements à venir
Aou 7
anniversaire Cem47
Aou 13
Anniversaire Siskas
Sep 8
Anniversaire de ang
plus 267 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445