(1) 2 »


Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Bonjour à tous :)

Je suis en train de créer l'animation d'un véhicule le long d'un chemin.

J'ai utilisé pour cela la contrainte "Follow Path", et un empty censé permettre la rotation des roues et l'arrêt du véhicule à certains points du chemin et de la timeline.

A mon véhicule, j'ai appliqué la contrainte "Follow Path" et un driver, l'empty sur l'axe Y.
A ce stade, mon véhicule suit la route.

Cela semble fonctionner, mais je rencontre un problème : Lorsque je "tire" l'empty sur Y, il entraine bien mon véhicule.
En revanche, lorsque je lance l'animation, le véhicule avance indépendamment de l'empty qui pourtant est son driver.
Je m'explique par un exemple : si je souhaite que mon véhicule ne démarre qu'à partir de la frame 200, je me positionne à 200 sur la timeline, et j'insère une keyframe 0 sur l'empty.
Ainsi celui-ci se repositionne à 0 et ne démarre pas avant la frame 200.
Le problème est que le véhicule démarre, lui, comme s'il était indépendant le l'empty.


Voilà, je suis bloqué sur ce point et j'aurais bien besoin d'un petit coup de main. Je suppose que j'oublie un paramètre mais je ne vois pas du tout où est mon problème

Je joins deux captures de mes réglages

Merci d'avance pour votre aide





Contribution le : 08/04/2019 08:08
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2824
Bonjour, Luc.

Je ne sais pas pourquoi tu as besoin d'un driver pour déplacer ton véhicule. Tu as peut-être tes raisons.

Tu pourrais déplacer ton véhicule directement avec une contrainte Follow Path. Tu te servirais du paramètre "Evaluation Time" de ton chemin pour mettre tes clefs d'animation.

Si tu veux faire ça avec un Empty, tu ferais la même chose que dit précédemment, et soit tu parenterais ton véhicule à l'Empty, soit tu appliquerais une contrainte "Copy Location" au véhicule avec l'Empty comme Target.

Pour l'Empty qui doit gérer la rotation des roues (sur elles-mêmes ou pour braquer ?) je ne comprends pas.

Si c'est pour que les roues tournent sur elles-mêmes en avançant, il suffit de mettre un driver sur les roues en "Average Value" vers ton chemin (Prop) et son Evaluation Time (en copiant le Data Block de celui-ci et en le collant dans la seconde case (Path) de ton Average Value. Après tu dois mettre un multiplicateur dans l'onglet Modifier de ton driver pour ajuster la quantité de rotation des roues.

Ensuite tu répètes l'opération pour chaque autre roue, ou plus simple tu leur colles une contrainte Copy Rotation.

En résumé, un Empty est inutile.

EDIT : Je t'ai mis un Blend simplifié sur PasteAll.

Contribution le : 08/04/2019 09:08
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci pour ta réponse Rimpotche :)

Pour répondre, cette animation est destinée à FSX. FSX n'accepte pas tous les modificateurs venant de Blender, d'après ce que j'ai compris au fil de mes recherches.

L'Empty, driver du véhicule ici sur Y, est une solution que j'ai trouvée, compatible, pour que les roues tournent sur elles-mêmes et proportionnellement à la vitesse de véhicule.

Je viens à l'instant de remplacer mon "path" par une "courbe de bézier" et tout fonctionne…. Un peu étrange mais peut-être est-ce normal ?

Il me reste à faire la rotation des roues avant sur Z (le braquage). Je peux la faire manuellement. Mais je cherche à la faire automatiquement. Avec ma méthode, ça n'a pas l'air évident.

J'ai envie quand même d'essayer d'applique la méthode que tu me donne

Contribution le : 08/04/2019 09:29
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci pour ta réponse Rimpotche :)

Pour répondre, cette animation est destinée à FSX. FSX n'accepte pas tous les modificateurs venant de Blender, d'après ce que j'ai compris au fil de mes recherches.

L'Empty, driver du véhicule ici sur Y, est une solution que j'ai trouvée, compatible, pour que les roues tournent sur elles-mêmes et proportionnellement à la vitesse de véhicule.

Je viens à l'instant de remplacer mon "path" par une "courbe de bézier" et tout fonctionne…. Un peu étrange mais peut-être est-ce normal ?

Il me reste à faire la rotation des roues avant sur Z (le braquage). Je peux la faire manuellement. Mais je cherche à la faire automatiquement. Avec ma méthode, ça n'a pas l'air évident.

J'ai envie quand même d'essayer d'applique la méthode que tu me donne

Contribution le : 08/04/2019 09:29
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2824
Regarde plus haut, pendant que tu me répondais, je t'ai mis un Blend dans mon précédent message, au cas où...

Contribution le : 08/04/2019 09:33
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2824
Je comprends mieux. Là, évidemmment, pour le braquage, tu pourrais mettre un Empty sur une copie du chemin, un poil en avance sur le véhicule et mettre un TrackTo (avec correction de l'angle) sur l'axe Z de tes roues avant.
Pourquoi une "copie" du chemin ? Parce que l'Evaluation Time ne sert qu'une fois et que celle du chemin 1 est déjà prise par le véhicule.

Contribution le : 08/04/2019 09:48
_________________
Des soucis, un SOUCI !
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Je regarde ton exemple. Le véhicule suit bien la courbe via l'empty mais son orientation est fixe (il ne pivote pas dans les virages).

Je dois, je pense, rajouter un paramètre.

Contribution le : 08/04/2019 10:30
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2824
Oui, j'avais fait au plus vite, et j'avais essayé comme toi de mettre un empty... inutile.
Alors voici un autre blend sans l'empty, et le vehicule tourne bien dans les virages.

Contribution le : 08/04/2019 12:54
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci :)
J'étais absent une partie de l'après midi, désolé pour le retard.

Je regarde ton fichier très vite

Contribution le : 08/04/2019 16:48
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Coucou :)

Impecable, ça semble fonctionner pour FSX.

Par contre, Mon animation est un véhicule assez long, un camion.
Tout va bien, mais dans les virages, l'arrière chasse vers l'extérieur. C'est normal, je pense du fait du point pivot. J'ai essayé de le déplaçer vers l'arrière du véhicule. Ca atténue un peu le problème, mais ce n'est pas encore ça.




Y a t-il un moyen pour que les axes arrière et avant soient tous deux "accrochés" à la courbe ? Comme dans la réalité, en fait

Contribution le : 11/04/2019 15:39
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Le coin des geeks Problème application android tablette 0 19 Aujourd'hui 10:19:01
Redstar 
Questions & Réponses Remplacer un objet par plusieurs autres 7 106 Hier 23:38:09
meltingman 
Questions & Réponses Configurer Blender pour plus de productivité (Version 2.5x)    [1][2][3] 28 45119 Hier 17:48:49
meltingman 
Questions & Réponses Bug de visualisation 3D 3 41 Hier 13:15:39
Melodicpinpon 
[WIP] et travaux terminés [résolu] Deplier une pièce 6 200 Hier 12:24:49
Redstar 
Questions & Réponses Combiner simple select et box select 2 88 Hier 12:16:51
Melodicpinpon 
Questions & Réponses [résolu] Rigid bodies répulsifs 4 72 Hier 07:02:01
Corpia 
Hors Sujet !! Tuto de la baleine, le retours :D - en français - Blender 2.93 9 570 Hier 02:34:23
meltingman 
Questions & Réponses [résolu] Objet qui disparaissent du ViewPort 5 79 11/04 14:35:45
Horemheb 
Questions & Réponses [résolu] Solidify non homogène dans une pièce 4 127 10/04 06:53:33
blendinfos 
Questions & Réponses Possible de changer plusieurs couleur d'un même objet avec export? 5 186 09/04 19:08:55
Bibi09 
Questions & Réponses Fonction 'Jump' en Fly mode rippe de côté 1 70 09/04 08:43:44
Melodicpinpon 
Questions & Réponses Raccourcis, préférences et thème 0 63 08/04 20:13:32
Melodicpinpon 
Questions & Réponses paint sous 2.79    [1][2] 11 465 08/04 17:54:08
moonboots 
Python & Plugins [WIP] Transportation Add-on pour Blender 9 2066 08/04 07:54:24
Nemo 
Questions & Réponses Comment verrouiller la longueur d'une courbe? 2 101 07/04 22:01:05
Melodicpinpon 
Python & Plugins Vegetation addon - tree, animation et plus ! 4 712 07/04 21:12:47
ferrari6 
Questions & Réponses [résolu] prolonger une NurbsPath par une ligne droite 2 89 07/04 15:59:05
Horemheb 
Questions & Réponses [non résolu] Problème de rendu de lumière 5 141 07/04 11:08:04
Bibi09 
[WIP] et travaux terminés [WIP] Mecha design - Iron Man Mountain Gorilla en Low Poly 7 198 06/04 15:40:48
moonboots 

Qui est en ligne
151 utilisateur(s) en ligne (dont 88 sur Forums)

Membre(s): 0
Invité(s): 151


plus...
Nouveaux membres

Nemo
11/3/2021
qingjie 10/3/2021
Kask909 9/3/2021
marie-antoinette 7/3/2021
Bugs 7/3/2021
lolorogli75 4/3/2021
Flagiel 4/3/2021
thedeathclown 1/3/2021
Littlespoon 28/2/2021
luxperpetua 27/2/2021
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Mai 18
Anniversaire Luneo
Jui 30
Anniv des Jedi :-D
Jui 10
BUG de Lyon
plus 256 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445