« 1 (2)


Re: Plus de son dans le séquenceur après avoir travaillé avec Audacity
Fou Furieux du Clan
Inscrit:
08/05/2007 05:28
Post(s): 129
J'avais déjà remarqué ce problème par hasard mais comme je n'utilise pas le séquenceur je ne m'en suis pas préoccupé. Par contre je ne savais pas que c'était en rapport avec Audacity.

J'ai l'impression que ça vient des bibliothèques OpenAl utilisées par Blender. Il faudrait aller voir sur le site officiel de blender.

J'ai arreté le serveur Pulseaudio mais toujours pas de son.

A mon avis le problème ne vient pas que du système, blender a aussi un bug car sinon comment expliquer que toutes les autre applications fonctionnent sans problème ?

PS Merci aux windoziens qui essaient quand même de donner un coup de pouce

Contribution le : 19/11/2008 04:02
_________________
back2analog is back.
Créer un fichier PDF de la contribution Imprimer


Re: Plus de son dans le séquenceur après avoir travaillé avec Audacity
OverdOzed
Inscrit:
02/09/2007 13:23
Post(s): 345
Merci pour l'aide.

J'ai essayé "sudo apt-get update" et je n'ai toujours pas de son dans le séquenceur.

Citation :
A mon avis le problème ne vient pas que du système, blender a aussi un bug car sinon comment expliquer que toutes les autre applications fonctionnent sans problème ?

Effectivement, c'est pas faux.

Sinon, j'avais essayer de trifouiller dans les préfèrences d'Audacity. Après avoir effectué quelques modifications, j'ai remarqué que je n'avais carrément plus de son dans tous les logiciels. Heureusement tous est revenu à la normale au bout d'un moment.
Par contre, toujours pas de son dans le séquenceur.

Contribution le : 19/11/2008 08:50
_________________
Mon blog
Créer un fichier PDF de la contribution Imprimer


Re: Plus de son dans le séquenceur après avoir travaillé avec Audacity
Ze Grand Manitou
Inscrit:
24/07/2003 14:50
De la Région Parisienne
Post(s): 21822
Audacity n'est pas compatible PulseAudio : http://www.pulseaudio.org/wiki/PerfectSetup#Audacity

Audacity

Audacity doesn't support PulseAudio, nor Esound for the moment. You'll have to kill or suspend pulseaudio before you use this application. Audacity uses the PortAudio cross-platform Audio API which doesnt support pulseaudio. Some work was started on making portaudio support PulseAudio but this does not appear to be under active development currently and does not work in it's current state.

Audacity can use OSS for sound input and sound output. By changing the 2 settings in preferences to /dev/dsp, and running audacity as

padsp audacity


you route OSS sound through pulseaudio and can have successful playback and recording with audacity. You could also set the sound input to be ALSA which (for regular users) is less likely to be blocked by another application, as recording with multiple applications at once is less commonly done

Using pasuspender to momentarily suspend pulseaudio is another way to use Audacity.

pasuspender -- audacity <argument>


@+

Contribution le : 19/11/2008 10:04
_________________

Mickaël Guédon | Site pro : www.mickaelguedon.com | Fondateur du Blender Clan : www.blenderclan.org
Auteur de Formations Blender chez Elephorm
Créer un fichier PDF de la contribution Imprimer


Re: Plus de son dans le séquenceur après avoir travaillé avec Audacity
OverdOzed
Inscrit:
02/09/2007 13:23
Post(s): 345
Bonsoir tous le monde !

Je viens de réinstaller Ubunutu, je me suis empressé de tester mon .blend et je constate avec grand malheur que le problème est persiste.

Voici ce que contient le fichier volume-restore dans le dossier .pulse :

pulsecore/protocol-native.c$ALSA plug-in [blender] 2 65536 65536 
alsa_output.pci_8086_3a3e_sound_card_0_alsa_playback_0  

pulsecore/protocol-native.c$ALSA plug-in [canberra-gtk-play] 2 65536 65536 
alsa_output.pci_8086_3a3e_sound_card_0_alsa_playback_0 

Contribution le : 20/11/2008 21:45
_________________
Mon blog
Créer un fichier PDF de la contribution Imprimer


Re: Plus de son dans le séquenceur après avoir travaillé avec Audacity
Ze Grand Manitou
Inscrit:
24/07/2003 14:50
De la Région Parisienne
Post(s): 21822
Citation :

SniperKing a écrit:
Je viens de réinstaller Ubunutu


Euh Linux c'est pas Windows, donc les réflexes du genre formatage ne sont clairement pas les bons.

As tu au moins lu ce que j'ai marqué plus haut ?
@+

Contribution le : 20/11/2008 22:16
_________________

Mickaël Guédon | Site pro : www.mickaelguedon.com | Fondateur du Blender Clan : www.blenderclan.org
Auteur de Formations Blender chez Elephorm
Créer un fichier PDF de la contribution Imprimer


Re: Plus de son dans le séquenceur après avoir travaillé avec Audacity
OverdOzed
Inscrit:
02/09/2007 13:23
Post(s): 345
Citation :
Euh Linux c'est pas Windows, donc les réflexes du genre formatage ne sont clairement pas les bons.

As tu au moins lu ce que j'ai marqué plus haut ?
@+

Pour le formatage, c'est effectivement ce que je constate.

Oui, j'ai lu ce que tu as marqué. Cependant, je débute avec Ubuntu et je suis très loin d'être bilingue. J'ai quand même essayé quelques petites choses mais sans résultats...

Contribution le : 20/11/2008 22:58
_________________
Mon blog
Créer un fichier PDF de la contribution Imprimer


Re: Plus de son dans le séquenceur après avoir travaillé avec Audacity
Ze Grand Manitou
Inscrit:
24/07/2003 14:50
De la Région Parisienne
Post(s): 21822
Pour faire court...

Tu lances Audacity, dans les préférences tu sélectionnes le module de sortie son sur OSS. Tu le fermes.

Maintenant à chaque fois que tu veux utiliser audacity, il te suffit de faire padsp audacity (en console).

@+

Contribution le : 20/11/2008 23:02
_________________

Mickaël Guédon | Site pro : www.mickaelguedon.com | Fondateur du Blender Clan : www.blenderclan.org
Auteur de Formations Blender chez Elephorm
Créer un fichier PDF de la contribution Imprimer


Re: Plus de son dans le séquenceur après avoir travaillé avec Audacity
OverdOzed
Inscrit:
02/09/2007 13:23
Post(s): 345
Merci beaucoup.

Je suis aller dans les préférences d'Audacity et "OSS:/dev/dsp" est déjà choisi par défaut.

Sinon quand je lance Audacity avec la commande "padsp audacity", la lecture de son ne semble pas toujours fonctionner (je suis la plupart du temps obliger de "forcer à quitter", j'ai l'impression que cela ce produit principalement quand j'ai lancé ou après avoir lancé le .blend contenant mon animation).

Et pour finir cela ne corrige pas le problème au niveau de séquenceur de Blender.

Contribution le : 20/11/2008 23:23
_________________
Mon blog
Créer un fichier PDF de la contribution Imprimer


Re:J'arrive à avoir du son dans le séquenceur après avoir lancé Youtube
OverdOzed
Inscrit:
02/09/2007 13:23
Post(s): 345
Bonjour !

En continuant mes recherches, je suis tomber sur la commande suivante :
SDL_AUDIODRIVER=alsa {chemin de blender}


Cependant impossible de la faire fonctionner :

luke@L:~$ SDL_AUDIODRIVER=alsa {/home/luke/Documents/Programmes/Blender/blender}
bash: {/home/luke/Documents/Programmes/Blender/blender}: Aucun fichier ou dossier de ce type
luke@L:~$ 


EDIT :

J'arrive à avoir du son dans le séquenceur en faisant plusieurs manipulations :

- j'ouvre Firefox et je lance la vidéo "la horde sauvage" sur Youtube (ça doit aussi le faire avec les autres vidéos ).
- ensuite, je lance Blender. Je constate que le son qui correspond à la musique de mon montage vidéo est toujours muet alors que les autres sons se jouent à merveille.
- j'efface donc le chemin du son qui ne fonctionne pas (dans Blender), je remet le même chemin, met cette fois le son fonctionne.

Je suis donc obligé de lancé Youtube pour avoir du son avec Blender.

Contribution le : 22/11/2008 11:29
_________________
Mon blog
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
« 1 (2)




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
The Blender Clan 'tchat ASSET POSE LIBRARIE - Nouvel outil de productivité -Tutoriel Blender 3 2 79 Aujourd'hui 03:07:07
meltingman 
Hors Sujet !! Synchro labiale facile - Lypsinc - Tutoriel Blender 3 4 67 Hier 20:36:00
debutant 
[WIP] et travaux terminés [WIP] Ma première sortie vidéo "regardable" 6 84 Hier 19:53:50
meltingman 
Questions & Réponses Vitesse d'une vidéo    [1][2] 12 345 Hier 18:45:01
Lylo 
Questions & Réponses Couleur dans le mode Solid du Viewport 0 34 Hier 18:15:22
Horemheb 
Questions & Réponses Montages dans Blender 4 109 27/01 22:01:14
meltingman 
Questions & Réponses [résolu] Matériau partiellement transparent    [1][2] 15 348 27/01 17:59:26
debutant 
Questions & Réponses Objets sur aucun 'View layer' 2 109 27/01 08:54:38
Melodicpinpon 
Concours Défi personnage - Crée un perso utilisable en animation (pour notre prochain challenge) 1 130623 26/01 14:48:03
meltingman 
Questions & Réponses freestyle lineset : ignorer un objet spécifique pour une arrête cachée    [1][2] 10 162621 26/01 13:03:54
sapajou 
Hors Sujet !! Le champilutin - tutoriel débutant - low polygone 1 112 26/01 01:45:59
meltingman 
Hors Sujet !! les tutos de Moonboots    [1][2][3]...[26] 257 30483 25/01 00:28:17
moonboots 
The Blender Clan 'tchat W10 pour le prix d'une cacahuète    [1][2][3] 23 726 22/01 17:29:47
Bibi09 
[WIP] et travaux terminés [WIP] La pince à linge    [1][2] 11 403 21/01 18:53:10
meltingman 
Hors Sujet !! Tuto Astraonaute low-poly + rigify en 25mm 3 273 21/01 14:47:47
meltingman 
Questions & Réponses Texture et courbe de Bézier 9 287 21/01 14:19:10
Horemheb 
[WIP] et travaux terminés Pagani Zonda Barchetta 6 303 20/01 09:03:37
moonboots 
[WIP] et travaux terminés [WIP] La gabarre '' Le Gros Ventre''    [1][2][3]...[12] 112 22455 19/01 17:57:26
Guiu 
Questions & Réponses chemins suivant une déformation de surface 6 253 19/01 12:26:50
meltingman 
Questions & Réponses Armature sans parenté? 1 140 18/01 19:38:25
meltingman 

Qui est en ligne
182 utilisateur(s) en ligne (dont 90 sur Forums)

Membre(s): 0
Invité(s): 182


plus...
Nouveaux membres
SteveBeebe 29/1/2022
ShonaOkeef 29/1/2022
MelissaWin 29/1/2022
IvaArndell 29/1/2022
MarjorieHu 29/1/2022
Gracie4074 29/1/2022
LeonardoVd 29/1/2022
JudsonCata 29/1/2022
AngieGreen 29/1/2022
AleciaMayn 29/1/2022
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Fev 15
Anniversaire de Dany
Fev 19
Anniversaire de APPGirault123
Fev 23
anniversaire de windspirit
plus 244 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445