« 1 ... 39 40 41 (42) 43 44 45 ... 48 »


Re: Cs (zones sol, héliport)
OverdOzed
Inscrit:
28/11/2008 09:55
De nantes
Post(s): 502
Bonjour, oui "normal map" en "tangent" est bien coché dans "image sampling".

Concernant l'eau je voudrais voir sa texture transparente, mais l'objet n'affiche qu'une couleur uni en glsl.

Contribution le : 13/07/2020 13:32
_________________
sbkodama-s.e.
Créer un fichier PDF de la contribution Imprimer


Re: Cs (zones sol, héliport)
OverdOzed
Inscrit:
19/03/2016 15:30
De Belgique
Post(s): 1689
Tu as le même problème si tu actives "aride nor" et "plage nor" (juste ces deux là) ?

Contribution le : 13/07/2020 14:14
Créer un fichier PDF de la contribution Imprimer


Re: Cs (zones sol, héliport)
OverdOzed
Inscrit:
28/11/2008 09:55
De nantes
Post(s): 502
Le même problème arrive peu importe quelle texture de normal est appliquée, elles prennent en compte le stencil placé au-dessus d'elles mais pas le stencil placé en dessous.

Contribution le : 13/07/2020 14:58
_________________
sbkodama-s.e.
Créer un fichier PDF de la contribution Imprimer


Re: Cs (zones sol, héliport)
OverdOzed
Inscrit:
19/03/2016 15:30
De Belgique
Post(s): 1689
D'accord. Je pense que tu dois inverser le sens.

Quand tu fais un masque, si tu as configuré la visibilité comme "noir", le noir du premier masque affichera ta seconde texture mais pas la zone blanche. Dans cette zone noire du premier, la zone noire du second masque affichera la 3e texture, etc.

Donc je pense que tu dois inverser le sens de sorte à ce que chaque texture soie visible.

Par exemple, si tu dis à Blender que la zone noire correspond à un chemin visible et que le blanc doit afficher la seconde texture, tu aura donc tout le loisir d'y afficher le reste dans cette zone là, du moment que tu suis la logique sur les autres masques.

C'est comme si tu dessinais un bout d'une carte au trésor sur 3 feuilles l'une derrière l'autre puis que tu les assembles pour avoir le tout.

Pour la texture de l'eau, essaie avec un autre format comme PNG ou DDS pour voir ?

Contribution le : 13/07/2020 15:20
Créer un fichier PDF de la contribution Imprimer


Re: Cs (stencil node, bug texture eau)
OverdOzed
Inscrit:
28/11/2008 09:55
De nantes
Post(s): 502
Bonjour, j'ai tenté d'inverser le blanc et noir et l'ordre mais le problème persiste, au final j'ai fouillé un peu le web et créé un matériau à base de node où le problème n'est pas présent.



Concernant l'eau j'ai tenté en format .png et regardé les réglages mais n'ai pas trouvé d'où vient le problème.
je joins un petit .blend comprenant deux lumières, une surface plane où est appliqué mon matériau eau, et ma texture d'eau packée. cs eau.blend

Contribution le : 14/07/2020 03:30
_________________
sbkodama-s.e.
Créer un fichier PDF de la contribution Imprimer


Re: Cs (stencil node, bug texture eau)
OverdOzed
Inscrit:
28/11/2008 09:55
De nantes
Post(s): 502
J'ai l'impression que l'édition de message bug, alors pardon pour le message en doublon.

J'ai corrigé un petit problème sur mon node, le premier "mix" était paramétré en mode "add" (qui donnait au bord son aspect trop clair) alors qu'il devait être paramétré en mode "mix" comme le deuxième.



Une petite capture d'une nouvelle sous-zone "telecom", placé où j'avais précédent la sous zone "héliport" qui à été déplacer au centre.


Contribution le : 14/07/2020 04:27
_________________
sbkodama-s.e.
Créer un fichier PDF de la contribution Imprimer


Re: Cs (stencil node, bug texture eau)
OverdOzed
Inscrit:
19/03/2016 15:30
De Belgique
Post(s): 1689
Oui, c'était la dernière possibilité que j'allais te proposer mais comme tu l'as trouvé...

Te te partage la configuration nodal que j'avais faite pour mon terrain. En gros, ça me permet de combiner plusieurs matériaux selon la nature du terrain.

C'est bon à savoir pour cette histoire de normal map que je n'avais pas découvert.

Alors, pour ton souci d'eau, une chose m'étonne, c'est qu'en mode solid, tu as la texture visible, mais pas en mode texture ni en mode material.Par contre, en ayant supprimé tes deux sources de lumière dans la scène 3D, il semble que tu aies ajouté une lumière artificielle, j'ignore comment tu as fais mais je ne trouve pas cette option.

J'ai pu remarqué ça dans le visuel du matériel, on est censé avoir un damier gris et gris foncé mais chez toi, on vois autre chose.

Contribution le : 14/07/2020 12:48
Créer un fichier PDF de la contribution Imprimer


Re: Cs (sous zone telecom, node stencil, bug texture d'eau)
OverdOzed
Inscrit:
28/11/2008 09:55
De nantes
Post(s): 502
J'ai trouvé un problème avec ma méthode de node pour le stencil, cinq mixes de "diffuse map" fonction bien mais quand je joint mon cinquième et dernier mix de "normal map" au normal du matériau l'objet devient invisible, je vais tenter ta méthode.

Concernant l'eau en effet je ne sais pas le problème, les dernières fois où j'avais tester de la transparence elle fonctionnait bien.
Chez moi l'objet devient noir lorsque je n'ai pas les deux lumières dans la fenêtre d'édition. Pour ce qui est du damier il apparait dans le visuel de la texture lorsque j'y active "image sampling" > "alpha : calculate", mais cela ne résout pas le problème.

Merci pour ton aide.

Contribution le : 14/07/2020 13:36
_________________
sbkodama-s.e.
Créer un fichier PDF de la contribution Imprimer


Re: Cs (sous zone telecom, node stencil, bug texture d'eau)
OverdOzed
Inscrit:
19/03/2016 15:30
De Belgique
Post(s): 1689
Je maintiens qu'il y a quelque chose qui ne va pas: pourquoi a-t-on ceci ?

C'est curieux.

Contribution le : 14/07/2020 15:46
Créer un fichier PDF de la contribution Imprimer


Re: Cs (sous zone telecom, node stencil, bug texture d'eau)
OverdOzed
Inscrit:
28/11/2008 09:55
De nantes
Post(s): 502
Alors de mon coté cela vient de mes réglages de diffuse et spéculaire, si je les réduit la lumière est beaucoup moins prononcé.

Sinon je me suis rappelé que j'avais certains matériaux transparent qui ne bugs pas alors j'en ai copié plusieurs fois un pour remplacer ceux qui bugs le problème semble réglé.

Contribution le : 14/07/2020 16:06
_________________
sbkodama-s.e.
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
« 1 ... 39 40 41 (42) 43 44 45 ... 48 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses [non résolu] Différence entre le viewport et le rendu dans une simulation de particule. 1 14 Aujourd'hui 18:53:01
lucky 
Questions & Réponses Problème de clic gauche poisseux dans nouveau Blender    [1][2] 10 381 Aujourd'hui 16:55:15
moonboots 
[WIP] et travaux terminés Animation Nodes & MIDI    [1][2] 10 2027 Aujourd'hui 15:51:09
WinZs 
Moteur de jeu GameBlender et alternatives Dulcis - Démo de RPG sur Unity    [1][2] 12 260 Aujourd'hui 12:51:47
meltingman 
[WIP] et travaux terminés [WIP] La gabarre '' Le Gros Ventre''    [1][2][3]...[5] 42 2984 Aujourd'hui 11:30:30
Guiu 
[WIP] et travaux terminés [WIP] Avion de combat    [1][2][3]...[9] 87 14872 Aujourd'hui 02:15:02
meltingman 
Questions & Réponses Texture des plastiques "Lego" 1 53 Hier 21:44:39
lucky 
Questions & Réponses Soucis dépliage UV 1 42 Hier 18:30:22
moonboots 
Hors Sujet !! Tuto débutant : un hippocampe - #1 le Maillage de base 0 35 Hier 15:51:07
meltingman 
Questions & Réponses Crash intempestif 2.91 4 59 Hier 15:13:32
lucky 
[WIP] et travaux terminés [WIP] Projet Darwin (nom temporaire)    [1][2][3]...[5] 40 7372 Hier 14:28:37
Bibi09 
Questions & Réponses congés    [1][2] 14 6376 14/01 01:28:11
meltingman 
Questions & Réponses [résolu] Copie sur DD externe corrompue 4 161 13/01 23:09:31
Carne 
Le coin des geeks Amd vs Nvidia    [1][2][3] 21 386 13/01 17:20:48
Lylo 
Questions & Réponses [résolu] faces qui disparaissent v2.91 1 77 13/01 16:26:05
skatekitchen 
Hors Sujet !! Booster sa créativité sur Blender - tuto de configuration 0 76 12/01 23:07:59
meltingman 
Questions & Réponses Dynamic paint 2 158 11/01 21:05:18
JaAlVir657 
Moteur de jeu GameBlender et alternatives [non résolu] Cs (vaisseau)    [1][2][3]...[48] 475 146974 11/01 19:16:24
sbkodama 
Questions & Réponses Forme inattendue sur Astronaute 9 381 11/01 13:18:45
Riz_Tah 
Questions & Réponses Blender n'utilise que 3% de ma carte graphique    [1][2] 18 463 10/01 19:50:02
lapineige 

Qui est en ligne
113 utilisateur(s) en ligne (dont 66 sur Forums)

Membre(s): 1
Invité(s): 112


ebrain, plus...
Nouveaux membres
MickeyWhis 16/1/2021
KassieGove 16/1/2021
AshleyThie 16/1/2021
NOCR3W 16/1/2021
SuperTrottoir 15/1/2021
Malok 13/1/2021
ludolerigolo 12/1/2021
Carne 12/1/2021
Nanook 12/1/2021
apax 8/1/2021
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Fev 15
Anniversaire de Dany
Fev 23
anniversaire de windspirit
Mar 14
Anniversaire de AMV12
plus 261 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445