« 1 2 (3) 4 5 6 7 »


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
OverdOzed
Inscrit:
08/11/2006 23:53
Post(s): 2453
je me permets un ptit up, car j'ai 2 soucis lorsque j'utilise le fichier :
- le 1er est lié à la caméra : lorsque l'on lance le jeu depuis un autre fichier (avec un actuator "game - start new game"), la caméra pose de soucis (elle semble inversée, ou quelque chose comme ça).
- lorsque je mets un spot pour des ombres en temps réel, les ombres bougent avec le personnage, alors qu'ils ne sont pas liés et que le spot est fixe.

Voilà, si tu as des solutions, je suis preneur

Contribution le : 22/02/2009 14:44
_________________
Blendman : 2D, 3D, Anim, dev
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
OverdOzed
Inscrit:
07/11/2008 19:38
Post(s): 874
Salut blendman,

1. Caméra
- J'ai créé un fichier test avec la scène de base de Blender.
- J'ai ajouté sur le cube un sensor keyboard 'Space', AND, Actuator Game New Game et nom de mon template.
J'ai ensuite enregistré ce fichier test dans le même répertoire que le template.
- Je suis passé en vue Caméra (0)
Il semble important d'être en mode caméra lorsque tu lances ton autre .blend.
Lorsque j'appuie sur Space ("loading"... patience), mon jeu se lance sans problème.

Essaie avec ce fichier .test en le plaçant dans ta scène.


2. Spot
Depuis que j'utilise le GE j'ai des pbs de carte graphique (X800) car après avoir lancé le template une fois j'ai de très nombreux bugs d'affichage. On dirait que les normales de tout un tas d'objets sont inversées.
J'ai donc du mal à m'en rendre compte, pour t'aider.
Il n'y a pas de paramètres particuliers concernant la lumière, as-tu supprimé le spot qui est parenté au mesh? Il se nomme "character_spot".

J'espère que ça aidera.

Contribution le : 22/02/2009 18:23
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
Fou Furieux du Clan
Inscrit:
10/01/2009 19:56
Post(s): 130
Hello cray

J'ai trouver un tuto pour le menu

wikipedia

en plus y'en n'a plein d'autre


a+

Contribution le : 22/02/2009 18:50
_________________
Bas, aucun signature

Dit donc, il a du culot ce petit!
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
OverdOzed
Inscrit:
08/11/2006 23:53
Post(s): 2453
Salut Cray
Citation :

cray a écrit:
1. Caméra
- J'ai créé un fichier test avec la scène de base de Blender.
- J'ai ajouté sur le cube un sensor keyboard 'Space', AND, Actuator Game New Game et nom de mon template.
J'ai ensuite enregistré ce fichier test dans le même répertoire que le template.
- Je suis passé en vue Caméra (0)
Il semble important d'être en mode caméra lorsque tu lances ton autre .blend.
Lorsque j'appuie sur Space ("loading"... patience), mon jeu se lance sans problème.

Essaie avec ce fichier .test en le plaçant dans ta scène.


je vais tester ça pour voir si ça fonctionne correctement chez moi (faut dire que j'ai fait pas mal de modif sur le fichier de base (le template ). Donc, ça se trouve, j'ai mis la pagaille .


Citation :
2. Spot
Il n'y a pas de paramètres particuliers concernant la lumière, as-tu supprimé le spot qui est parenté au mesh? Il se nomme "character_spot".

C'était effectivement ça, je ne le croyais pas parenté, alors qu'il était parenté au personnage effectivement.
Du coup, c'est nickel.

Par contre, j'ai un autre soucis, mais rien à voir avec ce fichier.

Voilà, j'utilise un 2D filter "bloom", qui fonctionne hyper vite.
Mais lorsque que j'ajoute une scène en overlay (pour un menu par exemple), ça double l'effet du bloom (et si je lance plusieurs menus, soit plsueirs scène en overlay, ça ajoute à chauqe fois une couche de bloom).

Bon, le fps reste identique, car le script est pas mal fait, mais je ne trouve pas la parade à moins de ne pas utiliser la méthode des multi-scènes :
voilà une vidéo qui montre le test que j'ai fait et le problème avec le "bloom" (à la fin) :
http://vimeo.com/3324494


Contribution le : 22/02/2009 22:02
_________________
Blendman : 2D, 3D, Anim, dev
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
OverdOzed
Inscrit:
07/11/2008 19:38
Post(s): 874
Tiens moi au courant pour le test.blend

Concernant le problème de filtre, il semblerait donc qu'il soit actif sur chaque scène affichée?
Je ne sais pas comment fonctionne le filtre/script dont tu parles, si son effet peut être isolé pour être actif sur une seule scène.

Même si je ne pense pas encore être capable de faire cela, je veux bien jeter un oeil à ce script.

Et merci pour le lien, Soul-link :)

Contribution le : 22/02/2009 23:59
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
OverdOzed
Inscrit:
08/11/2006 23:53
Post(s): 2453
Citation :

cray a écrit:
Tiens moi au courant pour le test.blend
oui, pas de soucis, je le teste dès que possible

Citation :
Concernant le problème de filtre, il semblerait donc qu'il soit actif sur chaque scène affichée?
Je ne sais pas comment fonctionne le filtre/script dont tu parles, si son effet peut être isolé pour être actif sur une seule scène.
je croyais qu'il n'était affiché qu'une fois mais visiblement, il s'affiche sur chaque scène et l'effet s'additionne pas glup .

Citation :
Même si je ne pense pas encore être capable de faire cela, je veux bien jeter un oeil à ce script.

tu trouveras le script ici :
http://myheroics.wordpress.com/2008/09/04/glsl-bloom-shader/

Il suffit de le mettre sur un actuator 2D filter (custom) et de lié à un script python (copier-coller du code de la page web du dessus).

un autre problème du "bloom", il pixelise l'image je trouve, mais ce doit être lié au script, je pense.

Contribution le : 23/02/2009 00:38
_________________
Blendman : 2D, 3D, Anim, dev
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
OverdOzed
Inscrit:
07/11/2008 19:38
Post(s): 874
J'ai essayé mais la console me renvoie l'erreur.

2dFilters - Shader program link error


Pourrais-tu me faire une scène basique (le cube à l'ouverture du Blender) avec le filtre, que je vérifie si j'ai toujours un erreur dans la console, ce qui signifierait peut-être une erreur de configuration de mon petit Blender?

Contribution le : 23/02/2009 01:36
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
OverdOzed
Inscrit:
08/11/2006 23:53
Post(s): 2453
Citation :

cray a écrit:
J'ai essayé mais la console me renvoie l'erreur.

2dFilters - Shader program link error


Pourrais-tu me faire une scène basique (le cube à l'ouverture du Blender) avec le filtre, que je vérifie si j'ai toujours un erreur dans la console, ce qui signifierait peut-être une erreur de configuration de mon petit Blender?


et hop, voilà le fichier :
http://blendman.free.fr/blender/files/bloom.blend

Il faut bien sûr que ta carte gère les GLSL shaders

Contribution le : 23/02/2009 14:45
_________________
Blendman : 2D, 3D, Anim, dev
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
OverdOzed
Inscrit:
07/11/2008 19:38
Post(s): 874
2dFilters - Shader program link error

Bon, ma carte ne gère pas les GLSL shaders, c'est officiel -_;

Déjà que je dois redémarrer tous les trois lancements parce que tout l'affichage de la scène disparait, ça fait beaucoup.
J'ai une Ati Radeon X800Gto installée, et je viens de récupérer une nvidia6600GT.
Aurais-je une grosse perte de performances si je passe de l'une à l'autre (en espérant que la nvidia gère les glsl)?
Je suis largué côté matériel...

Contribution le : 23/02/2009 19:03
Créer un fichier PDF de la contribution Imprimer


Re: [Update] Template - Jeu d'aventure à la 3ème personne (Zelda)
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
La 6600 GT gère les GLSL. Par contre je ne peux pas t'aider concernant la différence de performances... Il faudrait chercher un site avec les résultats des benchmark pour chacune des cartes.

Contribution le : 23/02/2009 19:53
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
« 1 2 (3) 4 5 6 7 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Hors Sujet !! Tuto rapide - Tips Astuce - mixer des matériaux - créer un marécage 0 8 Aujourd'hui 00:14:43
meltingman 
Mes premières images sous Blender (débutants) Quitter l'affichage touche Z 7 79 Aujourd'hui 00:02:48
meltingman 
Questions & Réponses [non résolu] Bug de rendu evee et material preview de cycles 2 18 Hier 23:30:54
bugsheep 
Questions & Réponses Récupérer un vieux fichier dans Blender 2.90    [1][2] 12 408 Hier 23:29:19
meltingman 
Hors Sujet !! Animation "S'abonner" pour YouTube 1 26 Hier 23:23:24
meltingman 
Mes premières images sous Blender (débutants) serpent 6 81 Hier 23:16:11
meltingman 
Questions & Réponses [résolu] Débutant sur les découpes des objets avec Blender 2.79    [1][2] 13 158 Hier 21:18:27
yocodream 
Questions & Réponses affichage décalé de la fumée (quick smoke) 1 22 Hier 19:32:03
gto37 
Questions & Réponses Configuration scroller et pan dans Blender 2.91 6 92 Hier 18:08:28
Rimpotche 
Moteur de jeu GameBlender et alternatives [WIP] Jeu "Iron Man Collapsing"    [1][2][3][4] 31 13403 Hier 15:16:40
timeman13 
[WIP] et travaux terminés [WIP] Coming Home (Animation de Noël)    [1][2] 15 385 28/11 23:41:51
Bibi09 
Questions & Réponses Aperçu des polices "qui clignotent" 2 80 28/11 08:56:23
Kristof_LEDRU 
[WIP] et travaux terminés [WIP] BUDY3000 prochain tuto spécial : modélisation semi mécanique 6 157 27/11 22:14:47
Laorz 
[WIP] et travaux terminés [WIP] TUTO Spécial Textures ! BOB et Gary :D 5 258 27/11 20:19:31
Bibi09 
Hors Sujet !! Tutoriel - Rigify - adapter Rigify à un personnage Cartoon (Bob l'éponge) 0 69 27/11 18:25:56
meltingman 
Questions & Réponses SSolidifier 5 83 27/11 18:19:55
rduvrac 
Questions & Réponses Bump map pixellisée    [1][2] 12 151 27/11 18:08:02
moonboots 
Questions & Réponses Je n'arrive pas a coller les membres de mes personnages sur l'armature    [1][2] 19 216 27/11 17:52:35
Lylo 
Questions & Réponses Scanner 3d et blender 2 96 27/11 17:37:28
Pandore62 
Questions & Réponses Ajouter l'effet de deux shaders? 1 62 27/11 17:28:02
moonboots 

Qui est en ligne
86 utilisateur(s) en ligne (dont 56 sur Forums)

Membre(s): 2
Invité(s): 84


EdwinHerma, Lorena9965, plus...
Nouveaux membres
Michelle93 30/11/2020
AvisLuncef 30/11/2020
SaundraNdj 30/11/2020
YettaE3453 30/11/2020
LDUTrina54 30/11/2020
DeborahCor 30/11/2020
WendiFilso 30/11/2020
SashaThurs 30/11/2020
EdwinHerma 30/11/2020
RenaShick0 30/11/2020
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Dec 29
Anniversaire d'ebrain
Jan 9
BUG de Lyon
Fev 15
Anniversaire de Dany
plus 263 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445