Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
AirplaneCompany.jpg
Publicité
Formation Blender ElephormBlender 3d Elephorm


     




(1) 2 3 4 ... 7 »


Blender digère mal les grosses textures ?
Ogre Baveur et Puant
Inscrit:
25/07/2003 15:26
De CORSICA
Post(s): 5836
Salut les enfants !

Voilà le probleme du jour...
J'ai une énorme texture à plaquer (une def satellite)... L'image jpeg faisait originellement 35 Mo... Rien à faire, blender plantait dès lors même que je chargeait l'image dans l'onglet texture... Fermeture intempestive de blender sans alerte, sans message d'erreur, rien... Bouf, fermeture quoi.
J'ai compressé mon jpeg et ai réussi à le descendre à 17 Megs... En dessous ca commence à devenir un peu crading...
A 17 Mo, l'image se charge correctement dans l'onglet texture... C'est quand vient le rendu que blender se ferme...
Bon la scène est très lourde en textures je le reconnais... En tout (avec la def à 17 Mo) yen a pour 29 Mo de textures pour le rendu...
Je me suis téléchargé la dernière version stable en date (la 249b, comme la 250 étant toujours en alpha) et le résultat est strictement le même...
La scène n'est pas très lourde en polys, le rendu ne fait que 2k x 1k px... Jpige pas trop...

Des problemes de ce genre connus chez vous et éventuellement des solutions qui vont avec ? ca me ferai assez chier de monter encore le niveau de compression du jpeg pour faire tomber le poids encore.

Merci les zamis.
Nx.

Contribution le : 30/12/2009 16:27
_________________
Blenderhead since 1998 !
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
OverdOzed
Inscrit:
11/11/2007 10:33
Post(s): 1749
j'avoue que j'ai jamais tenté de faire des rendus avec des textures supérieurs à 4000*4000 donc je sais pas trop

A la limite se serait aps plutot possible de couper ton image en plusieurs bouts et de bidouiller comme ça ?

Contribution le : 30/12/2009 16:36
_________________
La Tortue se meut !
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
Ogre Baveur et Puant
Inscrit:
25/07/2003 15:26
De CORSICA
Post(s): 5836
Citation :

everwind a écrit:
j'avoue que j'ai jamais tenté de faire des rendus avec des textures supérieurs à 4000*4000 donc je sais pas trop


Oé je venais rajouter des précisions, la texture cote 21 600*10 8000... C'est ptet pas tant le poids de l'image mais sa taille en fait qui generait blender, yo no sé...

Citation :

A la limite se serait aps plutot possible de couper ton image en plusieurs bouts et de bidouiller comme ça ?


Là ça risque d'être assez chiant à mettre en oeuvre quand même, j'y avais pensé mais y ai renoncé quelques minutes après reflexion

@ plouche
Nx.

Contribution le : 30/12/2009 16:40
_________________
Blenderhead since 1998 !
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11299
Salut Nx !

Et éventuellement, en utilisant un node Texture et un node MapUV ? Je ne sais pas si ça change grand chose, mais ça vaut peut être le coup d'essayer...

Ou bien avec un autre format que le jpeg ?

Contribution le : 30/12/2009 16:44
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
Fou Furieux du Clan
Inscrit:
19/06/2005 20:40
Post(s): 207
pourquoi t'as besoin d'une si grosse image? c'est une texture de quoi?

Contribution le : 30/12/2009 16:45
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
OverdOzed
Inscrit:
11/11/2007 10:33
Post(s): 1749
une texture de machin prise par satellite et je suppose qu'il en a besoin parce qu'il doit y avoir un gros zoom/dezoom, enfin un truc dans le genre je suppose (ou alors il a décidé de faire une affiche de cine en 300dpi)

Moi je pencherais plus pour un problème de définition que de taille de l'image, en fait blender doit avoir un mal fou a attribuer à chaque point une correspondance en pixel à la texture (si vous voyez ce que je veux dire). Donc à priori en découpant ça devrait passer mais euh ça doit etre assez horrible à faire j'imagine .

Après ça dépend de la structure sur laquelle tu dois la mettre, si c'est sur une spère ça va etre chaud de découper, mais si c'est un plan ou un truc un peu similaire tu as des log pour découper une image facielement, il reste plus qu'à recoller

Contribution le : 30/12/2009 16:58
_________________
La Tortue se meut !
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
Ogre Baveur et Puant
Inscrit:
25/07/2003 15:26
De CORSICA
Post(s): 5836
[-- Tain jviens d'avoir une grosse coucouille avec le BC, jpouvais plus repondre, ni poster, ni meme me reconnecter... --]

Salut Tibo !

Ca peut parraitre con mais, en tout grand fan et abuseur des nodes que je suis (pour certain trucs de quoi faire palir les post-prodeurs de chez ilm ) j'ai jamais utilisé les nodes de material et je sais pas comment ils marchent...
Mais bon beh comme c'est pour le boulot beh jvais m'y pencher...

Sinon c'est effectivement un problème de taille et pas de poids... Je viens de retrecir l'image de moitié en la passant donc à 10800 pix de long et ca marche impecc...

Sinon everwind, et ué c'est sur une sphère et j'ai besoin que toute la surface soit nickel chrome c'est pour une animation...

D'ailleur sur ce taff j'en ai chié avec les étoiles (blender plantait encore)... La scène est gigantesque dans la viewport et je peux pas fixer les étoiles assez loin pour un bon rendu... Une skymap sur une scène de cette taille c'est impensable (en fait c'est même impossible), et compte tenu des effets d'atmosphère, le compositing s'est révélé ne pas être une très bonne alternative... J'ai donc dû faire 3 fois la même scène à 3 échelles différentes pour 3 plans différents histoire d'avoir de belles étoiles (nan sérieux bien reglées, les étoiles de blendouilles sont au top !)...

Tu imagines donc mes hérissements de poils à l'idée de devoir en plus découper la Terre en 16 morceaux de textures....

Je vais donc me tourner du coté des nodes de materials comme me l'a conseillé Tibo et on vera... Au pire je trouverai bien un subterfuge... Mais ca m'emmerde quand même...

Ya une liste officielle des "limitations" en tout genre de blender quelquepart ?

@ plouche
Nx.

Contribution le : 30/12/2009 17:21
_________________
Blenderhead since 1998 !
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
OverdOzed
Inscrit:
11/11/2007 10:33
Post(s): 1749
hum la il suffit de couper l'image en 4 (ça se fait en 10s ça) et d'appliquer, ça va encore (si tant est que ça marche ). Tu fais un matériau pour 1/4 de sphère et tu fais ton UV en conséquence (ce qui n'est pas si difficile il me semble ?

je l'ai déjà fait (je sais plus pourquoi d'ailleurs), et pour 4 franchement ça passe comme dans du beurre (si c'est une phère sphérique evidemment )

Encore ça aurait été 8 la je dis pas, mais 4 c'est du gateau

Je pense que tu vois comment faire mais sinon jpeux te fair eun blend d'exemple sur une sphère basique

Contribution le : 30/12/2009 17:30
_________________
La Tortue se meut !
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
OverdOzed
Inscrit:
27/01/2007 21:23
Post(s): 930
Juste une petite question : est tu en 64bits et sous quel système ? Que dit la console ? (pour éviter que la console se ferme lorsque Blender plante, il suffit de lancer Blender par sa commande directement dans la console - du moins sous Linux). Vue la taille de ta texture (résolution), il se peut qu'un système 32bits ne sois pas en capacité de l'importer...

Autre solution, tente de convertir cette texture en TGA... tu vas exploser au niveau poid de la texture, mais l'intérêt est que Blender ne devra pas gérer la compression/décompression du jpeg. Il pourra la prendre direct en brut.

Contribution le : 30/12/2009 17:32
Créer un fichier PDF de la contribution Imprimer


Re: Blender digère mal les grosses textures ?
OverdOzed
Inscrit:
11/11/2007 10:33
Post(s): 1749
oui enfin je pense pas que le problème soit l'image elle meme ou sa décompression, j'imagine plutot un problème au niveau de l'application de la texture.

Après comme je connais aps trop le mode de fonctionnement du moteur de rendu je sais pas si ma solution marcherait ou si le problème serait le meme mais ça vaut le coup d'essayer vu la simplicité de la chose :-p

Contribution le : 30/12/2009 17:38
_________________
La Tortue se meut !
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 3 4 ... 7 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Blender 2.80 ne démarre pas 4 41 Aujourd'hui 07:06:40
touvenant 
Questions & Réponses [non résolu] Comportement 2.8    [1][2] 15 571 Hier 22:01:32
blendinfos 
Questions & Réponses Selection d'images pour le VSE 5 203 Hier 17:13:09
FoxRock 
Questions & Réponses Conseils pour la modélisation du visage 2 102 Hier 16:22:42
moonboots 
Questions & Réponses [résolu] Conseil pour une topologie 8 215 Hier 12:19:21
blendinfos 
Questions & Réponses Fusionner faces périphériques ? 7 99 Hier 11:33:20
Guppy88 
Questions & Réponses [non résolu] Blend4web : exporter les textures 2 111 Hier 08:43:17
blendinfos 
Questions & Réponses [résolu] Comment flouter uniquement le premier plan ? 4 93 20/09 19:43:35
Anton78 
Questions & Réponses [non résolu] Lignes de coupure sur UV    [1][2] 13 189 20/09 09:06:49
stigmamax 
Hors Sujet !! Présentation pour tous    [1][2][3]...[99] 982 247656 20/09 06:46:17
paquetdemouchoirs 
Questions & Réponses [résolu] MIDI to Blender 5 168 19/09 17:47:18
docouatzat 
The Blender Clan 'tchat La Bible des tutos Blender – Une Séléction de 150 Tutos Blender *en anglais 2 135 18/09 14:34:05
Gilead_Maerlyn 
Questions & Réponses [résolu] Blender lumière 3 158 18/09 09:06:47
moonboots 
Questions & Réponses Tableau d'objets déformés aléatoirement 4 181 17/09 21:11:22
creepclem 
Questions & Réponses [résolu] Problème de Sculpt 2 145 17/09 05:31:23
MHB29 
Questions & Réponses [résolu] Epaisseur non constante avec Solidify - Murs 2 150 16/09 14:36:42
HarDrive 
Questions & Réponses [non résolu] Array : duplication circulaire 2 132 16/09 06:04:40
blendinfos 
Questions & Réponses preferences utilisateur ne s'ouvrent plus 0 180 14/09 15:39:23
masje 
Questions & Réponses [résolu] Problème avec la symétrie    [1][2] 12 409 14/09 10:30:13
GFC 
Questions & Réponses galère d'importation SVG 5 269 14/09 08:42:16
Guppy88 

Qui est en ligne
60 utilisateur(s) en ligne (dont 41 sur Forums)

Membre(s): 0
Invité(s): 60


plus...
Nouveaux membres
DanaeEbers 22/9/2019
OfeliaKoer 22/9/2019
Daniel0233 22/9/2019
Holly72489 22/9/2019
Leia734671 22/9/2019
WillardPri 22/9/2019
VernonHolt 22/9/2019
VeroniqueM 22/9/2019
ClarissaRo 22/9/2019
OscarMatti 22/9/2019
Dernier Ajout
Forky-3D-ToyStory BC.png

Evènements à venir
Nov 18
Anniversaire de RichDeg
Dec 29
Anniversaire d'ebrain
Jan 11
BUG de Lyon
plus 278 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2019 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445