« 1 (2)


Re: LibLoad, impossible de jouer les Actions importées
OverdOzed
Inscrit:
19/01/2008 03:25
De tu voit le nuage sur la carte météo bin j'habite là
Post(s): 2554
j'ai lu en diagonale ton code et pour les chemins c'est plus performant d'utiliser os que bpy


os.chdir(monChemin)

Contribution le : 17/07/2015 17:39
Créer un fichier PDF de la contribution Imprimer


Re: LibLoad, impossible de jouer les Actions importées
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Merci pour l'info, je ne le savais pas. De toute façon on a viré bpy entre temps (pas pour des raisons de perfs, mais parce qu'il ne semble pas fonctionner en runtime).

Contribution le : 17/07/2015 18:24
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: LibLoad, impossible de jouer les Actions importées
OverdOzed
Inscrit:
21/08/2013 19:12
De CH [+]
Post(s): 1558
Yep - bpy n'est dispo qu'en embedded player, et de toute façon c'est très mauvais style de l'utiliser dans le BGE.

Contribution le : 17/07/2015 19:46
_________________
BAddons, La Collection d'Addons de Matpi: https://github.com/qwenger/BAddons
Développeur Blender quand j'en ai le temps...

Créer un fichier PDF de la contribution Imprimer


Re: LibLoad, impossible de jouer les Actions importées
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Les nouvelles ont l'air bonnes !

Afin de pouvoir tester ton patch, je me suis attaqué à compiler Blender. Bon ça m'a pris deux ou trois essais, (dont une fois où j'avais oublié d'activer le flag du BGE :roll) mais j'ai réussi. Et là en testant machinalement ma scène, hé bien ça fonctionne très bien. Encore mieux, sur un autre de nos tests de LibLoad, où on n'arrivait qu'à avoir un plantage désagréable de Blender (segfault), encore une fois le problème semble résolu avec ma build.

Est-ce que j'ai raison d'en déduire que le bug a été résolu entre la 2.75a et aujourd'hui ? (Peut être bien par Panzergame, d'ailleurs) Et que donc, on peut compter sur le fait que ça fonctionnera dans la prochaine release ? Si c'est bien ça, c'est fantastique.

Bref je suis plutôt optimiste, tout ça demande encore quelques tests, et du coup j'ai pas encore testé ton patch. Mais dodo

Contribution le : 18/07/2015 04:00
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: LibLoad, impossible de jouer les Actions importées
OverdOzed
Inscrit:
21/08/2013 19:12
De CH [+]
Post(s): 1558
Tu veux dire que le message "Failed to load action" n'apparaît plus?

Contribution le : 18/07/2015 07:09
_________________
BAddons, La Collection d'Addons de Matpi: https://github.com/qwenger/BAddons
Développeur Blender quand j'en ai le temps...

Créer un fichier PDF de la contribution Imprimer


Re: LibLoad, impossible de jouer les Actions importées
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Non seulement le message n’apparaît plus, mais surtout l'action est bien jouée.

Par contre j'ai un nouveau message d'erreur, "Zombie object! name=Armature" ; ce qui n'empêche pas l'armature en question de fonctionner.
Et sur une quarantaine d'essais, j'ai quand même eu trois fois une erreur de segmentation au moment de quitter le jeu avec Echap.


edit:Hum... avec la build du buildbot, j'ai systématiquement une erreur de segmentation, visiblement peu après l'appel à LibLoad cette fois

Contribution le : 18/07/2015 08:26
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: LibLoad, impossible de jouer les Actions importées
OverdOzed
Inscrit:
21/08/2013 19:12
De CH [+]
Post(s): 1558
Ouaip, il m'arrive aussi d'avoir des EXCEPTION_ACCESS_VIOLATION avec les builds actuelles...

Ça ne m'a toutefois pas l'air lié à mon patch.

Je pense que ce serait bien que tu fasses un report. Ou regarde peut-être avec Panzergame, CcdPhysicsEnvironment c'est assez son domaine, normalement.

Contribution le : 18/07/2015 17:26
_________________
BAddons, La Collection d'Addons de Matpi: https://github.com/qwenger/BAddons
Développeur Blender quand j'en ai le temps...

Créer un fichier PDF de la contribution Imprimer


Re: LibLoad, impossible de jouer les Actions importées
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Citation :
Ça ne m'a toutefois pas l'air lié à mon patch.
C'est même certain vu que je n'ai pas encore eu le temps de l'essayer. J'ai simplement suivi à la lettre cette doc, à la seule différence que j'ai activé WITH_GAME_ENGINE.

Oui je vais faire un report. Quand à Panzergame j'espérais qu'il passerait dans le coin , je vais lui envoyer un message.

Contribution le : 18/07/2015 17:33
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
« 1 (2)




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses [non résolu] Débutant sur les découpes des objets avec Blender 2.79    [1][2] 11 93 Hier 23:54:13
yocodream 
Mes premières images sous Blender (débutants) Quitter l'affichage touche Z 6 50 Hier 23:50:51
rduvrac 
Questions & Réponses Configuration scroller et pan dans Blender 2.91 2 37 Hier 23:50:02
moonboots 
[WIP] et travaux terminés [WIP] Coming Home (Animation de Noël)    [1][2] 15 350 Hier 23:41:51
Bibi09 
Questions & Réponses Récupérer un vieux fichier dans Blender 2.90    [1][2] 11 382 Hier 21:03:47
doudoulolita 
Mes premières images sous Blender (débutants) serpent 5 59 Hier 16:28:40
rduvrac 
Questions & Réponses Aperçu des polices "qui clignotent" 2 72 Hier 08:56:23
Kristof_LEDRU 
[WIP] et travaux terminés [WIP] BUDY3000 prochain tuto spécial : modélisation semi mécanique 6 144 27/11 22:14:47
Laorz 
[WIP] et travaux terminés [WIP] TUTO Spécial Textures ! BOB et Gary :D 5 244 27/11 20:19:31
Bibi09 
Hors Sujet !! Tutoriel - Rigify - adapter Rigify à un personnage Cartoon (Bob l'éponge) 0 45 27/11 18:25:56
meltingman 
Questions & Réponses SSolidifier 5 73 27/11 18:19:55
rduvrac 
Questions & Réponses Bump map pixellisée    [1][2] 12 133 27/11 18:08:02
moonboots 
Questions & Réponses Je n'arrive pas a coller les membres de mes personnages sur l'armature    [1][2] 19 192 27/11 17:52:35
Lylo 
Questions & Réponses Scanner 3d et blender 2 84 27/11 17:37:28
Pandore62 
Questions & Réponses Ajouter l'effet de deux shaders? 1 51 27/11 17:28:02
moonboots 
Questions & Réponses [non résolu] Afficchage matériaux 9 111 27/11 13:58:56
rduvrac 
Questions & Réponses Meilleure résolution bake fluid 3 79 27/11 13:52:37
Patrickletare 
Questions & Réponses depliage UV version blender 2.9 1 42 27/11 13:42:59
Rimpotche 
Questions & Réponses [WIP] Typo 0 52 27/11 09:35:34
Laorz 
Questions & Réponses [WIP] Problème Rétopo    [1][2] 19 975 27/11 09:24:18
Laorz 

Qui est en ligne
133 utilisateur(s) en ligne (dont 64 sur Forums)

Membre(s): 1
Invité(s): 132


ebrain, plus...
Nouveaux membres
MartiWitt 28/11/2020
Augustus_Strix 28/11/2020
yocodream 28/11/2020
Pandore62 27/11/2020
Kristof_LEDRU 26/11/2020
capitaine_moyen 22/11/2020
nhandinhbongda 21/11/2020
SomeName 21/11/2020
Balbine20 20/11/2020
BlendSkill 20/11/2020
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Dec 29
Anniversaire d'ebrain
Jan 9
BUG de Lyon
Fev 15
Anniversaire de Dany
plus 263 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445