Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
BANNV2.png
Publicité
Formation Blender ElephormBlender 3d Elephorm


     






La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 987
Bonjour,

J'ai placé un driver sur la couleur d'une texture (avec le internal), mu par un curseur modélisé 3D qui est dans ma scène. Ceci pour laisser apparaître la texture sous-jacente.
Quand je fais varier directement la couleur avec la souris dans la fenêtre Properties, ça marche, je vois ma texture apparaître ou disparaître.
Quand je bouge mon curseur dans la vue 3D, rien ne se passe.
Pourtant mon driver fonctionne puisque en resélectionnant l'objet texturé, la valeur correspondante s'est bien ajustée dans la propriété couleur de la texture.
C'est comme si la vue 3D ne s'actualisait pas.

Contribution le : 17/04 07:32:10
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
29/12/2011 00:49
Post(s): 771
Pas sûr que ça t'aide, mais il y a cette video sur le sujet:
https://vimeo.com/40389198

mate a partir de 18 min si tu veux vite l'explication.

y'a quelques differences avec ton post mais sait-on jamais.

++

Contribution le : 18/04 00:09:24
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 987
Merci Thewada, pour ce très intéressant tuto !

Il m'a appris pas mal de choses, je ne vais pas souvent trainer du côté des Datablocks. J'ai fait plein d'essais ce matin (tous en vain), mais je crois qu'il y a un problème profond de Blender dans l'actualisation.

Exemple : Prends un cube, déplace le à la souris, tu vois la position s'actualiser dans les coordonnées Location du panneau Transform.
A présent, va dans les Datablocks, Objects, Cube, Location.
Déplace ton cube, les coordonnées ne s'actualisent pas.
Resélectionne ton cube avec un clic droit sans le bouger, là enfin, les coordonnées s'actualisent.

Donc, comme dans les drivers, tout passe par les Datablocks, je crois que ça va pas le faire dans mon cas.

Contribution le : 18/04 11:41:43
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
29/12/2011 00:49
Post(s): 771
y'a ce post qui suit ;)
je vais tester de mon coté pour voir si j'arrive a qq chose.

https://blender.stackexchange.com/questions/70784/how-to-get-a-material-property-driver-to-update-properly-2-78


edit:
j'ai essayé de faire un setup avec un bone qui drive des trucs sur un cube.

J'arrive a modifier le scale de mon cube en scalant le bone. Le viewport s'update correctement.

Mais si je change la valeur d'un mix entre deux tex, quand je deplace mon bone, ca ne se voit effectivement pas dans le viewport.

Par contre les changements se font bien dans les datablocks, pas besoin de reselectionner le cube.
Et surtout, si je lance l'anim, en rendered, les changements se font bien, mais on ne voit pas les infos s'updater.
Pas très friendly, mais le driver fonctionne.


blend ici:
http://pasteall.org/blend/index.php?id=46288

Contribution le : 18/04 12:29:45
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
21/08/2013 19:12
De CH [+]
Post(s): 1425
@Rimpotche: pour la question de la position dans les Datablocks qui n'est pas actualisée, c'est juste que la région de l'écran contenant l'Outliner n'est pas actualisée (redessinée) quand tu bouges l'objet. Mais il suffit de passer la souris dessus pour que ça change.

Ton problème ne vient donc a priori pas de là, car en interne les propriétés affichées dans l'Outliner sont quand même modifiées.


EDIT: j'ai fait un petit test simple dans le genre que tu décris, et j'obtiens une mise à jour des valeurs sans souci. Si tu pouvais partager un .blend problématique, ce serait chouette.

Tu peux également essayer de démarrer Blender avec le nouveau Depsgraph, ça résout souvent ce genre de soucis.

Contribution le : 18/04 15:39:38
_________________
BAddons, La Collection d'Addons de Matpi: https://github.com/qwenger/BAddons
Développeur Blender quand j'en ai le temps...

Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 987
Merci à tous les deux de vous pencher sur mon casse-tête.

@Thewada :
Oui, pour le moyen d'actualiser avec le lien, c'est un peu différent de mon cas. Je n'arrive pas avec ce moyen.
Ton blend, je l'ai essayé, en effet ça fonctionne pour le rendu avec Cycles.
Moi, c'est pour utiliser en vue 3D Material, pas en rendu. En fait, ce que je suis en train de faire, c'est un outil pour localiser des noms de montagne, aucunement pour faire du rendu, je ne suis que dans la vue 3D, c'est pour ça que je n'ai même pas essayé avec Cycles.

@Matpi :
Je te mets un blend ultra simplifié, j'ai eu un peu de mal à packer les textures, mais je crois que c'est bon. J'ai inclus un petit mot explicatif en text view.
Driver problem

Bonne nuit !

Contribution le : 18/04 23:17:47
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 987
@ Matpi :
Je n'ai pas eu beaucoup de temps, j'ai essayé de lancer avec le depsgraph, sans y arriver. Mais je vais creuser la chose.

EDIT 15 minutes plus tard
Ça y est, je viens de réussir en m'appliquant. Je ne me mettais pas dans le répertoire de Blender, c'est pour ça que ça ne marchait pas, je n'ai pas l'habitude de la console.
En tous cas, c'était une bonne idée puisque bravo, le driver fonctionne !
Il va falloir que j'apprenne à faire un batch pour lancer Blender ainsi, à présent.
C'est fou les trucs qu'on doit apprendre !
Merci Matpi !!!!!

Contribution le : 18/04 23:20:16
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
21/08/2013 19:12
De CH [+]
Post(s): 1425
Super, heureux que ça fonctionne!

Normalement le nouveau depsgraph devrait devenir celui par défaut dans la 2.8.

Contribution le : 19/04 07:24:13
_________________
BAddons, La Collection d'Addons de Matpi: https://github.com/qwenger/BAddons
Développeur Blender quand j'en ai le temps...

Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 987
Oui, je viens de vérifier avec la 2.80 de Tungerz et ça marche aussi !

Contribution le : 19/04 10:20:22
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses [non résolu] Problème application texture 2 93 Hier 21:33:52
joey33 
Mes premières images sous Blender (débutants) [WIP] Modélisation d'un vélo    [1][2][3][4] 39 3143 Hier 18:15:33
bathal 
Questions & Réponses Animer des jambes...?    [1][2] 10 671 Hier 15:43:23
webherbe 
Concours Défis du Clan 2017 - S16 - Thème : Abandonné "Vote ouvert" 8 620 Hier 15:22:19
busanga 
The Blender Clan 'tchat Blender 2.8x : Actus, tests, feedback..    [1][2] 14 1591 Hier 11:56:19
lucky 
GIMP Faire une image présentable 4 240 Hier 08:09:46
Redstar 
Mes premières images sous Blender (débutants) The One-Time Hero    [1][2] 13 476 23/04 17:00:50
Furiosa 
[WIP] et travaux terminés [WIP] je vous présente LPRJ-01    [1][2][3][4] 36 2691 23/04 08:39:21
Furiosa 
Questions & Réponses BLENDER à l'arrêt complet.....    [1][2] 10 757 22/04 19:47:09
Rimpotche 
Mes premières images sous Blender (débutants) Le second temple et la cité du muséum Israël de Jérusalem en 3D 0 186 22/04 19:36:57
Fracoris 
Mes premières images sous Blender (débutants) Lampe de chevet 3 203 22/04 16:40:41
Furiosa 
The Blender Clan 'tchat le topic de l'impression 3D    [1][2][3]...[123] 1226 261806 22/04 11:29:46
Hook 
Questions & Réponses Problème interface 1 200 21/04 21:14:54
BILL 
Questions & Réponses Blender 2.78 VSE bien moins fluide 0 157 21/04 19:02:17
sfersystem 
Questions & Réponses [résolu] Lissage objet impression 3D 6 354 21/04 17:31:12
Blackschmoll 
Mes premières images sous Blender (débutants) Les Blends de Megeon    [1][2][3]...[28] 277 40548 21/04 14:59:59
Megeon 
Moteur de jeu GameBlender et alternatives Demande d'aide sur le scripting python (BGE)    [1][2][3]...[15] 142 14061 21/04 11:54:38
Redstar 
Questions & Réponses [résolu] Armature - démarche robotique au naturel    [1][2] 18 1081 20/04 11:57:23
Redstar 
Questions & Réponses Origami Animation 4 357 19/04 20:54:33
DaWaaaaghBabal 
Questions & Réponses Ajouter un socle à une surface...chelou 4 394 19/04 19:14:50
Matpi 

Qui est en ligne
22 utilisateur(s) en ligne (dont 18 sur Forums)

Membre(s): 0
Invité(s): 22


plus...
Nouveaux membres
MaryjoEngl 24/4/2017
RosemarieB 24/4/2017
VetaHavelo 24/4/2017

Joseph
22/4/2017
renzolight 19/4/2017
theseven13 18/4/2017
ArnaudC 18/4/2017
Vekhy 17/4/2017
Ringskar 17/4/2017
ImaBanana 16/4/2017
Dernier Ajout
7.jpg

Evènements à venir
Mai 18
Anniversaire Luneo
Jui 30
Anniv des Jedi :-D
Jui 15
BUG de Lyon
plus 320 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2017 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445