Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
Diamonnt ring 2.png
Publicité
Formation Blender ElephormBlender 3d Elephorm


     






La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1177
Bonjour,

J'ai placé un driver sur la couleur d'une texture (avec le internal), mu par un curseur modélisé 3D qui est dans ma scène. Ceci pour laisser apparaître la texture sous-jacente.
Quand je fais varier directement la couleur avec la souris dans la fenêtre Properties, ça marche, je vois ma texture apparaître ou disparaître.
Quand je bouge mon curseur dans la vue 3D, rien ne se passe.
Pourtant mon driver fonctionne puisque en resélectionnant l'objet texturé, la valeur correspondante s'est bien ajustée dans la propriété couleur de la texture.
C'est comme si la vue 3D ne s'actualisait pas.

Contribution le : 17/04/2017 07:32
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
29/12/2011 00:49
Post(s): 911
Pas sûr que ça t'aide, mais il y a cette video sur le sujet:
https://vimeo.com/40389198

mate a partir de 18 min si tu veux vite l'explication.

y'a quelques differences avec ton post mais sait-on jamais.

++

Contribution le : 18/04/2017 00:09
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1177
Merci Thewada, pour ce très intéressant tuto !

Il m'a appris pas mal de choses, je ne vais pas souvent trainer du côté des Datablocks. J'ai fait plein d'essais ce matin (tous en vain), mais je crois qu'il y a un problème profond de Blender dans l'actualisation.

Exemple : Prends un cube, déplace le à la souris, tu vois la position s'actualiser dans les coordonnées Location du panneau Transform.
A présent, va dans les Datablocks, Objects, Cube, Location.
Déplace ton cube, les coordonnées ne s'actualisent pas.
Resélectionne ton cube avec un clic droit sans le bouger, là enfin, les coordonnées s'actualisent.

Donc, comme dans les drivers, tout passe par les Datablocks, je crois que ça va pas le faire dans mon cas.

Contribution le : 18/04/2017 11:41
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
29/12/2011 00:49
Post(s): 911
y'a ce post qui suit ;)
je vais tester de mon coté pour voir si j'arrive a qq chose.

https://blender.stackexchange.com/questions/70784/how-to-get-a-material-property-driver-to-update-properly-2-78


edit:
j'ai essayé de faire un setup avec un bone qui drive des trucs sur un cube.

J'arrive a modifier le scale de mon cube en scalant le bone. Le viewport s'update correctement.

Mais si je change la valeur d'un mix entre deux tex, quand je deplace mon bone, ca ne se voit effectivement pas dans le viewport.

Par contre les changements se font bien dans les datablocks, pas besoin de reselectionner le cube.
Et surtout, si je lance l'anim, en rendered, les changements se font bien, mais on ne voit pas les infos s'updater.
Pas très friendly, mais le driver fonctionne.


blend ici:
http://pasteall.org/blend/index.php?id=46288

Contribution le : 18/04/2017 12:29
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
21/08/2013 19:12
De CH [+]
Post(s): 1558
@Rimpotche: pour la question de la position dans les Datablocks qui n'est pas actualisée, c'est juste que la région de l'écran contenant l'Outliner n'est pas actualisée (redessinée) quand tu bouges l'objet. Mais il suffit de passer la souris dessus pour que ça change.

Ton problème ne vient donc a priori pas de là, car en interne les propriétés affichées dans l'Outliner sont quand même modifiées.


EDIT: j'ai fait un petit test simple dans le genre que tu décris, et j'obtiens une mise à jour des valeurs sans souci. Si tu pouvais partager un .blend problématique, ce serait chouette.

Tu peux également essayer de démarrer Blender avec le nouveau Depsgraph, ça résout souvent ce genre de soucis.

Contribution le : 18/04/2017 15:39
_________________
BAddons, La Collection d'Addons de Matpi: https://github.com/qwenger/BAddons
Développeur Blender quand j'en ai le temps...

Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1177
Merci à tous les deux de vous pencher sur mon casse-tête.

@Thewada :
Oui, pour le moyen d'actualiser avec le lien, c'est un peu différent de mon cas. Je n'arrive pas avec ce moyen.
Ton blend, je l'ai essayé, en effet ça fonctionne pour le rendu avec Cycles.
Moi, c'est pour utiliser en vue 3D Material, pas en rendu. En fait, ce que je suis en train de faire, c'est un outil pour localiser des noms de montagne, aucunement pour faire du rendu, je ne suis que dans la vue 3D, c'est pour ça que je n'ai même pas essayé avec Cycles.

@Matpi :
Je te mets un blend ultra simplifié, j'ai eu un peu de mal à packer les textures, mais je crois que c'est bon. J'ai inclus un petit mot explicatif en text view.
Driver problem

Bonne nuit !

Contribution le : 18/04/2017 23:17
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1177
@ Matpi :
Je n'ai pas eu beaucoup de temps, j'ai essayé de lancer avec le depsgraph, sans y arriver. Mais je vais creuser la chose.

EDIT 15 minutes plus tard
Ça y est, je viens de réussir en m'appliquant. Je ne me mettais pas dans le répertoire de Blender, c'est pour ça que ça ne marchait pas, je n'ai pas l'habitude de la console.
En tous cas, c'était une bonne idée puisque bravo, le driver fonctionne !
Il va falloir que j'apprenne à faire un batch pour lancer Blender ainsi, à présent.
C'est fou les trucs qu'on doit apprendre !
Merci Matpi !!!!!

Contribution le : 18/04/2017 23:20
Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
21/08/2013 19:12
De CH [+]
Post(s): 1558
Super, heureux que ça fonctionne!

Normalement le nouveau depsgraph devrait devenir celui par défaut dans la 2.8.

Contribution le : 19/04/2017 07:24
_________________
BAddons, La Collection d'Addons de Matpi: https://github.com/qwenger/BAddons
Développeur Blender quand j'en ai le temps...

Créer un fichier PDF de la contribution Imprimer


Re: La vue 3D ne s'actualise pas avec un driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1177
Oui, je viens de vérifier avec la 2.80 de Tungerz et ça marche aussi !

Contribution le : 19/04/2017 10:20
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
[WIP] et travaux terminés Wip Fillette 7 1283 Hier 21:48:32
Papa_Dragon 
Questions & Réponses rendu invisible 4 210 Hier 18:00:11
Guppy88 
Mes premières images sous Blender (débutants) forgiveness and submission in any 0 71 Hier 16:11:03
wigs241 
Questions & Réponses objets sélectionnés ne s'entourent pas d'une autre couleur 4 149 Hier 16:10:52
Melodicpinpon 
Questions & Réponses Bevel et Boolean qui ne fonctionnent pas    [1][2] 17 693 Hier 14:40:26
Prof_Saesee 
Questions & Réponses Shift+Ctrl+B automatique à 45° 6 156 Hier 13:19:03
moonboots 
Questions & Réponses Joindre deux objects 2 180 Hier 11:07:55
Lawenan1244 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Niveau d’intérieur WIP (Manoir) - VIDEO P36    [1][2][3]...[36] 352 44874 Hier 10:36:06
Hook 
Concours Defi de clan 2018 n°21 / Thème : Dessin animé /// VOTES ///    [1][2] 16 833 20/06 16:39:48
Rom162 
Questions & Réponses Comment incliner un texte sur un cercle sans déformation des lettres ? 7 274 20/06 06:27:25
benjamin_hausbrandt 
Questions & Réponses Décor qui apparait petit a petit    [1][2] 10 491 19/06 14:49:58
thierry1222 
Questions & Réponses [non résolu] Petit soucis lors d'un riging 7 279 18/06 09:00:24
moonboots 
Questions & Réponses Ombre avec map hdri 1 141 17/06 21:29:20
moonboots 
Questions & Réponses [résolu] séparer en 2 objets 7 154 17/06 16:13:21
TOTONE92 
Questions & Réponses [résolu] tuto gurt probleme de subdivision surface    [1][2] 10 244 16/06 20:43:28
TOTONE92 
Questions & Réponses [résolu] Appliquer une pose avec un certain pourcentage 3 167 16/06 13:22:32
BleuRaven 
Questions & Réponses Rigging...    [1][2] 11 434 16/06 08:17:29
Redstar 
Mes premières images sous Blender (débutants) Etudiant en archi qui patauge un peu 2 184 15/06 18:34:50
moonboots 
The Blender Clan 'tchat Évolution de la 3D et automatisation 6 627 15/06 10:26:51
gone69000 
Questions & Réponses [non résolu] Problème 0 128 14/06 16:56:53
loop 

Qui est en ligne
13 utilisateur(s) en ligne (dont 8 sur Forums)

Membre(s): 0
Invité(s): 13


plus...
Nouveaux membres
MaritaMcAd 22/6/2018
KennethGor 22/6/2018
LucieMcElh 22/6/2018
MerryHiggi 21/6/2018
Latashia59 21/6/2018
wigs241 21/6/2018
MillaTroia 21/6/2018
Leticia214 21/6/2018
nherve 18/6/2018
albeback 18/6/2018
Dernier Ajout
DB11_Aston_Martin_2017_bothview.jpg

Evènements à venir
Jui 30
Anniv des Jedi :-D
Jui 14
BUG de Lyon
Jui 23
Anniv du BlenderClan !
plus 303 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2017 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445