Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
bc.jpg
Publicité
Formation Blender ElephormBlender 3d Elephorm


     






Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10/2017 08:58
Post(s): 55
Bonjour tout le monde.

Après avoir fonctionné quelques temps avec des armatures classiques, ou tous les os étaient reliés, j'ai voulu profiter des possibilités offertes par les IK bones. Cependant, une fois terminée mon armature et assignée à mon personnage, j'ai un problème au niveau des transformations du mesh. En effet, les vertices s'applatissent au niveau de la cuisse, ce qui donne un résultat très mauvais.

[URL=http://www.casimages.com/i/171011034334216295.jpg.html][IMG]http://nsa39.casimages.com/img/2017/10/11/mini_171011034334216295.jpg[/IMG][/url]

[URL=http://www.casimages.com/i/171011034334333096.jpg.html][IMG]http://nsa39.casimages.com/img/2017/10/11/mini_171011034334333096.jpg[/IMG][/url]

Sur l'image le 1 correspond à mon IK genou, le 2 à l'os de mon fémur, le 3 à l'os de mon tibia et le 4 au controleur de mon pied.

Si l'un de vous sait d'où vient le couac, ça m'arrangerait bien ! merci.

Contribution le : 11/10/2017 14:19
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10/2017 08:58
Post(s): 55
J'ai trouvé de là où semble venir mon problème, quand j'assigne l'armature avec poids automatiques, je n'ai aucun groupe de vertices créés correspondants à la cuisses gauche, alors que j'en ai bien pour la cuisse droite. Et j'ai essayé d'assigner la même armature à plusieurs personnage, le problème est le même à chaque fois.

Contribution le : 12/10/2017 10:02
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
OverdOzed
Inscrit:
07/08/2014 09:17
Post(s): 856
Il faudrait que tu partages ton fichier pour voir d'où vient le problème

Tu peux vérifier si le parentage s'est correctement effectué en mettant ton armature en mode pose puis ton mesh en mode Weight Paint, ensuite, en sélectionnant un os tu peux voir s'il agit bien sur la partie voulue du mesh, si ce n'est pas le cas tu peux corriger avec le pinceau.

Si ça ne marche toujours pas, car on ne voit pas forcément tout en mode Weight Paint, tu peux aller voir les vertex Groups de ton personnage et assigner les parties qui ne le sont pas au groupe qui porte le nom de l'os voulu, et inversement en désassignant d'un groupe certaines parties de mesh qui ne sont pas censées y appartenir.

Pour éviter quelques bugs il faut aussi vérifier que les os qui te servent de target n'ont pas l'option Deform cochée dans le menu Bone. Également dans les modifiers de ton mesh vérifier que le modifier Armature est au-dessus du modifier Subsurface, et que dans ce modifier Armature l'option Preserve Volume est activée.

Contribution le : 12/10/2017 10:19
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10/2017 08:58
Post(s): 55
Merci pour ta réponse.

Concernant le parentage en mode weight paint, je n'ai rien du tout étant donné que je n'ai pas de vertex group qui est attribué pour l'os de la cuisse gauche.

Lorsque je créé mon vertex group et que je peints les poids, j'ai effectivement mon problème de résolu. Maintenant je me demande pourquoi le groupe de vertice correspondant ne se créé pas.

Voila mon fichier : https://www.mediafire.com/file/ng13uw2164in4a7/Jiren.blend (il faut activer la déformation sur l'os qui ne l'était pas au moment de l'upload).

Contribution le : 12/10/2017 13:31
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
OverdOzed
Inscrit:
07/08/2014 09:17
Post(s): 856
j'ai fait un test : j'ai déparenté ton mesh puis je l'ai reparenté à ton armature, et ça semble fonctionner normalement, après je n'ai pas regardé dans les détails, il me semble qu'il y a des trucs pas conventionnels dans ton armature mais c'est peut-être ta façon de faire, en tout cas il n'y a pas de déformation de la cuisse...

à moins que je n'aie pas saisi ton problème ?


Contribution le : 12/10/2017 15:21
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10/2017 08:58
Post(s): 55
Problème résolu merci, les choses les plus simples sont parfois les plus difficiles à trouver lorsqu'on a le nez dedans. Gracias moonboots ! :)

Contribution le : 12/10/2017 15:40
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses [non résolu] distorsion d'image après tracking 1 123 Aujourd'hui 15:11:17
Rimpotche 
Concours Defi de clan 2018 n°22 / Thème : A l'origine 1 220 Aujourd'hui 13:18:17
Rolix 
Questions & Réponses objet multiplier le long d'un chemin bezier 8 409 Aujourd'hui 13:09:21
titi38360 
Hors Sujet !! Obtenez Votre Permis De Conduire En 6 Jours 0 75 Aujourd'hui 10:42:44
Malot 
Questions & Réponses modification du thème 0 108 Aujourd'hui 08:03:30
francerf 
Questions & Réponses mixer deux procedural textures 0 60 Aujourd'hui 07:12:38
moonboots 
Hors Sujet !! Exercice - etude de marché sur une idée de jeu video    [1][2] 10 3811 Aujourd'hui 03:15:14
BILGAKILUNGA 
[WIP] et travaux terminés Wip Fillette 8 1435 Aujourd'hui 03:08:52
BILGAKILUNGA 
Concours Defi de clan 2018 n°21 / Thème : Dessin animé /// GAGNANT : Shoover ! ///    [1][2][3] 20 1095 Hier 23:42:28
shoover 
Questions & Réponses Image de rendu sans fond après compositiing 2 135 Hier 18:56:48
MB74 
Questions & Réponses Rigging...    [1][2] 13 565 Hier 11:36:10
Zack2554 
Questions & Réponses rendu invisible 9 476 22/06 17:40:41
JaAlVir657 
Questions & Réponses Vernis sélectif pour un .obj 3 187 22/06 15:57:38
moonboots 
Questions & Réponses [non résolu] Petit soucis lors d'un riging 8 347 22/06 09:15:30
lookingforspice 
Questions & Réponses Bevel et Boolean qui ne fonctionnent pas    [1][2] 18 812 22/06 08:09:34
debutant 
Questions & Réponses objets sélectionnés ne s'entourent pas d'une autre couleur 4 213 21/06 16:10:52
Melodicpinpon 
Questions & Réponses Shift+Ctrl+B automatique à 45° 6 195 21/06 13:19:03
moonboots 
Questions & Réponses Joindre deux objects 2 218 21/06 11:07:55
Lawenan1244 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Niveau d’intérieur WIP (Manoir) - VIDEO P36    [1][2][3]...[36] 352 45161 21/06 10:36:06
Hook 
Questions & Réponses Comment incliner un texte sur un cercle sans déformation des lettres ? 7 310 20/06 06:27:25
benjamin_hausbrandt 

Qui est en ligne
23 utilisateur(s) en ligne (dont 11 sur Forums)

Membre(s): 3
Invité(s): 20


AurelienJ, Rimpotche, moonboots, plus...
Nouveaux membres
SardineArdente 24/6/2018
Malot 24/6/2018
Dewitt1704 24/6/2018
BILGAKILUNGA 24/6/2018
Elokynn 23/6/2018
pierrottulez 23/6/2018
embaline3d 22/6/2018
MB74 22/6/2018
nherve 18/6/2018
albeback 18/6/2018
Dernier Ajout
DB11_Aston_Martin_2017_bothview.jpg

Evènements à venir
Jui 30
Anniv des Jedi :-D
Jui 14
BUG de Lyon
Jui 23
Anniv du BlenderClan !
plus 303 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2017 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445