Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
dogandbutterflyVF2Web.jpg
Publicité
Formation Blender ElephormBlender 3d Elephorm


     






Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10 08:58:35
Post(s): 41
Bonjour tout le monde.

Après avoir fonctionné quelques temps avec des armatures classiques, ou tous les os étaient reliés, j'ai voulu profiter des possibilités offertes par les IK bones. Cependant, une fois terminée mon armature et assignée à mon personnage, j'ai un problème au niveau des transformations du mesh. En effet, les vertices s'applatissent au niveau de la cuisse, ce qui donne un résultat très mauvais.

[URL=http://www.casimages.com/i/171011034334216295.jpg.html][IMG]http://nsa39.casimages.com/img/2017/10/11/mini_171011034334216295.jpg[/IMG][/url]

[URL=http://www.casimages.com/i/171011034334333096.jpg.html][IMG]http://nsa39.casimages.com/img/2017/10/11/mini_171011034334333096.jpg[/IMG][/url]

Sur l'image le 1 correspond à mon IK genou, le 2 à l'os de mon fémur, le 3 à l'os de mon tibia et le 4 au controleur de mon pied.

Si l'un de vous sait d'où vient le couac, ça m'arrangerait bien ! merci.

Contribution le : 11/10 14:19:57
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10 08:58:35
Post(s): 41
J'ai trouvé de là où semble venir mon problème, quand j'assigne l'armature avec poids automatiques, je n'ai aucun groupe de vertices créés correspondants à la cuisses gauche, alors que j'en ai bien pour la cuisse droite. Et j'ai essayé d'assigner la même armature à plusieurs personnage, le problème est le même à chaque fois.

Contribution le : 12/10 10:02:35
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
OverdOzed
Inscrit:
07/08/2014 09:17
Post(s): 516
Il faudrait que tu partages ton fichier pour voir d'où vient le problème

Tu peux vérifier si le parentage s'est correctement effectué en mettant ton armature en mode pose puis ton mesh en mode Weight Paint, ensuite, en sélectionnant un os tu peux voir s'il agit bien sur la partie voulue du mesh, si ce n'est pas le cas tu peux corriger avec le pinceau.

Si ça ne marche toujours pas, car on ne voit pas forcément tout en mode Weight Paint, tu peux aller voir les vertex Groups de ton personnage et assigner les parties qui ne le sont pas au groupe qui porte le nom de l'os voulu, et inversement en désassignant d'un groupe certaines parties de mesh qui ne sont pas censées y appartenir.

Pour éviter quelques bugs il faut aussi vérifier que les os qui te servent de target n'ont pas l'option Deform cochée dans le menu Bone. Également dans les modifiers de ton mesh vérifier que le modifier Armature est au-dessus du modifier Subsurface, et que dans ce modifier Armature l'option Preserve Volume est activée.

Contribution le : 12/10 10:19:48
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10 08:58:35
Post(s): 41
Merci pour ta réponse.

Concernant le parentage en mode weight paint, je n'ai rien du tout étant donné que je n'ai pas de vertex group qui est attribué pour l'os de la cuisse gauche.

Lorsque je créé mon vertex group et que je peints les poids, j'ai effectivement mon problème de résolu. Maintenant je me demande pourquoi le groupe de vertice correspondant ne se créé pas.

Voila mon fichier : https://www.mediafire.com/file/ng13uw2164in4a7/Jiren.blend (il faut activer la déformation sur l'os qui ne l'était pas au moment de l'upload).

Contribution le : 12/10 13:31:14
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
OverdOzed
Inscrit:
07/08/2014 09:17
Post(s): 516
j'ai fait un test : j'ai déparenté ton mesh puis je l'ai reparenté à ton armature, et ça semble fonctionner normalement, après je n'ai pas regardé dans les détails, il me semble qu'il y a des trucs pas conventionnels dans ton armature mais c'est peut-être ta façon de faire, en tout cas il n'y a pas de déformation de la cuisse...

à moins que je n'aie pas saisi ton problème ?


Contribution le : 12/10 15:21:50
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10 08:58:35
Post(s): 41
Problème résolu merci, les choses les plus simples sont parfois les plus difficiles à trouver lorsqu'on a le nez dedans. Gracias moonboots ! :)

Contribution le : 12/10 15:40:22
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Probleme d'armature avec MakeHuman 3 103 Aujourd'hui 00:29:02
Machaon 
Concours Défis du clan - semaine 47 : Dieux Oubliés    [1][2] 18 617 Aujourd'hui 00:12:44
busanga 
Concours Défis du clan - semaine 48 : "Sens dessus dessous" 2 39 Hier 23:20:48
Deleatur 
[WIP] et travaux terminés [WIP] Wips Divers Lollito    [1][2][3]...[27] 260 35162 Hier 22:09:32
Deleatur 
Questions & Réponses [non résolu] Faire des cheveux de façon rapide et efficace.    [1][2] 13 639 Hier 19:40:59
dynamique-zak 
Moteur de jeu GameBlender et alternatives [non résolu] Programmation et liens entre blend 0 37 Hier 16:56:18
Redstar 
Questions & Réponses Choix du Bake Type UV 0 40 Hier 16:33:16
Horemheb 
Moteur de jeu GameBlender et alternatives [WIP] Fps Survival Horror (Vidéo Trailer Mode arène page 30)    [1][2][3]...[30] 299 32157 Hier 14:43:37
rikoo 
Questions & Réponses [non résolu] Objets qui tremblent, mouvements étranges 2 141 Hier 13:28:01
Rimpotche 
Questions & Réponses video editing: perte de qualité 1 62 Hier 13:18:52
Rimpotche 
Questions & Réponses [résolu] Rigging d'une pince 6 144 Hier 10:18:21
moonboots 
Questions & Réponses [résolu] Opération booléenne catastrophique 9 458 11/12 21:44:51
BILL 
Questions & Réponses nouvelles versions 3 310 11/12 19:00:45
ebrain 
Moteur de jeu GameBlender et alternatives [WIP]RPG monde ouvert terranate    [1][2] 14 2503 11/12 18:23:56
camelia59236 
Questions & Réponses [résolu] Contrainte de rotation sur une armature qui ne fonctionne pas 5 159 11/12 16:14:31
FoxRock 
[WIP] et travaux terminés 6090 FS Hydraulic Mining Shovel Caterpillar    [1][2] 13 794 10/12 22:26:33
Machaon 
Questions & Réponses [non résolu] Petit soucis avec la simulation de Fluide 0 83 10/12 14:11:20
Vincendre 
Le coin des geeks Blender avec un ordinateur en Cloud ?    [1][2] 10 518 10/12 12:43:47
Rom162 
Questions & Réponses Meilleure méthode pour faire des vêtements ?    [1][2] 14 764 10/12 12:41:47
Rom162 
[WIP] et travaux terminés Quartz rose étoilé 3 203 10/12 10:46:12
qlemouland 

Qui est en ligne
25 utilisateur(s) en ligne (dont 12 sur Forums)

Membre(s): 0
Invité(s): 25


plus...
Nouveaux membres
artvirtuel 12/12/2017
PrincessOg 12/12/2017
greg89 12/12/2017
Bryan1167 12/12/2017
KateHenson 12/12/2017
HurdyGuigui 10/12/2017
qlemouland 9/12/2017
Litshei 8/12/2017
titi38360 7/12/2017
pulsar-animation 4/12/2017
Dernier Ajout
DB11_Aston_Martin_2017_bothview.jpg

Evènements à venir
Dec 29
Anniversaire d'ebrain
Jan 13
BUG de Lyon
Fev 15
Anniversaire de Dany
plus 310 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2017 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445