Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
rendu.jpg
Publicité
Formation Blender ElephormBlender 3d Elephorm


     






Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10/2017 08:58
Post(s): 55
Bonjour tout le monde.

Après avoir fonctionné quelques temps avec des armatures classiques, ou tous les os étaient reliés, j'ai voulu profiter des possibilités offertes par les IK bones. Cependant, une fois terminée mon armature et assignée à mon personnage, j'ai un problème au niveau des transformations du mesh. En effet, les vertices s'applatissent au niveau de la cuisse, ce qui donne un résultat très mauvais.

[URL=http://www.casimages.com/i/171011034334216295.jpg.html][IMG]http://nsa39.casimages.com/img/2017/10/11/mini_171011034334216295.jpg[/IMG][/url]

[URL=http://www.casimages.com/i/171011034334333096.jpg.html][IMG]http://nsa39.casimages.com/img/2017/10/11/mini_171011034334333096.jpg[/IMG][/url]

Sur l'image le 1 correspond à mon IK genou, le 2 à l'os de mon fémur, le 3 à l'os de mon tibia et le 4 au controleur de mon pied.

Si l'un de vous sait d'où vient le couac, ça m'arrangerait bien ! merci.

Contribution le : 11/10/2017 14:19
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10/2017 08:58
Post(s): 55
J'ai trouvé de là où semble venir mon problème, quand j'assigne l'armature avec poids automatiques, je n'ai aucun groupe de vertices créés correspondants à la cuisses gauche, alors que j'en ai bien pour la cuisse droite. Et j'ai essayé d'assigner la même armature à plusieurs personnage, le problème est le même à chaque fois.

Contribution le : 12/10/2017 10:02
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
OverdOzed
Inscrit:
07/08/2014 09:17
Post(s): 1013
Il faudrait que tu partages ton fichier pour voir d'où vient le problème

Tu peux vérifier si le parentage s'est correctement effectué en mettant ton armature en mode pose puis ton mesh en mode Weight Paint, ensuite, en sélectionnant un os tu peux voir s'il agit bien sur la partie voulue du mesh, si ce n'est pas le cas tu peux corriger avec le pinceau.

Si ça ne marche toujours pas, car on ne voit pas forcément tout en mode Weight Paint, tu peux aller voir les vertex Groups de ton personnage et assigner les parties qui ne le sont pas au groupe qui porte le nom de l'os voulu, et inversement en désassignant d'un groupe certaines parties de mesh qui ne sont pas censées y appartenir.

Pour éviter quelques bugs il faut aussi vérifier que les os qui te servent de target n'ont pas l'option Deform cochée dans le menu Bone. Également dans les modifiers de ton mesh vérifier que le modifier Armature est au-dessus du modifier Subsurface, et que dans ce modifier Armature l'option Preserve Volume est activée.

Contribution le : 12/10/2017 10:19
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10/2017 08:58
Post(s): 55
Merci pour ta réponse.

Concernant le parentage en mode weight paint, je n'ai rien du tout étant donné que je n'ai pas de vertex group qui est attribué pour l'os de la cuisse gauche.

Lorsque je créé mon vertex group et que je peints les poids, j'ai effectivement mon problème de résolu. Maintenant je me demande pourquoi le groupe de vertice correspondant ne se créé pas.

Voila mon fichier : https://www.mediafire.com/file/ng13uw2164in4a7/Jiren.blend (il faut activer la déformation sur l'os qui ne l'était pas au moment de l'upload).

Contribution le : 12/10/2017 13:31
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
OverdOzed
Inscrit:
07/08/2014 09:17
Post(s): 1013
j'ai fait un test : j'ai déparenté ton mesh puis je l'ai reparenté à ton armature, et ça semble fonctionner normalement, après je n'ai pas regardé dans les détails, il me semble qu'il y a des trucs pas conventionnels dans ton armature mais c'est peut-être ta façon de faire, en tout cas il n'y a pas de déformation de la cuisse...

à moins que je n'aie pas saisi ton problème ?


Contribution le : 12/10/2017 15:21
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Clan Afficionado
Inscrit:
09/10/2017 08:58
Post(s): 55
Problème résolu merci, les choses les plus simples sont parfois les plus difficiles à trouver lorsqu'on a le nez dedans. Gracias moonboots ! :)

Contribution le : 12/10/2017 15:40
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Fumée de réacteur 0 4 Aujourd'hui 08:52:33
Yeti 
Concours Défi du clan 2018 n°24 / Thème : Volant 2 131 Aujourd'hui 08:20:35
Yeti 
Mes premières images sous Blender (débutants) ma première 2 138 Hier 08:42:10
Leuko 
Python & Plugins Executer mon code python dans le cloud. 2 81 Hier 05:14:07
tsurubaso 
Questions & Réponses torsion Simple Deform 9 272 22/09 07:46:40
Rimpotche 
Questions & Réponses Arrête fantome    [1][2] 11 131 21/09 16:45:41
Leuko 
Questions & Réponses creer une fourrure en creux pour un animal 5 110 21/09 16:11:56
moonboots 
Hors Sujet !! Ramon Humber Jersey 0 56 21/09 09:19:44
linchao 
Questions & Réponses Carte graphique 1 128 20/09 19:51:26
Stuf34 
Questions & Réponses meilleur tracking 2 154 20/09 14:21:45
louis_lechauve 
Mes premières images sous Blender (débutants) Avis sur modélisation vector kriss 1 163 20/09 10:52:00
Nocs91 
Questions & Réponses Sauvegarder une animation compositée 4 116 19/09 21:55:49
Docbrown 
Python & Plugins [non résolu] Comment convertir des points grease pencil en empty ? 0 92 19/09 16:31:55
snakblack 
Questions & Réponses [non résolu] Créer une grille et la déformer 3 117 19/09 11:55:35
debutant 
Questions & Réponses uv map different 1 135 17/09 22:49:02
Rimpotche 
Questions & Réponses afficher les mesures 2 164 17/09 19:33:04
Rimpotche 
Mes premières images sous Blender (débutants) Obtenir la camera de la preview… 1 117 17/09 15:13:42
moonboots 
[WIP] et travaux terminés [non résolu] uv mapping different sur un même mesh 2 115 17/09 15:12:40
medicalkit 
[WIP] et travaux terminés [WIP] 3 arks : quelques news p54    [1][2][3]...[55] 546 155945 17/09 11:22:07
blendman 
Questions & Réponses video editing lag 6 250 17/09 10:25:48
thomas56 

Qui est en ligne
25 utilisateur(s) en ligne (dont 17 sur Forums)

Membre(s): 0
Invité(s): 25


plus...
Nouveaux membres
ValeriaU27 24/9/2018
EddyForan 24/9/2018
pierre-431 23/9/2018
charbo16 23/9/2018
Leuko 21/9/2018
linchao 21/9/2018
noemie_blend 19/9/2018
Vlarki 17/9/2018
Solky 15/9/2018
drago1985 14/9/2018
Dernier Ajout
Garage_BC.jpg

Evènements à venir
Nov 18
Anniversaire de RichDeg
Dec 29
Anniversaire d'ebrain
Jan 12
BUG de Lyon
plus 297 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2018 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445