Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
origalde.jpg
Publicité
Formation Blender ElephormBlender 3d Elephorm


     






Problème de rig sur un personnage avec IK
Touriste
Inscrit:
09/10 09:58:35
Post(s): 11
Bonjour tout le monde.

Après avoir fonctionné quelques temps avec des armatures classiques, ou tous les os étaient reliés, j'ai voulu profiter des possibilités offertes par les IK bones. Cependant, une fois terminée mon armature et assignée à mon personnage, j'ai un problème au niveau des transformations du mesh. En effet, les vertices s'applatissent au niveau de la cuisse, ce qui donne un résultat très mauvais.

[URL=http://www.casimages.com/i/171011034334216295.jpg.html][IMG]http://nsa39.casimages.com/img/2017/10/11/mini_171011034334216295.jpg[/IMG][/url]

[URL=http://www.casimages.com/i/171011034334333096.jpg.html][IMG]http://nsa39.casimages.com/img/2017/10/11/mini_171011034334333096.jpg[/IMG][/url]

Sur l'image le 1 correspond à mon IK genou, le 2 à l'os de mon fémur, le 3 à l'os de mon tibia et le 4 au controleur de mon pied.

Si l'un de vous sait d'où vient le couac, ça m'arrangerait bien ! merci.

Contribution le : 11/10 15:19:57
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Touriste
Inscrit:
09/10 09:58:35
Post(s): 11
J'ai trouvé de là où semble venir mon problème, quand j'assigne l'armature avec poids automatiques, je n'ai aucun groupe de vertices créés correspondants à la cuisses gauche, alors que j'en ai bien pour la cuisse droite. Et j'ai essayé d'assigner la même armature à plusieurs personnage, le problème est le même à chaque fois.

Contribution le : 12/10 11:02:35
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
OverdOzed
Inscrit:
07/08/2014 10:17
Post(s): 375
Il faudrait que tu partages ton fichier pour voir d'où vient le problème

Tu peux vérifier si le parentage s'est correctement effectué en mettant ton armature en mode pose puis ton mesh en mode Weight Paint, ensuite, en sélectionnant un os tu peux voir s'il agit bien sur la partie voulue du mesh, si ce n'est pas le cas tu peux corriger avec le pinceau.

Si ça ne marche toujours pas, car on ne voit pas forcément tout en mode Weight Paint, tu peux aller voir les vertex Groups de ton personnage et assigner les parties qui ne le sont pas au groupe qui porte le nom de l'os voulu, et inversement en désassignant d'un groupe certaines parties de mesh qui ne sont pas censées y appartenir.

Pour éviter quelques bugs il faut aussi vérifier que les os qui te servent de target n'ont pas l'option Deform cochée dans le menu Bone. Également dans les modifiers de ton mesh vérifier que le modifier Armature est au-dessus du modifier Subsurface, et que dans ce modifier Armature l'option Preserve Volume est activée.

Contribution le : 12/10 11:19:48
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Touriste
Inscrit:
09/10 09:58:35
Post(s): 11
Merci pour ta réponse.

Concernant le parentage en mode weight paint, je n'ai rien du tout étant donné que je n'ai pas de vertex group qui est attribué pour l'os de la cuisse gauche.

Lorsque je créé mon vertex group et que je peints les poids, j'ai effectivement mon problème de résolu. Maintenant je me demande pourquoi le groupe de vertice correspondant ne se créé pas.

Voila mon fichier : https://www.mediafire.com/file/ng13uw2164in4a7/Jiren.blend (il faut activer la déformation sur l'os qui ne l'était pas au moment de l'upload).

Contribution le : 12/10 14:31:14
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
OverdOzed
Inscrit:
07/08/2014 10:17
Post(s): 375
j'ai fait un test : j'ai déparenté ton mesh puis je l'ai reparenté à ton armature, et ça semble fonctionner normalement, après je n'ai pas regardé dans les détails, il me semble qu'il y a des trucs pas conventionnels dans ton armature mais c'est peut-être ta façon de faire, en tout cas il n'y a pas de déformation de la cuisse...

à moins que je n'aie pas saisi ton problème ?


Contribution le : 12/10 16:21:50
Créer un fichier PDF de la contribution Imprimer


Re: Problème de rig sur un personnage avec IK
Touriste
Inscrit:
09/10 09:58:35
Post(s): 11
Problème résolu merci, les choses les plus simples sont parfois les plus difficiles à trouver lorsqu'on a le nez dedans. Gracias moonboots ! :)

Contribution le : 12/10 16:40:22
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Subdivision et crease, mauvais deal ?? 0 30 Aujourd'hui 01:16:41
Docteurkro 
[WIP] et travaux terminés WIP 3D Models pour un jeu! 1 131 Aujourd'hui 01:11:20
Martulen 
Questions & Réponses Hair settings introuvable 1 102 Aujourd'hui 01:08:59
Martulen 
Questions & Réponses Comment créé un Node Group avec des entier en entrée ? 5 288 Aujourd'hui 00:03:54
Matpi 
The Blender Clan 'tchat Recherche mentor Blender en Vendée 2 280 Hier 22:01:41
pierrero 
Moteur de jeu GameBlender et alternatives Projets simples jeux basiques navires de guerre (essaie pour apprendre)    [1][2][3][4] 34 1907 Hier 18:40:25
rikoo 
Concours Défis du Clan - s.40 - thème : "O.V.N.I."    [1][2] 12 628 Hier 17:36:22
brachyvore 
Questions & Réponses Images références ont disparu lors de la réouverture 6 214 Hier 15:47:07
shermichel 
Questions & Réponses Problème avec le modifier Booléen 2 68 Hier 15:36:02
Rom162 
The Blender Clan 'tchat Ammamellen et Elias 2 109 Hier 14:45:01
Redstar 
Questions & Réponses ajouter texture et couleur (débutant) 3 148 17/10 18:58:29
Melodicpinpon 
The Blender Clan 'tchat Video Blender 2.79 Nouvelles fonctionnalités 4 640 17/10 14:26:27
lapineige 
Moteur de jeu GameBlender et alternatives [résolu] Stopper un son en python 6 343 17/10 13:23:29
Redstar 
Questions & Réponses [non résolu] Ajout IK à une armature animée 2 96 17/10 13:10:22
Kriss4Realms 
Questions & Réponses [non résolu] création d'un cône de glace 3 322 17/10 09:52:20
littlealien 
[WIP] et travaux terminés [WIP] Solo de batterie 8 465 17/10 00:44:43
Ringskar 
Moteur de jeu GameBlender et alternatives [WIP] Fps Survival Horror (Nouvelle vidéo page 27)    [1][2][3]...[29] 280 28648 16/10 20:19:21
rikoo 
Questions & Réponses [résolu] Barre du dessus disparue 5 149 16/10 18:39:46
edddy 
The Blender Clan 'tchat [BUG PARIS] RDV en 2017 !    [1][2][3]...[68] 677 142967 16/10 17:01:00
edddy 
Questions & Réponses impossible saisir objet en User Persp 2 150 16/10 13:22:05
moonboots 

Qui est en ligne
13 utilisateur(s) en ligne (dont 7 sur Forums)

Membre(s): 1
Invité(s): 12


LonList34, plus...
Nouveaux membres
LonList34 19/10/2017
Archimestre 18/10/2017
gwarr 17/10/2017
Kriss4Realms 17/10/2017
djo101 17/10/2017
Stefrogers 15/10/2017
Elfueros 14/10/2017
lordfederer 13/10/2017
rachta 12/10/2017
lepetitatelierxyz 12/10/2017
Dernier Ajout
seul.jpg

Evènements à venir
Nov 4
BUG de Paris
Nov 18
Anniversaire de RichDeg
Dec 29
Anniversaire d'ebrain
plus 312 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2017 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445