Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
Découverte réduite.jpg
Publicité
Formation Blender ElephormBlender 3d Elephorm


     






Aligner / Ajuster / Synchroniser Musique et vue 3D avant rendu
Clan Afficionado
Inscrit:
22/10/2010 09:23
Post(s): 61
Bonjour à toutes et tous,

Après quelques recherches je me permets de faire appel à vos connaissances pour m'aider sur ce point s'il vous plait :

Je veux réaliser un clip et placer des keyframes à certains moments de la musique pour synchroniser mouvements de camera et son.

J'ai une courbe Bézier, follopath camera type travelling, startframe avec la musique à 1 et "frames" de la courbe à 8800 frames qui correspond à la fin de l'extrait sonore (vu dans la fenêtre video editor).

Mon problème c'est que lors de la "prévisualisation", quand je lance l'animation par le bouton play, le déplacement de la camera en vue 3D est plus rapide qu'escompté.

Du coup il m'est impossible à ce stade de savoir à quel moment placer les keyframes pour changer la position de la caméra au moment du morceau de musique.

Est-ce que vous sauriez me dire comment synchroniser le son et l'image avant le render ?

(j'ai imaginé placer les keyframes sur le VSE mais je ne sais pas encore comment procéder et ça me semble moins intuitif)

Est-ce que je dois jouer sur les paramètres évaluation time et follow (Onglet Curve -> Animation) ? Si oui comment svp ? Si vous avez d'autres pistes d'avance merci !

Contribution le : 13/03 19:32:30
Créer un fichier PDF de la contribution Imprimer


Re: Aligner / Ajuster / Synchroniser Musique et vue 3D avant rendu
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1326
Salut, Scylla.

Si tu as mis un modifier FollowCurve, tes symptômes sont normaux. L'animation est calée sur 100 par défaut.
Tu dois aller dans l'onglet Data de ta courbe (l'icône représentant un bout de courbe avec deux sommets) et dans "Path Animation" changer 100 en 8800.

Contribution le : 14/03 11:07:04
Créer un fichier PDF de la contribution Imprimer


Re: Aligner / Ajuster / Synchroniser Musique et vue 3D avant rendu
Clan Afficionado
Inscrit:
22/10/2010 09:23
Post(s): 61
Merci beaucoup pour cette réponse,
lorsque je fais ça et que je lance la prévisualisation dans la fenêtre 3D mon titre musical se termine bien avant la fin de l'animation, et ça me paraît normal puisque j'ai un frame rate entre 6 et 10 (inscrit en haut à gauche en rouge) lors de la prévisualisation alors que le framrate est de 24 pour le rendu final. Il "faudrait" que j'ai le même taux d'image par seconde lors de la prévisualisation c'est possible ?

Contribution le : 14/03 15:03:34
Créer un fichier PDF de la contribution Imprimer


Re: Aligner / Ajuster / Synchroniser Musique et vue 3D avant rendu
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1326
Le carte graphique et le processeur peuvent freiner s'ils ne sont pas assez puissants, et selon la complexité de la scène.

Peut-être peux-tu explorer les différents modes de synchronisation audio, au milieu, au bas de la vue 3D.

- "All Sync Blender" va sauter des frames lorsque la vidéo est en retard sur l'audio.

- "Frame Dropping" fait la même chose pour conserver la cadence en image par secondes.

- "No Sync" fait ce qu'on imagine bien, rien.

J'espère que ça pourra t'aider.

Contribution le : 14/03 19:39:13
Créer un fichier PDF de la contribution Imprimer


Re: Aligner / Ajuster / Synchroniser Musique et vue 3D avant rendu
Clan Afficionado
Inscrit:
22/10/2010 09:23
Post(s): 61
GENIAL vraiment merci beaucoup tu as pointé juste !!!

A un détail près... c'est que les options dans mon menu ne sont pas exactement sous les mêmes libellés (Blender v 2.79)

J'ai :
AV Sync (synch to audio playback)
Frame Droping (drop frames if playback is to slow)
No sync (do not synch play every frames)

Et le résultat semble tout à fait correspondre à ce que tu décris. J'ai sélectionné AV Sync et ça a l'air de bien fonctionner. Deux choses m'étonnent : dans ce mode on ne voit pas de saut de frame, le frame rate est plus élevé mais ne correspond pas à 24/s. A part ça je pensais avoir un très bon PC mais c'était il y a trop longtemps apparemment lol.

Encore MERCI pour votre aide !

Contribution le : 14/03 22:23:26
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses décomposer une surface ? 3 53 Aujourd'hui 11:44:24
moonboots 
Questions & Réponses copier-coller 1 8 Aujourd'hui 11:35:14
moonboots 
Questions & Réponses Creation petit alien 7 62 Aujourd'hui 10:12:58
moonboots 
Questions & Réponses performance 2 69 Hier 17:55:54
fenixdragon 
Questions & Réponses Passer un modèle de l'Internal à Cycles 1 40 Hier 15:29:52
Gilead_Maerlyn 
Questions & Réponses faire des nuages (autrement qu'avec cloud generator qui fait tout rammer) 4 214 Hier 15:02:43
Blabla 
Questions & Réponses [non résolu] Optimiser Eevee (Blender 2.8) 2 153 Hier 15:00:07
Okinage 
[WIP] et travaux terminés [WIP] Clash of bûches - Unity    [1][2] 10 4611 Hier 14:06:45
smog 
Concours Défi du clan 2018 n°27 / Thème : LEGO    [1][2] 18 374 Hier 13:37:56
titi38360 
[WIP] et travaux terminés [terminé] Terre des ours 1 64 Hier 09:26:47
Hook 
Questions & Réponses [résolu] Perte de l'UVMap lors d'une fusion 6 132 17/12 11:50:05
Horemheb 
Questions & Réponses rotation de l'axe d'origine ? 2 99 17/12 11:47:30
Pixtim 
Questions & Réponses [non résolu] Image de référence    [1][2] 10 172 16/12 21:02:59
blend74 
Questions & Réponses [résolu] Les limites de mouvement dans la cinématique inverse 3 89 16/12 21:02:03
Zarathoustra 
Mes premières images sous Blender (débutants) mon premier bonzai low poly (un peu déplumé)    [1][2][3][4] 30 1759 16/12 20:56:02
blend74 
Mes premières images sous Blender (débutants) Océan 4 122 16/12 14:20:39
blend74 
Graphisme alternatif Le topic des trucs à télécharger    [1][2][3]...[26] 251 113969 16/12 13:54:38
blend74 
Questions & Réponses [non résolu] Problème avec Texture paint 4 81 15/12 21:01:25
GuiGeex 
Questions & Réponses [non résolu] problème en particle mode ? 0 49 15/12 15:31:46
GuiGeex 
Questions & Réponses [non résolu] conseils svp pour modéliser un personnage    [1][2][3][4] 32 1796 15/12 09:27:05
blendinfos 

Qui est en ligne
39 utilisateur(s) en ligne (dont 24 sur Forums)

Membre(s): 0
Invité(s): 39


plus...
Nouveaux membres
DennisHank 19/12/2018
VBPAnnmari 19/12/2018
Jasmin0800 19/12/2018
JoanaRibei 19/12/2018
Joanne1893 19/12/2018
Joana3078 19/12/2018
ChasNixon 19/12/2018
TimG470175 19/12/2018
RigobertoL 19/12/2018
RubinFrank 19/12/2018
Dernier Ajout
platine3.jpg

Evènements à venir
Dec 29
Anniversaire d'ebrain
Jan 12
BUG de Lyon
Fev 15
Anniversaire de Dany
plus 296 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2018 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445