(1) 2 »


Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Bonjour à tous :)

Je suis en train de créer l'animation d'un véhicule le long d'un chemin.

J'ai utilisé pour cela la contrainte "Follow Path", et un empty censé permettre la rotation des roues et l'arrêt du véhicule à certains points du chemin et de la timeline.

A mon véhicule, j'ai appliqué la contrainte "Follow Path" et un driver, l'empty sur l'axe Y.
A ce stade, mon véhicule suit la route.

Cela semble fonctionner, mais je rencontre un problème : Lorsque je "tire" l'empty sur Y, il entraine bien mon véhicule.
En revanche, lorsque je lance l'animation, le véhicule avance indépendamment de l'empty qui pourtant est son driver.
Je m'explique par un exemple : si je souhaite que mon véhicule ne démarre qu'à partir de la frame 200, je me positionne à 200 sur la timeline, et j'insère une keyframe 0 sur l'empty.
Ainsi celui-ci se repositionne à 0 et ne démarre pas avant la frame 200.
Le problème est que le véhicule démarre, lui, comme s'il était indépendant le l'empty.


Voilà, je suis bloqué sur ce point et j'aurais bien besoin d'un petit coup de main. Je suppose que j'oublie un paramètre mais je ne vois pas du tout où est mon problème

Je joins deux captures de mes réglages

Merci d'avance pour votre aide





Contribution le : 08/04/2019 08:08
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1936
Bonjour, Luc.

Je ne sais pas pourquoi tu as besoin d'un driver pour déplacer ton véhicule. Tu as peut-être tes raisons.

Tu pourrais déplacer ton véhicule directement avec une contrainte Follow Path. Tu te servirais du paramètre "Evaluation Time" de ton chemin pour mettre tes clefs d'animation.

Si tu veux faire ça avec un Empty, tu ferais la même chose que dit précédemment, et soit tu parenterais ton véhicule à l'Empty, soit tu appliquerais une contrainte "Copy Location" au véhicule avec l'Empty comme Target.

Pour l'Empty qui doit gérer la rotation des roues (sur elles-mêmes ou pour braquer ?) je ne comprends pas.

Si c'est pour que les roues tournent sur elles-mêmes en avançant, il suffit de mettre un driver sur les roues en "Average Value" vers ton chemin (Prop) et son Evaluation Time (en copiant le Data Block de celui-ci et en le collant dans la seconde case (Path) de ton Average Value. Après tu dois mettre un multiplicateur dans l'onglet Modifier de ton driver pour ajuster la quantité de rotation des roues.

Ensuite tu répètes l'opération pour chaque autre roue, ou plus simple tu leur colles une contrainte Copy Rotation.

En résumé, un Empty est inutile.

EDIT : Je t'ai mis un Blend simplifié sur PasteAll.

Contribution le : 08/04/2019 09:08
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci pour ta réponse Rimpotche :)

Pour répondre, cette animation est destinée à FSX. FSX n'accepte pas tous les modificateurs venant de Blender, d'après ce que j'ai compris au fil de mes recherches.

L'Empty, driver du véhicule ici sur Y, est une solution que j'ai trouvée, compatible, pour que les roues tournent sur elles-mêmes et proportionnellement à la vitesse de véhicule.

Je viens à l'instant de remplacer mon "path" par une "courbe de bézier" et tout fonctionne…. Un peu étrange mais peut-être est-ce normal ?

Il me reste à faire la rotation des roues avant sur Z (le braquage). Je peux la faire manuellement. Mais je cherche à la faire automatiquement. Avec ma méthode, ça n'a pas l'air évident.

J'ai envie quand même d'essayer d'applique la méthode que tu me donne

Contribution le : 08/04/2019 09:29
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci pour ta réponse Rimpotche :)

Pour répondre, cette animation est destinée à FSX. FSX n'accepte pas tous les modificateurs venant de Blender, d'après ce que j'ai compris au fil de mes recherches.

L'Empty, driver du véhicule ici sur Y, est une solution que j'ai trouvée, compatible, pour que les roues tournent sur elles-mêmes et proportionnellement à la vitesse de véhicule.

Je viens à l'instant de remplacer mon "path" par une "courbe de bézier" et tout fonctionne…. Un peu étrange mais peut-être est-ce normal ?

Il me reste à faire la rotation des roues avant sur Z (le braquage). Je peux la faire manuellement. Mais je cherche à la faire automatiquement. Avec ma méthode, ça n'a pas l'air évident.

J'ai envie quand même d'essayer d'applique la méthode que tu me donne

Contribution le : 08/04/2019 09:29
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1936
Regarde plus haut, pendant que tu me répondais, je t'ai mis un Blend dans mon précédent message, au cas où...

Contribution le : 08/04/2019 09:33
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1936
Je comprends mieux. Là, évidemmment, pour le braquage, tu pourrais mettre un Empty sur une copie du chemin, un poil en avance sur le véhicule et mettre un TrackTo (avec correction de l'angle) sur l'axe Z de tes roues avant.
Pourquoi une "copie" du chemin ? Parce que l'Evaluation Time ne sert qu'une fois et que celle du chemin 1 est déjà prise par le véhicule.

Contribution le : 08/04/2019 09:48
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Je regarde ton exemple. Le véhicule suit bien la courbe via l'empty mais son orientation est fixe (il ne pivote pas dans les virages).

Je dois, je pense, rajouter un paramètre.

Contribution le : 08/04/2019 10:30
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1936
Oui, j'avais fait au plus vite, et j'avais essayé comme toi de mettre un empty... inutile.
Alors voici un autre blend sans l'empty, et le vehicule tourne bien dans les virages.

Contribution le : 08/04/2019 12:54
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci :)
J'étais absent une partie de l'après midi, désolé pour le retard.

Je regarde ton fichier très vite

Contribution le : 08/04/2019 16:48
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Coucou :)

Impecable, ça semble fonctionner pour FSX.

Par contre, Mon animation est un véhicule assez long, un camion.
Tout va bien, mais dans les virages, l'arrière chasse vers l'extérieur. C'est normal, je pense du fait du point pivot. J'ai essayé de le déplaçer vers l'arrière du véhicule. Ca atténue un peu le problème, mais ce n'est pas encore ça.




Y a t-il un moyen pour que les axes arrière et avant soient tous deux "accrochés" à la courbe ? Comme dans la réalité, en fait

Contribution le : 11/04/2019 15:39
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Méthode de référence : verre avec Eevee 2 27 Aujourd'hui 21:27:16
tykrane 
Questions & Réponses comment importer un fichier makehuman avec son armature dans blender 2.82 ? 0 27 Aujourd'hui 15:20:21
fouyou 
Questions & Réponses [non résolu] Fluide passe à travers obstacle    [1][2] 14 224 Aujourd'hui 15:18:15
alexmge 
Questions & Réponses [Bones]renomer en symétire 3 119 Hier 19:47:55
pierre-y 
Questions & Réponses [résolu] Perte de vue de mon objet par des zones grises 2 129 Hier 18:13:42
Olguern 
Questions & Réponses [Quaternion] Que represente le w dans la rotation en quaternion? 1 103 Hier 14:18:02
Redstar 
Questions & Réponses Century fox rendu pas top    [1][2] 12 274 23/02 11:21:57
Rimpotche 
Questions & Réponses Installer une ancienne version pour Blend4web 4 178 21/02 18:44:19
Rimpotche 
Questions & Réponses [résolu] Array autour d'un axe 3 132 22/02 16:52:12
Crocodile_13 
Questions & Réponses eevee radiosité 3 144 24/02 17:15:34
Rimpotche 
Questions & Réponses entailler texte sur surface courbe en ayant quads 4 143 Hier 07:19:14
tykrane 
Questions & Réponses [résolu] Problèmes de rendu avec les dimensions d'la caméra 3 129 Hier 09:54:47
lollito 
Questions & Réponses modélisation 3d blender vue 1 46 Hier 12:25:17
Rimpotche 
Questions & Réponses [résolu] Snapping avec Blender 2.81 3 94 25/02 15:42:50
TVISARL 
[WIP] et travaux terminés [WIP] Projet Tales & Legends    [1][2][3]...[12] 110 37192 25/02 12:06:15
Redstar 
Questions & Réponses [résolu] texte blender n’apparaît pas en impression 3D 3 78 25/02 10:15:15
kepkep 
Le coin des geeks InstallJammer 0 63 24/02 17:14:37
Redstar 
Questions & Réponses Dessinner sur un calque 1 87 24/02 14:56:58
Rimpotche 
Moteur de jeu GameBlender et alternatives [non résolu] Tour du monde et pathfiding 4 143 24/02 13:56:44
Redstar 
[WIP] et travaux terminés [WIP] Akihabara 3 236 23/02 17:18:36
stev 

Qui est en ligne
72 utilisateur(s) en ligne (dont 41 sur Forums)

Membre(s): 0
Invité(s): 72


plus...
Nouveaux membres
RenaRitchi 27/2/2020
CruzPermew 27/2/2020
JeremiahPo 27/2/2020
HGRMeagan 27/2/2020
DebbieGabr 27/2/2020
KrystleD14 27/2/2020
Tosha13383 27/2/2020
Fred25F214 27/2/2020
RXOEmory18 27/2/2020
AlanaNemet 27/2/2020
Dernier Ajout
mirages-preview~0.jpg

Evènements à venir
Mar 14
Anniversaire de AMV12
Mar 16
Anniversaire de galba
Mar 29
GeeWee's B-Day
plus 273 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445