Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
bathroom_final_small.png
Publicité
Formation Blender ElephormBlender 3d Elephorm


     




(1) 2 »


Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Bonjour à tous :)

Je suis en train de créer l'animation d'un véhicule le long d'un chemin.

J'ai utilisé pour cela la contrainte "Follow Path", et un empty censé permettre la rotation des roues et l'arrêt du véhicule à certains points du chemin et de la timeline.

A mon véhicule, j'ai appliqué la contrainte "Follow Path" et un driver, l'empty sur l'axe Y.
A ce stade, mon véhicule suit la route.

Cela semble fonctionner, mais je rencontre un problème : Lorsque je "tire" l'empty sur Y, il entraine bien mon véhicule.
En revanche, lorsque je lance l'animation, le véhicule avance indépendamment de l'empty qui pourtant est son driver.
Je m'explique par un exemple : si je souhaite que mon véhicule ne démarre qu'à partir de la frame 200, je me positionne à 200 sur la timeline, et j'insère une keyframe 0 sur l'empty.
Ainsi celui-ci se repositionne à 0 et ne démarre pas avant la frame 200.
Le problème est que le véhicule démarre, lui, comme s'il était indépendant le l'empty.


Voilà, je suis bloqué sur ce point et j'aurais bien besoin d'un petit coup de main. Je suppose que j'oublie un paramètre mais je ne vois pas du tout où est mon problème

Je joins deux captures de mes réglages

Merci d'avance pour votre aide





Contribution le : 08/04 08:08:14
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1502
Bonjour, Luc.

Je ne sais pas pourquoi tu as besoin d'un driver pour déplacer ton véhicule. Tu as peut-être tes raisons.

Tu pourrais déplacer ton véhicule directement avec une contrainte Follow Path. Tu te servirais du paramètre "Evaluation Time" de ton chemin pour mettre tes clefs d'animation.

Si tu veux faire ça avec un Empty, tu ferais la même chose que dit précédemment, et soit tu parenterais ton véhicule à l'Empty, soit tu appliquerais une contrainte "Copy Location" au véhicule avec l'Empty comme Target.

Pour l'Empty qui doit gérer la rotation des roues (sur elles-mêmes ou pour braquer ?) je ne comprends pas.

Si c'est pour que les roues tournent sur elles-mêmes en avançant, il suffit de mettre un driver sur les roues en "Average Value" vers ton chemin (Prop) et son Evaluation Time (en copiant le Data Block de celui-ci et en le collant dans la seconde case (Path) de ton Average Value. Après tu dois mettre un multiplicateur dans l'onglet Modifier de ton driver pour ajuster la quantité de rotation des roues.

Ensuite tu répètes l'opération pour chaque autre roue, ou plus simple tu leur colles une contrainte Copy Rotation.

En résumé, un Empty est inutile.

EDIT : Je t'ai mis un Blend simplifié sur PasteAll.

Contribution le : 08/04 09:08:56
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci pour ta réponse Rimpotche :)

Pour répondre, cette animation est destinée à FSX. FSX n'accepte pas tous les modificateurs venant de Blender, d'après ce que j'ai compris au fil de mes recherches.

L'Empty, driver du véhicule ici sur Y, est une solution que j'ai trouvée, compatible, pour que les roues tournent sur elles-mêmes et proportionnellement à la vitesse de véhicule.

Je viens à l'instant de remplacer mon "path" par une "courbe de bézier" et tout fonctionne…. Un peu étrange mais peut-être est-ce normal ?

Il me reste à faire la rotation des roues avant sur Z (le braquage). Je peux la faire manuellement. Mais je cherche à la faire automatiquement. Avec ma méthode, ça n'a pas l'air évident.

J'ai envie quand même d'essayer d'applique la méthode que tu me donne

Contribution le : 08/04 09:29:30
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci pour ta réponse Rimpotche :)

Pour répondre, cette animation est destinée à FSX. FSX n'accepte pas tous les modificateurs venant de Blender, d'après ce que j'ai compris au fil de mes recherches.

L'Empty, driver du véhicule ici sur Y, est une solution que j'ai trouvée, compatible, pour que les roues tournent sur elles-mêmes et proportionnellement à la vitesse de véhicule.

Je viens à l'instant de remplacer mon "path" par une "courbe de bézier" et tout fonctionne…. Un peu étrange mais peut-être est-ce normal ?

Il me reste à faire la rotation des roues avant sur Z (le braquage). Je peux la faire manuellement. Mais je cherche à la faire automatiquement. Avec ma méthode, ça n'a pas l'air évident.

J'ai envie quand même d'essayer d'applique la méthode que tu me donne

Contribution le : 08/04 09:29:31
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1502
Regarde plus haut, pendant que tu me répondais, je t'ai mis un Blend dans mon précédent message, au cas où...

Contribution le : 08/04 09:33:23
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1502
Je comprends mieux. Là, évidemmment, pour le braquage, tu pourrais mettre un Empty sur une copie du chemin, un poil en avance sur le véhicule et mettre un TrackTo (avec correction de l'angle) sur l'axe Z de tes roues avant.
Pourquoi une "copie" du chemin ? Parce que l'Evaluation Time ne sert qu'une fois et que celle du chemin 1 est déjà prise par le véhicule.

Contribution le : 08/04 09:48:32
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Je regarde ton exemple. Le véhicule suit bien la courbe via l'empty mais son orientation est fixe (il ne pivote pas dans les virages).

Je dois, je pense, rajouter un paramètre.

Contribution le : 08/04 10:30:53
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1502
Oui, j'avais fait au plus vite, et j'avais essayé comme toi de mettre un empty... inutile.
Alors voici un autre blend sans l'empty, et le vehicule tourne bien dans les virages.

Contribution le : 08/04 12:54:58
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci :)
J'étais absent une partie de l'après midi, désolé pour le retard.

Je regarde ton fichier très vite

Contribution le : 08/04 16:48:53
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Coucou :)

Impecable, ça semble fonctionner pour FSX.

Par contre, Mon animation est un véhicule assez long, un camion.
Tout va bien, mais dans les virages, l'arrière chasse vers l'extérieur. C'est normal, je pense du fait du point pivot. J'ai essayé de le déplaçer vers l'arrière du véhicule. Ca atténue un peu le problème, mais ce n'est pas encore ça.




Y a t-il un moyen pour que les axes arrière et avant soient tous deux "accrochés" à la courbe ? Comme dans la réalité, en fait

Contribution le : 11/04 15:39:43
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Moteur de jeu GameBlender et alternatives Parenter armature 2 111 Hier 18:26:05
moonboots 
Questions & Réponses Supprimer sommets en double 4 65 Hier 16:40:46
thierry_st_malo 
Questions & Réponses [non résolu] problème de caméra (et de rendu ?)    [1][2] 12 78 Hier 16:06:33
blendinfos 
Mes premières images sous Blender (débutants) mes trucs de noob    [1][2][3]...[16] 153 9788 Hier 13:17:56
blend74 
Moteur de jeu GameBlender et alternatives Personnage catapulté 4 95 Hier 11:03:31
MaGe 
Questions & Réponses [non résolu] conseils svp pour modéliser un personnage    [1][2][3]...[6] 51 4355 Hier 08:43:07
blendinfos 
Questions & Réponses [résolu] prblm rendu caméra    [1][2] 11 838 Hier 08:22:59
blendinfos 
Questions & Réponses [non résolu] aligner plusieurs vertices dans un même plan 2 39 Hier 07:12:25
Rimpotche 
[WIP] et travaux terminés [WIP] Portrait réaliste - Zbrush/Blender    [1][2][3][4] 30 1733 21/04 10:19:50
Papa_Dragon 
Questions & Réponses Exportation avec smooth (.fbx) 3 69 20/04 16:54:10
Redstar 
Questions & Réponses [résolu] Point d'Origine du squelette 1 64 20/04 08:52:17
Zarathoustra 
Questions & Réponses shape key vs NLA 2 99 20/04 06:15:26
Corpia 
The Blender Clan 'tchat Blender 2.8x : Actus, tests, feedback..    [1][2][3] 27 15939 19/04 10:34:50
lucky 
Questions & Réponses [résolu] Copie de materials ... 5 116 17/04 13:46:02
simonchoops 
Questions & Réponses [résolu] Freestyle line en pointillés sur rendu 8 331 17/04 11:11:37
Zear 
Questions & Réponses Enregistrer une animation 6 219 16/04 10:52:25
Okinage 
Mes premières images sous Blender (débutants) reprise    [1][2][3]...[11] 109 7288 14/04 17:59:52
tykrane 
Questions & Réponses [résolu] j'aimerais que mon environnement ne light qu'un objet 9 255 13/04 12:54:59
komenkonfai 
Questions & Réponses Animation vehicule : Problème de driver    [1][2] 12 348 11/04 21:32:42
Teluma 
The Blender Clan 'tchat Urgent recherche stage non rémunéré 0 155 11/04 18:33:28
FoxRock 

Qui est en ligne
22 utilisateur(s) en ligne (dont 14 sur Forums)

Membre(s): 0
Invité(s): 22


plus...
Nouveaux membres
GenieZelma 23/4/2019
YvetteKall 23/4/2019
FerminFend 23/4/2019
canabalt 23/4/2019
Blaceyes 20/4/2019
MaGe 19/4/2019
Wanzenkova 11/4/2019
krasarah225 11/4/2019
RemiB 9/4/2019
killiann 8/4/2019
Dernier Ajout
super8_2.jpg

Evènements à venir
Mai 7
Anniv OlivS
Mai 18
Anniversaire Luneo
Jui 30
Anniv des Jedi :-D
plus 287 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2019 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445