(1) 2 »


Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Bonjour à tous :)

Je suis en train de créer l'animation d'un véhicule le long d'un chemin.

J'ai utilisé pour cela la contrainte "Follow Path", et un empty censé permettre la rotation des roues et l'arrêt du véhicule à certains points du chemin et de la timeline.

A mon véhicule, j'ai appliqué la contrainte "Follow Path" et un driver, l'empty sur l'axe Y.
A ce stade, mon véhicule suit la route.

Cela semble fonctionner, mais je rencontre un problème : Lorsque je "tire" l'empty sur Y, il entraine bien mon véhicule.
En revanche, lorsque je lance l'animation, le véhicule avance indépendamment de l'empty qui pourtant est son driver.
Je m'explique par un exemple : si je souhaite que mon véhicule ne démarre qu'à partir de la frame 200, je me positionne à 200 sur la timeline, et j'insère une keyframe 0 sur l'empty.
Ainsi celui-ci se repositionne à 0 et ne démarre pas avant la frame 200.
Le problème est que le véhicule démarre, lui, comme s'il était indépendant le l'empty.


Voilà, je suis bloqué sur ce point et j'aurais bien besoin d'un petit coup de main. Je suppose que j'oublie un paramètre mais je ne vois pas du tout où est mon problème

Je joins deux captures de mes réglages

Merci d'avance pour votre aide





Contribution le : 08/04/2019 08:08
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2382
Bonjour, Luc.

Je ne sais pas pourquoi tu as besoin d'un driver pour déplacer ton véhicule. Tu as peut-être tes raisons.

Tu pourrais déplacer ton véhicule directement avec une contrainte Follow Path. Tu te servirais du paramètre "Evaluation Time" de ton chemin pour mettre tes clefs d'animation.

Si tu veux faire ça avec un Empty, tu ferais la même chose que dit précédemment, et soit tu parenterais ton véhicule à l'Empty, soit tu appliquerais une contrainte "Copy Location" au véhicule avec l'Empty comme Target.

Pour l'Empty qui doit gérer la rotation des roues (sur elles-mêmes ou pour braquer ?) je ne comprends pas.

Si c'est pour que les roues tournent sur elles-mêmes en avançant, il suffit de mettre un driver sur les roues en "Average Value" vers ton chemin (Prop) et son Evaluation Time (en copiant le Data Block de celui-ci et en le collant dans la seconde case (Path) de ton Average Value. Après tu dois mettre un multiplicateur dans l'onglet Modifier de ton driver pour ajuster la quantité de rotation des roues.

Ensuite tu répètes l'opération pour chaque autre roue, ou plus simple tu leur colles une contrainte Copy Rotation.

En résumé, un Empty est inutile.

EDIT : Je t'ai mis un Blend simplifié sur PasteAll.

Contribution le : 08/04/2019 09:08
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci pour ta réponse Rimpotche :)

Pour répondre, cette animation est destinée à FSX. FSX n'accepte pas tous les modificateurs venant de Blender, d'après ce que j'ai compris au fil de mes recherches.

L'Empty, driver du véhicule ici sur Y, est une solution que j'ai trouvée, compatible, pour que les roues tournent sur elles-mêmes et proportionnellement à la vitesse de véhicule.

Je viens à l'instant de remplacer mon "path" par une "courbe de bézier" et tout fonctionne…. Un peu étrange mais peut-être est-ce normal ?

Il me reste à faire la rotation des roues avant sur Z (le braquage). Je peux la faire manuellement. Mais je cherche à la faire automatiquement. Avec ma méthode, ça n'a pas l'air évident.

J'ai envie quand même d'essayer d'applique la méthode que tu me donne

Contribution le : 08/04/2019 09:29
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci pour ta réponse Rimpotche :)

Pour répondre, cette animation est destinée à FSX. FSX n'accepte pas tous les modificateurs venant de Blender, d'après ce que j'ai compris au fil de mes recherches.

L'Empty, driver du véhicule ici sur Y, est une solution que j'ai trouvée, compatible, pour que les roues tournent sur elles-mêmes et proportionnellement à la vitesse de véhicule.

Je viens à l'instant de remplacer mon "path" par une "courbe de bézier" et tout fonctionne…. Un peu étrange mais peut-être est-ce normal ?

Il me reste à faire la rotation des roues avant sur Z (le braquage). Je peux la faire manuellement. Mais je cherche à la faire automatiquement. Avec ma méthode, ça n'a pas l'air évident.

J'ai envie quand même d'essayer d'applique la méthode que tu me donne

Contribution le : 08/04/2019 09:29
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2382
Regarde plus haut, pendant que tu me répondais, je t'ai mis un Blend dans mon précédent message, au cas où...

Contribution le : 08/04/2019 09:33
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2382
Je comprends mieux. Là, évidemmment, pour le braquage, tu pourrais mettre un Empty sur une copie du chemin, un poil en avance sur le véhicule et mettre un TrackTo (avec correction de l'angle) sur l'axe Z de tes roues avant.
Pourquoi une "copie" du chemin ? Parce que l'Evaluation Time ne sert qu'une fois et que celle du chemin 1 est déjà prise par le véhicule.

Contribution le : 08/04/2019 09:48
_________________
Des soucis, un SOUCI !
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Je regarde ton exemple. Le véhicule suit bien la courbe via l'empty mais son orientation est fixe (il ne pivote pas dans les virages).

Je dois, je pense, rajouter un paramètre.

Contribution le : 08/04/2019 10:30
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2382
Oui, j'avais fait au plus vite, et j'avais essayé comme toi de mettre un empty... inutile.
Alors voici un autre blend sans l'empty, et le vehicule tourne bien dans les virages.

Contribution le : 08/04/2019 12:54
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Merci :)
J'étais absent une partie de l'après midi, désolé pour le retard.

Je regarde ton fichier très vite

Contribution le : 08/04/2019 16:48
Créer un fichier PDF de la contribution Imprimer


Re: Animation vehicule : Problème de driver
Blendie
Inscrit:
23/01/2017 13:29
Post(s): 27
Coucou :)

Impecable, ça semble fonctionner pour FSX.

Par contre, Mon animation est un véhicule assez long, un camion.
Tout va bien, mais dans les virages, l'arrière chasse vers l'extérieur. C'est normal, je pense du fait du point pivot. J'ai essayé de le déplaçer vers l'arrière du véhicule. Ca atténue un peu le problème, mais ce n'est pas encore ça.




Y a t-il un moyen pour que les axes arrière et avant soient tous deux "accrochés" à la courbe ? Comme dans la réalité, en fait

Contribution le : 11/04/2019 15:39
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
[WIP] et travaux terminés bas sculpture corps    [1][2][3] 25 582 Aujourd'hui 02:10:59
prometheusx 
Questions & Réponses Mesure de plusieurs objet Blender 2.82 3 51 Hier 19:38:58
Rimpotche 
Le coin des geeks Vieilles cartes graphiques : Quadro FX5800 ou Quadro 4000 ? 4 304 Hier 15:22:46
patapote 
Moteur de jeu GameBlender et alternatives hARMful engine    [1][2][3]...[9] 83 9350 Hier 12:59:48
Bibi09 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Première version disponible !    [1][2][3]...[57] 561 93889 Hier 12:36:01
Bibi09 
Moteur de jeu GameBlender et alternatives [WIP] Cs (zones sol, héliport)    [1][2][3]...[41] 405 133757 Hier 07:52:57
Redstar 
Questions & Réponses problème radeon pro render vêtements transparents 0 71 09/07 18:49:17
soloic 
Questions & Réponses [résolu] "vieux" fichier blender "invisible"    [1][2] 11 966 09/07 16:03:24
kinder 
Questions & Réponses [non résolu] Adoucir les courbes et espacer uniformément les vertices dans l'UV Map 2 232 09/07 13:35:44
moonboots 
Le coin des geeks pc bas prix    [1][2][3] 20 428 09/07 09:34:29
Bibi09 
Questions & Réponses [terminé] contrôle de l'angle d'incision du chanfrein/bevel 2 91 08/07 16:08:24
halphasten 
The Blender Clan 'tchat Clignotement de l'interface de blender 7 386 08/07 13:13:40
zezer 
Questions & Réponses Pass index 1 84 08/07 12:47:07
Rimpotche 
[WIP] et travaux terminés [terminé] court métrage 2020 8 280 07/07 18:44:19
flahaut 
Questions & Réponses épaisseur sur une texture 6 150 07/07 15:28:27
moonboots 
Questions & Réponses [résolu] Affichage de la grille du plan et des axes 2 118 07/07 14:27:44
gedru 
Questions & Réponses [résolu] Blender 2.80 ne démarre pas 7 1155 07/07 09:42:16
geo160 
Questions & Réponses Knife tool a arrêté de fonctionner 1 102 06/07 16:29:51
Rimpotche 
Hors Sujet !! Système solaire open source 5 1594 26/12/2019 12:46
Bibi09 
Questions & Réponses [non résolu] Ecran bleu 2 145 05/07 18:35:32
alexmge 

Qui est en ligne
77 utilisateur(s) en ligne (dont 57 sur Forums)

Membre(s): 0
Invité(s): 77


plus...
Nouveaux membres
Erna37Q172 12/7/2020
RaquelBach 12/7/2020
ArleenChee 12/7/2020
JurgenOng0 12/7/2020
BarryRiver 12/7/2020
FlorianMcC 12/7/2020
KariMcKell 12/7/2020
Merri1054 12/7/2020
ErickBratc 12/7/2020
ArnulfoMan 12/7/2020
Dernier Ajout
mirages-preview~0.jpg

Evènements à venir
Jui 23
Anniv du BlenderClan !
Aou 7
anniversaire Cem47
Aou 13
Anniversaire Siskas
plus 268 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445