Connexion
Menu Principal
Recherche
Menu secondaire
Image Aléatoire
Neoti DL 3.jpg
Publicité
Formation Blender ElephormBlender 3d Elephorm


     






Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 17:06:16
Post(s): 9
Bonjounr à toutes et à tous ami(e)s blenderien(ne)s. Ce topic est la remontée du topic que j'avais posté la semaine dernière et dont j'avais je pense mal formulé le titre d'où une possible mauvaise compréhension de ma demande : http://blenderclan.tuxfamily.org/html/modules/newbb/viewtopic.php?topic_id=49239&forum=1

J'utilise Blender moins pour ses fonctions de modélisation 3D que pour ses fonctions d'animation à partir d'images 2D importées. Ces courtes animations sont ensuites rajoutées à des montages vidéos faits avec un autre logiciel.

Concrètement sous Blender 2.8 dans la vue de modélisation 3D par défaut j'ai ajouté une image d'arrière-plan ( (Add -> Image -> Background) et après rajouté une image de plus petite taille en avant-plan destinée à être animée ((Add -> Image -> Background). J'ai ajouté à cette dernière image un effet de déplacement simple de gauche à droite par keyframes.

Jusqu'à maintenant le rendu de cette animation (ALT+F12)aboutissait à un plantage de Blender et à une fermeture immédiate du logiciel.Je me suis rendu compte que ceci venait du type de rendu qui était Eevee par défaut (barre d'outils de droite : Render-Engine). Le type de rendu chois passant à Workbench ou Cycles plus de plantage : le rendu se lance .. et aboutit à une vidéo montrant une image noire uniforme tout le long de l'animation. A explorer et modifier les paramètres de rendu j'ai pu aboutir à une vidéo de couleur grise () mais impossible d'avoir un rendu correct. Avec la version 2.79 je dois avouer que je n'avais pas ce souci.

Donc est-ce que quelqu'un peut me conseiller comment régler ces paramètres de rendu pour que mon animation soit correctement rendue ?

Je suis désolé si ma question semble être une question de newbie/débutant mais ... c'est ce que je suis

Contribution le : 01/09 13:03:30
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1672
Bonjour, Mikienko.

En tapant dans goût-gueule "Blender Add Image Background",
on trouve cette page, qui dit :
"In Blender, reference images can be vital, especially for new artists. Figuring out how to create and manipulate faces can be hard enough, without worrying about the anatomy of the model itself.

Thankfully, Blender has a nifty feature called “Background Images”. By directly importing an image into your workspace, you can easily make it your reference. The image only appears when your view is aligned with the axes and doesn’t appear in your final render.

For example, if you want to make an exact replica of a part to 3D print, you can simply take a picture of it. Using that as your reference, you don’t need to worry about getting exact measurements for each part."

Donc ça dit clairement que l'image n'apparaît pas au rendu.

Je n'avais jamais utilisé cette fonction, c'est pourquoi j'ai cherché à en savoir plus.

A mon avis, pour ce que tu veux faire, il vaudrait mieux utiliser "Import Image as Plane" qui est toujours rendue
pour peu qu'on l'éclaire avec des lampes ou qu'on la mette en "Emission" avec un node shader du même nom.

Donc essaye ça, et si cà ne marche pas mieux, mets-nous ton blend (par exemple avec pasteall.org). N'oublie pas de "packer" ton image dans ton blend, sinon on ne pourra pas t'aider efficacement.

Contribution le : 01/09 13:48:34
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 17:06:16
Post(s): 9
Merci beaucoup ! Je vais tester de cette façon et si ça plante encore j'enverrais mon .blend.
Question idiote : que signifie "packer" une image dans un .blend file ?

Contribution le : 01/09 14:32:46
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1672
Citation :

Mikienko a écrit: Question idiote : que signifie "packer" une image dans un .blend file ?

Ta question n'est pas idiote, mais tu pourrais peut-être faire quelques recherches... Il y a plein de réponses à cette question sur le net. Par exemple celle-ci.

Contribution le : 01/09 14:39:49
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 17:06:16
Post(s): 9
Honte sur moi ! Merci pour le tuyau. Je me penche sur mon fichier blend et je vais faire en sorte d'arranger tout ça.
Merci encore.

Contribution le : 01/09 15:40:29
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1672
Je te conseille d'utiliser un seul node shader pour tes images : "Emission" en laissant les paramètres par défaut, c'est-à-dire blanc et Strength à 1.000. Ainsi tes images seront rendues telles quelles. Si elles sont trop claires ou trop sombres, tu peux jouer sur le Strength. Ainsi pas besoin d'éclairage.

Contribution le : 01/09 16:16:03
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 17:06:16
Post(s): 9
Merci beaucoup Rimpotche. Après moults et moults tests j'ai l'impression que le Node Shader "Emission" n'est disponible que dans le type de rendu EEvee .. qui fait planter Blender. Grrr !
La je commence à m'arracher les cheveux. Je me suis permis de mettre à disposition le fichier .blend ici : http://pasteall.org/blend/index.php?id=52264. Si quelqu'un peut se penche sur le problème et le résoudre eh bien ... vraiment un grand merci !
Sinon ne vous prenez pas la tête. Dans le pire des cas je referais mes animations sous Blender 2.79.
Encore merci pour votre aide et bonne soirée

Contribution le : 01/09 17:45:37
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 1672
Plusieurs choses. Ton blend fait 0 octets. Donc impossible à lire.
Ensuite tous les shaders sur 2.80 sont valables pour Eevee comme pour Cycles.
C'est compliqué d'utiliser un logiciel sans passer par la base.
Alors, je te conseille en effet d'utiliser le Blender Render sur 2.79 qui te donnera un rendu beaucoup plus rapide et suffisant pour ce que tu veux faire. Et dans le Blender Render, dans le shading du Material de tes images, coche "Shadeless" qui correspond à "Emission" dans Cycles ou Eevee.
Ainsi pas besoin de lampes, tes images ou animations que tu déplaces seront rendues telles quelles.

Contribution le : 01/09 17:55:39
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 17:06:16
Post(s): 9
Merci beaucoup. Je vais faire comme ça. Bonne soirée à vous

Contribution le : 01/09 18:47:36
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
28/07 16:07:50
Post(s): 11
Comment faut-il faire sur Blender 2.8 pour adapter un bvh à un personnage MHx2 ? Je ne retrouve plus la fonction load and retarget de Blender 2.7 !

Merci de bien vouloir me répondre !

Contribution le : 04/09 17:07:59
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Blender 2.80 ne démarre pas 0 1 Aujourd'hui 16:51:31
touvenant 
Questions & Réponses Selection d'images pour le VSE 4 190 Aujourd'hui 16:27:31
WinZs 
Questions & Réponses Conseils pour la modélisation du visage 2 85 Aujourd'hui 16:22:42
moonboots 
Questions & Réponses [résolu] Conseil pour une topologie 8 205 Aujourd'hui 12:19:21
blendinfos 
Questions & Réponses Fusionner faces périphériques ? 7 89 Aujourd'hui 11:33:20
Guppy88 
Questions & Réponses [non résolu] Blend4web : exporter les textures 2 104 Aujourd'hui 08:43:17
blendinfos 
Questions & Réponses [résolu] Comment flouter uniquement le premier plan ? 4 85 Hier 19:43:35
Anton78 
Questions & Réponses [non résolu] Lignes de coupure sur UV    [1][2] 13 168 Hier 09:06:49
stigmamax 
Hors Sujet !! Présentation pour tous    [1][2][3]...[99] 982 247639 Hier 06:46:17
paquetdemouchoirs 
Questions & Réponses MIDI to Blender 5 161 19/09 17:47:18
docouatzat 
The Blender Clan 'tchat La Bible des tutos Blender – Une Séléction de 150 Tutos Blender *en anglais 2 128 18/09 14:34:05
Gilead_Maerlyn 
Questions & Réponses [résolu] Blender lumière 3 154 18/09 09:06:47
moonboots 
Questions & Réponses Tableau d'objets déformés aléatoirement 4 170 17/09 21:11:22
creepclem 
Questions & Réponses Comportement 2.8    [1][2] 12 534 17/09 14:28:25
Rimpotche 
Questions & Réponses [résolu] Problème de Sculpt 2 140 17/09 05:31:23
MHB29 
Questions & Réponses [résolu] Epaisseur non constante avec Solidify - Murs 2 147 16/09 14:36:42
HarDrive 
Questions & Réponses [non résolu] Array : duplication circulaire 2 130 16/09 06:04:40
blendinfos 
Questions & Réponses preferences utilisateur ne s'ouvrent plus 0 172 14/09 15:39:23
masje 
Questions & Réponses [résolu] Problème avec la symétrie    [1][2] 12 403 14/09 10:30:13
GFC 
Questions & Réponses galère d'importation SVG 5 265 14/09 08:42:16
Guppy88 

Qui est en ligne
83 utilisateur(s) en ligne (dont 40 sur Forums)

Membre(s): 2
Invité(s): 81


blendinfos, touvenant, plus...
Nouveaux membres
metalu 20/9/2019
Anton78 20/9/2019
paquetdemouchoirs 20/9/2019
Mecanicus 16/9/2019
surfer10 16/9/2019
tokoji 15/9/2019
bolfab 13/9/2019
lolozen 9/9/2019
madmax-elkana 7/9/2019
karlouch 5/9/2019
Dernier Ajout
Forky-3D-ToyStory BC.png

Evènements à venir
Nov 18
Anniversaire de RichDeg
Dec 29
Anniversaire d'ebrain
Jan 11
BUG de Lyon
plus 278 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2019 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445