Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 18:06:16
Post(s): 9
Bonjounr à toutes et à tous ami(e)s blenderien(ne)s. Ce topic est la remontée du topic que j'avais posté la semaine dernière et dont j'avais je pense mal formulé le titre d'où une possible mauvaise compréhension de ma demande : http://blenderclan.tuxfamily.org/html/modules/newbb/viewtopic.php?topic_id=49239&forum=1

J'utilise Blender moins pour ses fonctions de modélisation 3D que pour ses fonctions d'animation à partir d'images 2D importées. Ces courtes animations sont ensuites rajoutées à des montages vidéos faits avec un autre logiciel.

Concrètement sous Blender 2.8 dans la vue de modélisation 3D par défaut j'ai ajouté une image d'arrière-plan ( (Add -> Image -> Background) et après rajouté une image de plus petite taille en avant-plan destinée à être animée ((Add -> Image -> Background). J'ai ajouté à cette dernière image un effet de déplacement simple de gauche à droite par keyframes.

Jusqu'à maintenant le rendu de cette animation (ALT+F12)aboutissait à un plantage de Blender et à une fermeture immédiate du logiciel.Je me suis rendu compte que ceci venait du type de rendu qui était Eevee par défaut (barre d'outils de droite : Render-Engine). Le type de rendu chois passant à Workbench ou Cycles plus de plantage : le rendu se lance .. et aboutit à une vidéo montrant une image noire uniforme tout le long de l'animation. A explorer et modifier les paramètres de rendu j'ai pu aboutir à une vidéo de couleur grise () mais impossible d'avoir un rendu correct. Avec la version 2.79 je dois avouer que je n'avais pas ce souci.

Donc est-ce que quelqu'un peut me conseiller comment régler ces paramètres de rendu pour que mon animation soit correctement rendue ?

Je suis désolé si ma question semble être une question de newbie/débutant mais ... c'est ce que je suis

Contribution le : 01/09 14:03:30
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
OverdOzed
Inscrit:
22/03/2010 13:13
De Gard du Nord
Post(s): 1744
Bonjour, Mikienko.

En tapant dans goût-gueule "Blender Add Image Background",
on trouve cette page, qui dit :
"In Blender, reference images can be vital, especially for new artists. Figuring out how to create and manipulate faces can be hard enough, without worrying about the anatomy of the model itself.

Thankfully, Blender has a nifty feature called “Background Images”. By directly importing an image into your workspace, you can easily make it your reference. The image only appears when your view is aligned with the axes and doesn’t appear in your final render.

For example, if you want to make an exact replica of a part to 3D print, you can simply take a picture of it. Using that as your reference, you don’t need to worry about getting exact measurements for each part."

Donc ça dit clairement que l'image n'apparaît pas au rendu.

Je n'avais jamais utilisé cette fonction, c'est pourquoi j'ai cherché à en savoir plus.

A mon avis, pour ce que tu veux faire, il vaudrait mieux utiliser "Import Image as Plane" qui est toujours rendue
pour peu qu'on l'éclaire avec des lampes ou qu'on la mette en "Emission" avec un node shader du même nom.

Donc essaye ça, et si cà ne marche pas mieux, mets-nous ton blend (par exemple avec pasteall.org). N'oublie pas de "packer" ton image dans ton blend, sinon on ne pourra pas t'aider efficacement.

Contribution le : 01/09 14:48:34
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 18:06:16
Post(s): 9
Merci beaucoup ! Je vais tester de cette façon et si ça plante encore j'enverrais mon .blend.
Question idiote : que signifie "packer" une image dans un .blend file ?

Contribution le : 01/09 15:32:46
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
OverdOzed
Inscrit:
22/03/2010 13:13
De Gard du Nord
Post(s): 1744
Citation :

Mikienko a écrit: Question idiote : que signifie "packer" une image dans un .blend file ?

Ta question n'est pas idiote, mais tu pourrais peut-être faire quelques recherches... Il y a plein de réponses à cette question sur le net. Par exemple celle-ci.

Contribution le : 01/09 15:39:49
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 18:06:16
Post(s): 9
Honte sur moi ! Merci pour le tuyau. Je me penche sur mon fichier blend et je vais faire en sorte d'arranger tout ça.
Merci encore.

Contribution le : 01/09 16:40:29
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
OverdOzed
Inscrit:
22/03/2010 13:13
De Gard du Nord
Post(s): 1744
Je te conseille d'utiliser un seul node shader pour tes images : "Emission" en laissant les paramètres par défaut, c'est-à-dire blanc et Strength à 1.000. Ainsi tes images seront rendues telles quelles. Si elles sont trop claires ou trop sombres, tu peux jouer sur le Strength. Ainsi pas besoin d'éclairage.

Contribution le : 01/09 17:16:03
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 18:06:16
Post(s): 9
Merci beaucoup Rimpotche. Après moults et moults tests j'ai l'impression que le Node Shader "Emission" n'est disponible que dans le type de rendu EEvee .. qui fait planter Blender. Grrr !
La je commence à m'arracher les cheveux. Je me suis permis de mettre à disposition le fichier .blend ici : http://pasteall.org/blend/index.php?id=52264. Si quelqu'un peut se penche sur le problème et le résoudre eh bien ... vraiment un grand merci !
Sinon ne vous prenez pas la tête. Dans le pire des cas je referais mes animations sous Blender 2.79.
Encore merci pour votre aide et bonne soirée

Contribution le : 01/09 18:45:37
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
OverdOzed
Inscrit:
22/03/2010 13:13
De Gard du Nord
Post(s): 1744
Plusieurs choses. Ton blend fait 0 octets. Donc impossible à lire.
Ensuite tous les shaders sur 2.80 sont valables pour Eevee comme pour Cycles.
C'est compliqué d'utiliser un logiciel sans passer par la base.
Alors, je te conseille en effet d'utiliser le Blender Render sur 2.79 qui te donnera un rendu beaucoup plus rapide et suffisant pour ce que tu veux faire. Et dans le Blender Render, dans le shading du Material de tes images, coche "Shadeless" qui correspond à "Emission" dans Cycles ou Eevee.
Ainsi pas besoin de lampes, tes images ou animations que tu déplaces seront rendues telles quelles.

Contribution le : 01/09 18:55:39
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
25/08 18:06:16
Post(s): 9
Merci beaucoup. Je vais faire comme ça. Bonne soirée à vous

Contribution le : 01/09 19:47:36
Créer un fichier PDF de la contribution Imprimer


Re: Rendu vidéo animation complètement noir
Touriste
Inscrit:
28/07 17:07:50
Post(s): 11
Comment faut-il faire sur Blender 2.8 pour adapter un bvh à un personnage MHx2 ? Je ne retrouve plus la fonction load and retarget de Blender 2.7 !

Merci de bien vouloir me répondre !

Contribution le : 04/09 18:07:59
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Besoin d'aide simulation de vent sur des plantes (système particules) 0 15 Aujourd'hui 17:50:55
B3nD 
Questions & Réponses Contrainte en édition 1 29 Aujourd'hui 13:57:05
naeco 
Python & Plugins [WIP] Tracer une courbe et obtenir son équation 0 21 Aujourd'hui 10:49:49
Jeanclaude25 
Questions & Réponses Impossible de faire un bevel regulier 8 178 Aujourd'hui 09:43:47
busanga 
Questions & Réponses [non résolu] Des conseils ? 5 150 Hier 22:21:41
tokoji 
Moteur de jeu GameBlender et alternatives [non résolu] Programmer un archer à cheval    [1][2][3][4] 32 837 Hier 22:12:53
Bibi09 
Questions & Réponses La video n'est pas lu dans l'editeur node 0 25 Hier 20:06:12
masje 
Questions & Réponses Question sur IvyGen 3 194 Hier 16:20:13
Muad 
Questions & Réponses Déplacement d'un personnage riggé sur courbe de Bézier 3 60 Hier 13:45:28
Rimpotche 
Questions & Réponses Choisir Rendu sur la carte graphique de l'ordinateur 4 134 Hier 11:13:26
masje 
Questions & Réponses Extrusion régulière sur plusieurs angles ?    [1][2] 12 214 12/11 15:37:27
Fracoris 
[WIP] et travaux terminés [WIP] Bataille Navale // Animation 3d    [1][2][3] 24 1903 11/11 22:02:15
Bibi09 
[WIP] et travaux terminés Teeny Tiny - Story 1 130 11/11 21:42:22
Bibi09 
Questions & Réponses des rayures bizzard ? 3 83 11/11 20:52:08
Eleonor-e 
Mes premières images sous Blender (débutants) Les trucs à Élé 6 199 11/11 18:53:11
Eleonor-e 
Questions & Réponses [non résolu] Impossible d'effectuer un boolean sur sculpt 3 98 11/11 15:04:53
busanga 
Questions & Réponses Longueur d'une courbe de béziers ? 3 219 11/11 01:23:27
Eleonor-e 
Questions & Réponses Viewer node ne fonctionne pas 1 105 11/11 01:21:41
Eleonor-e 
Mes premières images sous Blender (débutants) club Blender en collège/lycée    [1][2][3]...[6] 59 24475 10/11 21:05:52
Thewada 
Le coin des geeks config pour projet d'environ 30 000 000 de vertex 3 240 09/11 13:56:22
Bibi09 

Qui est en ligne
67 utilisateur(s) en ligne (dont 37 sur Forums)

Membre(s): 1
Invité(s): 66


ebrain, plus...
Nouveaux membres
B3nD 14/11/2019
Jothys 13/11/2019
21600883 11/11/2019
Eleonor-e 11/11/2019
DAOUDA 8/11/2019

AikonFR
8/11/2019
LouYa9 6/11/2019
nikita182 6/11/2019
parki 6/11/2019
papillon 5/11/2019
Dernier Ajout
2019-11-05 01.JPG

Evènements à venir
Nov 18
Anniversaire de RichDeg
Dec 29
Anniversaire d'ebrain
Jan 11
BUG de Lyon
plus 278 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2019 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445