« 1 (2)


Re: Nouvelle config.
Fou Furieux du Clan
Inscrit:
26/07/2008 22:53
Post(s): 208
Effectivement, le processeur bosse pas mal pendant le rendu GPU, c'est étrange.
J'ai mes 4 cœurs à 60-70% en faisant un rendu GPU only, et à 100% en CPU only ou CPU+GPU.

Contribution le : 11/02 14:18:59
Créer un fichier PDF de la contribution Imprimer


Re: Nouvelle config.
OverdOzed
Inscrit:
23/02/2006 18:10
De Alpes-Maritimes
Post(s): 2372
En effet, je n'avais pas vraiment pris en compte le travail supplémentaire des autres cœurs pourtant bien visible également sur ma capture d'écran. Cependant, même si cette partie est boostée avec un processeur plus performant, à quel point peut-elle avoir une incidence sur la fréquence du rendu ?
Tu peux avoir une partie de la tâche qui fonctionne sur plusieurs threads (le "bruit de fond"). Je pense notamment à recalculer les coordonnées des points sélectionnés et déplacés. Cela sera effectivement plus rapide de par le nombre de cœurs disponibles.
Par contre, l'envoi des données au GPU, passant par l'intermédiaire du driver vidéo ne pourra être réalisé que par un seul cœur. C'est inhérent à OpenGL sur lequel Blender se base pour le viewport.

Tu remarqueras que Blender rame tout autant si tu ne déplaces qu'un seul vertex sur un mesh de 1.5 millions de polygones.
D'après moi, mais ce n'est qu'un avis encore une fois et non une vérité absolue, il y a un souci sur la façon dont Blender est codé pour ce type de tâche. C'est comme s'ils mettaient à jour l'intégralité de la géométrie au lieu de modifier uniquement les points déplacés. Je n'ai pas regardé le code source pour en être sûr, ce serait chercher une aiguille dans une botte de foin...

Par ailleurs, il a été reconnu que Blender 2.80 était une régression au niveau des performances en édition par rapport à la 2.79. Cela est probablement dû à la refonte du moteur du viewport, passant d'OpenGL2 à OpenGL3.3. Je crois que la 2.81 a apporté un mieux, peut-être qu'ils vont continuer en ce sens.
Quoiqu'il en soit, on est encore très loin des performances de 3DSMax dans l'édition de géométrie lourde.

Pour résumer et reprendre ma conclusion précédente, et ça reste une intuition, le principal souci vient de Blender en lui-même qui tire trop sur la communication CPU-GPU.

Contribution le : 11/02 18:29:14
Créer un fichier PDF de la contribution Imprimer


Re: Nouvelle config.
OverdOzed
Inscrit:
04/03/2007 14:10
Post(s): 4060
Bon, j'ai quand même monté un nouveau AMD Ryzen 9 9300 avec une RTX2070 dans ma tour.
Pour l’édition du maillage le progrès n'est pas flagrant,il y a toujours un temps de latence entre le lancement d'une commande merge par exemple et son exécution.

En mode CPu,Blender me fait un rendu sous cycle en un peu moins de temps qu'il m'en fallait avec ma Geforce GTX 980.. et il utilise bien tous ses cœurs pour faire le rendu mais un seul à 100%
En revanche il utilise tous les cœurs à 100% pour un rendu avec GPU, je ne comprends pas...

J'ai testé un rendu d'un vieux cavalier de Mistercroche que j'avais encore, il fallait à l'époque 19 min pour le faire, environ 1mn 45 secondes avec la TRS 2070. Il avait une GTX 580 je crois.

Mais je rencontre un problème inattendu, Blender bug avec la carte graphique. Je croyais que c'était un problème avec ma carte graphique et un nombre de vertices élevé mais non, c'est un problème de gestion entre CUDA Blender et NVIDIA et peut être aussi d'autres cartes graphiques.
Et tant que c'est des petits mesh cela ne se manifeste pas trop, ou ne se voit pas du tout.

Au démarrage il indique bien dans le mode Edit => préférences => system que j'ai un Ryzen 9 de 12 cœurs et une Geforce 2070, mais il ne peut faire un rendu qu'au démarrage. Après quelques rendus ou un peu de temps, blender trouve que le mode GPU devient incompatible avec CUDA.

Au bout d'un certain temps donc il se met en panne et finit pas déclarer
- CUDA kernel failed, see console for details.

J'ai été voir sur internet, et j'ai découvert que c'était assez récurrent comme problème entre Blender et les cartes graphiques NVIDIA, tant sous Windows que sous Linux (Debian 10 pour moi).
De plus cela n'a rien a voir avec la 2.79, j'en ai toujours une que j'ai conservé et qui commence à me dérouter (c'est fou ce qu'on oublie vite les choses) mais le problème se manifeste aussi tant avec l'ancienne carte graphique que ma nouvelle.
C'est donc bien un problème avec les nouvelles versions j'avais récemment mis à jour les pilotes et toolkit, mais cela n'a rien changé.
Guppy

Ps.
Je viens de voir qu'il y avait une nouvelle version 2.82 pour Linux, je l'ai téléchargée et pour l'instant je ne rencontre plus les problèmes indiqués ci dessus.
Je teste... j'ai déjà fait plus d'une dizaine de rendus et , rien ne semble flancher. Le mode GPU tient toujours, et pas de message avec CUDA kernel failed.

L’utilisation des cœurs est très aléatoire, j'en ai compté jusqu'à 10 fonctionnant en même temps et à 100 %, les autres ne faisant que très peu d'efforts, voire des fainéants qui se la coule douce et affichent sans honte qu'il sont occupés à ..0%.
Mis ils prennent quand même le relais, ce ne sont pas toujours les mêmes qui travaillent à 100%
Peut être es-ce la bonne version pour moi.

Contribution le : 14/02 18:31:17
_________________
Ils ont des yeux pour voir, mais ils ne voient point.
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
« 1 (2)




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses Je bloque sur la modélisation de ce verre! Avez-vous une solution? 7 143 Hier 21:33:52
titisteph 
Questions & Réponses [non résolu] cloth: déformation bizzarre au rendu 3 52 Hier 09:21:18
Arielboid 
Questions & Réponses les cheveux longueur 1 38 06/08 19:53:18
Rimpotche 
Questions & Réponses ADDON MB - Lab 0 40 06/08 15:29:23
GI-jo13 
Questions & Réponses [résolu] en sculpt mode 5 150 04/08 18:21:10
prometheusx 
Questions & Réponses [résolu] Array circulaire 2 126 04/08 15:22:46
Redstar 
[WIP] et travaux terminés [WIP] Teeny Tiny - Story    [1][2][3]...[5] 40 3893 04/08 07:18:00
Bibi09 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Première version disponible !    [1][2][3]...[58] 576 98005 03/08 11:11:32
Hook 
Questions & Réponses Addon pour textures procedurales 2 130 02/08 20:11:35
Crocodile_13 
Questions & Réponses avis animation marche :)    [1][2][3][4] 34 660 02/08 20:03:14
prometheusx 
[WIP] et travaux terminés [terminé] court métrage 2020    [1][2] 13 844 02/08 15:28:29
flahaut 
Questions & Réponses [résolu] Générique, sous-titres etc 3 136 02/08 09:18:02
Corpia 
Questions & Réponses [résolu] Scène prend la couleur du fond    [1][2] 11 261 02/08 08:20:32
Arielboid 
Questions & Réponses [non résolu] Problele d'addon 0 106 02/08 01:52:30
nayther 
Questions & Réponses Addon pour textures procedurales 1 96 01/08 12:22:52
moonboots 
Questions & Réponses hair densité sélection de polys 9 234 30/07 23:18:21
lenogre 
Questions & Réponses [résolu] graph editor et location key frame 7 193 30/07 16:41:18
math_ 
Questions & Réponses les graphs editor :/ 4 179 30/07 11:19:07
prometheusx 
[WIP] et travaux terminés [WIP] Tutoriel vidéo et création de mon prochain court métrage 2 176 29/07 20:32:46
Bibi09 
Le coin des geeks pc bas prix    [1][2][3][4] 38 1838 28/07 21:14:56
Bibi09 

Qui est en ligne
217 utilisateur(s) en ligne (dont 152 sur Forums)

Membre(s): 2
Invité(s): 215


WhitneyFre, RicoTylor, plus...
Nouveaux membres
AntoniaSwi 8/8/2020
BerylAhern 8/8/2020
KaceyFkq38 8/8/2020
RossBowker 8/8/2020
TheronRatc 8/8/2020
MargaritaS 8/8/2020
VioletteMe 8/8/2020
Harrison95 8/8/2020
MeridithYa 8/8/2020
KennithLap 8/8/2020
Dernier Ajout
mirages-preview~0.jpg

Evènements à venir
(continuer) - Aou 8
anniversaire Cem47
Aou 13
Anniversaire Siskas
Sep 8
Anniversaire de ang
plus 267 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445