(1) 2 »


[résolu]Problème OpenGL et Ubuntu studio
OverdOzed
Inscrit:
02/09/2010 10:34
Post(s): 657
Bonjours,
J'ai récemment d'installer Ubuntu Studio 12.04 LTS avec Xfce et lorsque j'ai voulu utilisé mon logiciel de 3D préférés (qui est installés par défaut sur cette distrib) et ben y s'est rien passé. Du coup je l'ai lancer depuis un terminal pour trouver le problème. Résultat :

Xlib: extension "GLX" missing on display ":0.0".
/build/buildd/blender-2.62/intern/ghost/intern/GHOST_WindowX11.cpp:193: X11 glXQueryVersion() failed, verify working openGL system!
initial window could not find the GLX extension, exit!
Erreur de segmentation (core dumped)

Après recherche il s’avère que le problème viens d'OpenGl.
Je tape "glxinfo | grep "OpenGL version"" :

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

Et maintenant je sais pas trop quoi faire parce que avec Ubuntu normal ça marché très bien. Pour info j'ai une carte Nvidia GeForce GT 520MX.
Pour conclure j'en appelle au linuxiens qui saurait quoi faire :
Comment faire remarché Blender ?????!!!!!!

Contribution le : 19/03/2013 20:15
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
RegulatorZ
Inscrit:
01/07/2005 17:05
De Guyane francaise dans la jungeul
Post(s): 11297
Salut Commentquonfait

blender peut être installé sur n'importe qu'elle distribution linux, donc pas besoins de Ubuntu Studio pour ça.
Moi j'avais sur tout besoin de Studio parce que je faisait de la musique et aussi parce qu'avec un connexion internet fablarde on est bien content d'avoir les logiciels déjà inclus au DVD .
Du coup je ne suis pas sur que ça soit t'a situation.
J'ai vu que Nvidia et les dernières ubuntu n'ont pas les drivers proposés par défaut (à part la lts en 32Bits).
Donc, si tu veux être tranquille je te conseillerais de passer à la version "normale". voir la 32Bits (ou sinon tu peu aussi installe les PPA de Nvidia dans Synaptique).

voila, en tout cas si c'est à refaire je reste sur de la 32bits de mon coté (par ce que j'ai galéré pendant 3 nuits pour arriver à installer à la main les drivers de ma gtx650 ).

bon courage

Contribution le : 19/03/2013 20:29
_________________

Pour vous abonner à ma chaine : https://www.youtube.com/c/MELTINGPROD/?sub_confirmation=1
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
OverdOzed
Inscrit:
02/09/2010 10:34
Post(s): 657
Non bien sure je n'ai pas installé cette distribution pour avoir blender prés installé. J'ai choisi Ubuntu studio pour faire marcher ma batterie électronique en midi. Ensuite pas question que je passe à la 32 bit, j'aurais l'impression de gâcher mon booo ordi presque tout neuf. Et repasser à la version standard je préfère pas pour ma batterie.

Donc on en viens à la troisième solution : les pilotes propriétaires. Tu crois que ça peut marcher avec ça ? Si oui qu'est-ce que je doit faire avec synaptique ?

Contribution le : 19/03/2013 21:22
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
Ze Grand Manitou
Inscrit:
24/07/2003 14:50
De la Région Parisienne
Post(s): 21822
Je crois que c'est encore jockey-gtk qui gère le truc sous cette version d'Ubuntu, essaye de le lancer tout simplement, et d'installer le driver en cochant un bidule.

@+

Contribution le : 20/03/2013 14:00
_________________

Mickaël Guédon | Site pro : www.mickaelguedon.com | Fondateur du Blender Clan : www.blenderclan.org
Auteur de Formations Blender chez Elephorm
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
OverdOzed
Inscrit:
06/07/2009 09:22
De Fraggle Rock
Post(s): 5782
Haha, la Nvidia GeForce GT 520MX.
Le problème est bien connu: la technologie Optimus http://www.nvidia.fr/object/optimus_technology_fr.html
très mal gérée par Linux

tu dois installer bumblebee puis tu démarreras tes appli 3D avec, par exemple pour blender ça donnera:
optirun blender


un peu de lecture: http://doc.ubuntu-fr.org/nvidia_optimus

bon blend

ps: tu as 100% raison pour le 64bits, IL NE FAUT SURTOUT PAS INSTALLER UN SYSTÈME 32BITS SUR LES ORDI RÉCENTS! (je te l'ai tant répété pourtant melti -_-)

Contribution le : 20/03/2013 14:13
_________________
ce n'est pas parce que l'on ne se comprend pas qu'il ne faut pas chercher à se faire entendre
Le chat du BUG
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
OverdOzed
Inscrit:
02/09/2010 10:34
Post(s): 657
Super merci Edddy! J'ai installé bumblebee et tout remarche correctement. Je vais pouvoir me remettre à Blender. C'est géniale! Par contre étrange détail, depuis que j'ai installer bumblebee je peut utiliser blender sans taper optirun avant. Je supposer que la gestion corecte de la carte Nvidia à permis la gestion correcte de la carte intégré au processeur.
Bref le problème est résolu!
(On fait comment pour passer le sujet en résolu ?)

Contribution le : 20/03/2013 21:41
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
RegulatorZ
Inscrit:
01/07/2005 17:05
De Guyane francaise dans la jungeul
Post(s): 11297
pour passer ton sujet en résolu il suffit d'editer ton premier post et de passer la case Préfix d'article de [None] à [Résolu].

Content que t'ai eu la solution à ton problème

Contribution le : 21/03/2013 02:08
_________________

Pour vous abonner à ma chaine : https://www.youtube.com/c/MELTINGPROD/?sub_confirmation=1
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
Fou Furieux du Clan
Inscrit:
16/09/2011 10:39
Post(s): 279
Citation :

edddy a écrit:
ps: tu as 100% raison pour le 64bits, IL NE FAUT SURTOUT PAS INSTALLER UN SYSTÈME 32BITS SUR LES ORDI RÉCENTS! (je te l'ai tant répété pourtant melti -_-)


Salut,

Tu veux dire quoi par récent ? Quelle génération ?

Contribution le : 21/03/2013 09:16
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Bin déjà tout ce qui a plus de 3 Go de ram, sinon elle n'est pas exploitée. Et de manière générale, si le processeur supporte le 64bits pourquoi s'en priver ?

(sur la fiche technique du proco, c'est indiqué sous "Jeu d'instruction" chez Intel, "Mode de fonctionnement" chez AMD)

Contribution le : 21/03/2013 15:49
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Problème OpenGL et Ubuntu studio
OverdOzed
Inscrit:
02/09/2010 10:34
Post(s): 657
Désolé pour le résolu mais je trouve pas la case préfixe d'article.

Contribution le : 22/03/2013 19:40
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Mes premières images sous Blender (débutants) Quitter l'affichage touche Z 4 46 Aujourd'hui 21:25:05
Rimpotche 
Questions & Réponses Récupérer un vieux fichier dans Blender 2.90    [1][2] 11 382 Aujourd'hui 21:03:47
doudoulolita 
Questions & Réponses [non résolu] Débutant sur les découpes des objets avec Blender 2.79    [1][2] 10 83 Aujourd'hui 19:43:59
yocodream 
Questions & Réponses Configuration scroller et pan dans Blender 2.91 1 36 Aujourd'hui 19:36:53
Rimpotche 
Mes premières images sous Blender (débutants) serpent 5 57 Aujourd'hui 16:28:40
rduvrac 
Questions & Réponses Aperçu des polices "qui clignotent" 2 72 Aujourd'hui 08:56:23
Kristof_LEDRU 
[WIP] et travaux terminés [WIP] BUDY3000 prochain tuto spécial : modélisation semi mécanique 6 144 Hier 22:14:47
Laorz 
[WIP] et travaux terminés [WIP] Coming Home (Animation de Noël)    [1][2] 14 340 Hier 20:21:42
Bibi09 
[WIP] et travaux terminés [WIP] TUTO Spécial Textures ! BOB et Gary :D 5 244 Hier 20:19:31
Bibi09 
Hors Sujet !! Tutoriel - Rigify - adapter Rigify à un personnage Cartoon (Bob l'éponge) 0 45 Hier 18:25:56
meltingman 
Questions & Réponses SSolidifier 5 73 Hier 18:19:55
rduvrac 
Questions & Réponses Bump map pixellisée    [1][2] 12 133 Hier 18:08:02
moonboots 
Questions & Réponses Je n'arrive pas a coller les membres de mes personnages sur l'armature    [1][2] 19 192 Hier 17:52:35
Lylo 
Questions & Réponses Scanner 3d et blender 2 84 Hier 17:37:28
Pandore62 
Questions & Réponses Ajouter l'effet de deux shaders? 1 51 Hier 17:28:02
moonboots 
Questions & Réponses [non résolu] Afficchage matériaux 9 111 Hier 13:58:56
rduvrac 
Questions & Réponses Meilleure résolution bake fluid 3 79 Hier 13:52:37
Patrickletare 
Questions & Réponses depliage UV version blender 2.9 1 42 Hier 13:42:59
Rimpotche 
Questions & Réponses [WIP] Typo 0 52 Hier 09:35:34
Laorz 
Questions & Réponses [WIP] Problème Rétopo    [1][2] 19 975 Hier 09:24:18
Laorz 

Qui est en ligne
133 utilisateur(s) en ligne (dont 55 sur Forums)

Membre(s): 0
Invité(s): 133


plus...
Nouveaux membres
Augustus_Strix 28/11/2020
yocodream 28/11/2020
Pandore62 27/11/2020
Kristof_LEDRU 26/11/2020
capitaine_moyen 22/11/2020
nhandinhbongda 21/11/2020
SomeName 21/11/2020
Balbine20 20/11/2020
BlendSkill 20/11/2020
Gazpart 19/11/2020
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Dec 29
Anniversaire d'ebrain
Jan 9
BUG de Lyon
Fev 15
Anniversaire de Dany
plus 263 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445