Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
11/11/2005 12:43
De quelque part dans le 57 :P
Post(s): 1674
Hello

Bah voilà, fallait bien que ça arrive. J'ai acheté une NVIDIA GTX 970 pour un de mes pc de rendu. L'OS actuel est Xubuntu 14.04 64 bits. Les installations des pilotes d'affichage et CUDA en manuel se sont bien passées (NVIDIA-Linux-x86_64-343.22.run et cuda_6.5.19_linux_64.run) et Blender 2.71 officielle et 2.72 rc1 reconnaissent bien ma carte mais lorsque je lance un rendu de la vue 3d j'obtiens ce message dans le terminal:

Compiling CUDA kernel ... "/usr/local/cuda/bin/nvcc" -arch=sm_52 -m64 --cubin "/home/jk/Documents/Blender2.72/2.72/scripts/addons/cycles/kernel/kernel.cu" -o "/home/jk/.config/blender/2.72/cache/cycles_kernel_sm52_9DA7CAD125EDEB0BDE16806F490958DF.cubin" --ptxas-options="-v" -I"/home/jk/Documents/Blender2.72/2.72/scripts/addons/cycles/kernel" -DNVCC -D__KERNEL_CUDA_VERSION__=65 /home/jk/Documents/Blender2.72/2.72/scripts/addons/cycles/kernel/kernel.cu:69:2: error: #error "Unknown or unsupported CUDA architecture, can't determine launch bounds" #error "Unknown or unsupported CUDA architecture, can't determine launch bounds" ^ /home/jk/Documents/Blender2.72/2.72/scripts/addons/cycles/kernel/kernel.cu:87:87: error: division by zero in #if #if CUDA_MULTIPRESSOR_MAX_REGISTERS/(CUDA_THREADS_BLOCK_WIDTH*CUDA_THREADS_BLOCK_WIDTH*CUDA_KERNEL_MAX_REGISTERS) > CUDA_MULTIPROCESSOR_MAX_BLOCKS ^ CUDA kernel compilation failed, see console for details. Refer to the Cycles GPU rendering documentation for possible solutions: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/GPU_Rendering

Une idée du problème?

Contribution le : 28/09/2014 15:22
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
06/07/2009 09:22
De Fraggle Rock
Post(s): 5782
j'allais te dire "t'as installé le dernier CUDA Toolkit?"
puis je suis allé sur la page de download https://developer.nvidia.com/cuda-downloads
et j'y vois ça: "If you are developing with CUDA 6.5 on a GeForce GTX980 or GTX970 download CUDA 6.5 Toolkits with support for your GPU here."
et quand on clique here y a les versions windows et linux mais pas de version OSX
edit: tellement l'habitude que tu sois sur OSX bon, ben en installant le CUDA toolkit 6.5 modifié pour ton gpu, ça devrait passer

Contribution le : 28/09/2014 15:57
_________________
ce n'est pas parce que l'on ne se comprend pas qu'il ne faut pas chercher à se faire entendre
Le chat du BUG
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
11/11/2005 12:43
De quelque part dans le 57 :P
Post(s): 1674
J'ai téléchargé la version depuis ce lien pourtant.

J'ai même testé avec les pilotes graphiques fourni dans ce .run (343.19) mais ça ne change rien.

Pour OSX, peut-être que les pilotes vont arriver (pour les anciens MAc Pro par exemple).

edit: le .run que j'ai téléchargé est bien celui pour les GTX 980/970.

Contribution le : 28/09/2014 16:04
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
06/07/2009 09:22
De Fraggle Rock
Post(s): 5782
oui, excuse je suis un peu dans le gaz ce dimanche...

t'as essayé de compiler?

avant, si le kernel CUDA n'était pas présent dans la compile de Blender, ça le compilait sous linux, mais c'est peut-être plus le cas, faut peut-être recompiler tout Blender

Contribution le : 28/09/2014 16:24
_________________
ce n'est pas parce que l'on ne se comprend pas qu'il ne faut pas chercher à se faire entendre
Le chat du BUG
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
01/11/2004 21:14
Post(s): 6567
C'est ça. Les versions officielles de Blender ne sont pas compilées pour ces cartes.

Dans un bugreport, Dingto indique que blender les supportera pour la 2.73. Mais la sortie de la 2.72 était trop proche lorsqu'elles sont sorties.

Cependant,il précise que renommer le fichier kernel_sm_50.cubin dans 2.72/scripts/addon/cycles/lib en kernel_sm_52.cubin devrait suffir.

Contribution le : 28/09/2014 16:34
Créer un fichier PDF de la contribution Imprimer


Re: Cuda installé mais ne fonctionne pas (GTX 970 + Xubuntu 14.04 + derniers pilotes)
OverdOzed
Inscrit:
11/11/2005 12:43
De quelque part dans le 57 :P
Post(s): 1674
Merci Zeauro et Edddy, c'était bien cette histoire de fichier à renommer. J'avais lu ça sur BA en plus, mais là avec mes galères d'install (trop de changements entre Xubuntu 13.10 et 14.04 à mon goût), ça m'était sorti de la tête.

Problème résolu mais je vais réinstaller Xubuntu 13.10 et tester depuis cette version.

Contribution le : 28/09/2014 16:42
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
The Blender Clan 'tchat W10 pour le prix d'une cacahuète    [1][2][3] 20 295 Aujourd'hui 22:27:42
sapajou 
[WIP] et travaux terminés [WIP] La pince à linge    [1][2] 11 169 Aujourd'hui 18:53:10
meltingman 
Hors Sujet !! Tuto Astraonaute low-poly + rigify en 25mm 3 171 Aujourd'hui 14:47:47
meltingman 
Questions & Réponses Texture et courbe de Bézier 9 130 Aujourd'hui 14:19:10
Horemheb 
Questions & Réponses freestyle lineset : ignorer un objet spécifique pour une arrête cachée 0 25245 Aujourd'hui 08:56:34
yekcim 
[WIP] et travaux terminés Pagani Zonda Barchetta 6 188 Hier 09:03:37
moonboots 
[WIP] et travaux terminés [WIP] La gabarre '' Le Gros Ventre''    [1][2][3]...[12] 112 22128 19/01 17:57:26
Guiu 
Questions & Réponses chemins suivant une déformation de surface 6 138 19/01 12:26:50
meltingman 
Questions & Réponses Vitesse d'une vidéo 4 109 18/01 19:59:42
meltingman 
Questions & Réponses Armature sans parenté? 1 65 18/01 19:38:25
meltingman 
The Blender Clan 'tchat Avenir du blender clan    [1][2][3]...[41] 405 48949 17/01 20:40:59
Rimpotche 
Questions & Réponses texture eyes avec empty 1 67 17/01 13:17:33
Rimpotche 
The Blender Clan 'tchat Progression dans Blender et la 3D    [1][2] 11 524 16/01 17:37:45
Rimpotche 
Questions & Réponses [terminé] Modificateur Mirror sur un Vertex Group 2 113 16/01 15:55:36
Horemheb 
Questions & Réponses Ma caméra me saoule... 5 239 15/01 20:33:23
Lylo 
Hors Sujet !! Appareil Photo Compact, qualité, zoom...    [1][2] 19 482 14/01 14:45:17
lucky 
Questions & Réponses [résolu] Comportement du parentage et du Weight Paint bizarres    [1][2] 14 147959 10/01 15:17:23
Horemheb 
Hors Sujet !! BONNE ANNEE LE BLENDER CLAN    [1][2] 10 413 10/01 13:34:18
Riggelm 
Questions & Réponses Limit location constraint-Affect transforms 4 200 09/01 14:33:38
Melodicpinpon 
Questions & Réponses Mon objet suit la courbe à 12 km...    [1][2] 10 585 08/01 01:37:51
Lylo 

Qui est en ligne
225 utilisateur(s) en ligne (dont 88 sur Forums)

Membre(s): 2
Invité(s): 223


Lylo, LinnieLon1, plus...
Nouveaux membres
BlondellGa 2/1/2022
EileenTomk 2/1/2022
RamonaDahl 2/1/2022
SashaBeals 2/1/2022
TroyLightn 2/1/2022
PhillippBu 2/1/2022
LesterHida 2/1/2022
PansyHolm 2/1/2022
YukikoMitt 2/1/2022
Randall318 2/1/2022
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Fev 15
Anniversaire de Dany
Fev 19
Anniversaire de APPGirault123
Fev 23
anniversaire de windspirit
plus 244 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445