(1) 2 »


[Cycles] - Pas de rendu en GPU.
Fou Furieux du Clan
Inscrit:
27/04/2014 09:11
Post(s): 201
Bonjour,

J'ai un rendu avec 7000 particules en Emitter (une explosion d'un bâtiment, pour essayer) et cette explosion dure de la frame 80 à la 120.

Tous les rendus de ces frames en GPU sont transparents. Je ne comprends pas pourquoi.

Si je rends une seule image, elle est transparente aussi.
Le pic de mémoire n'excède pas les 550 Mo (ma CG a 2Go et j'ai déjà rendu des projets plus lourds).
Si je baisse le nombre de particules à 100, cela fonctionne.
Si j'utilise le CPU, cela fonctionne aussi. (Mais c'est formidablement lent)

À quoi cela sert-il de baker les particules ? 

Contribution le : 18/11/2014 20:04
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
OverdOzed
Inscrit:
18/03/2011 21:09
Post(s): 1026
salut
réponse empirique : ça sert a stocker en mémoire les mouvements au lieu de les soumettre à un recalcul lors de la construction du BVH, comme appliquer les valeurs de formule dans Excel ..

C'est absolument nécessaire à mon sens.

Fait des tests sur 5 samples, afin de trouver la valeur max de particules que tu peux rendre. Perso j ai deja fait plus de 10 000 en anim, mais la scène influe aussi ..

Contribution le : 18/11/2014 20:22
_________________
Galerie WIP
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
Fou Furieux du Clan
Inscrit:
27/04/2014 09:11
Post(s): 201
J'ai testé, c'est à peu près 200. Je trouve ça bien peu. (J'ai déjà fait des scènes à 30 000 particules, avec des particules children, en plus)

Merci pour la réponse empirique.

Contribution le : 18/11/2014 20:40
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Salut,
en effet 200 c'est ridicule, il y a forcement un truc.

Tu pourrais nous en dire plus sur tes particules ?
C'est un seul objet instancié, ou bien plein d'objets différents ?
Combien de faces ?
... sinon poste un screen, c'est difficile de deviner à l'aveugle

Contribution le : 18/11/2014 20:55
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
OverdOzed
Inscrit:
16/01/2011 17:05
De Le plus grand terrier du monde ! Et le plus high-tech.
Post(s): 4063
C'est quoi ta carte graphique ?

Mais normalement ça ne viens pas de là, si tu n'avais pas assez de mémoire il ne ferai pas le rendu.

Contribution le : 18/11/2014 21:03
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
Fou Furieux du Clan
Inscrit:
27/04/2014 09:11
Post(s): 201
Voilà deux images :





La première, c'est la frame 95 (qui rendait transparente). Ici, il n'y a que 100 particules.

La seconde, c'est l'image 121 (les particules Emitter vont jusqu'à la frame 120, le reste, c'est le modifier Explode), qui elle fonctionne avec les 7000 particules.

C'est un seul objet (le morceau de l'immeuble avec un peu d'intérieur).

Ma carte graphique est une 750 Gtx 2Go, je suis sous Debian.

Là, il fait bien le rendu, il y a toutes les frames dans mon dossier et je le vois faire. Seulement, les tiles rendues sont transparentes et ça va très, très vite.

Contribution le : 18/11/2014 21:16
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
OverdOzed
Inscrit:
16/01/2011 17:05
De Le plus grand terrier du monde ! Et le plus high-tech.
Post(s): 4063
C'est pas plutôt un problème de réglage au niveau de ta frame ?
L'image est vraiment totalement transparente ? (c'est un renderlayer séparé ?)

Contribution le : 18/11/2014 21:30
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
Fou Furieux du Clan
Inscrit:
27/04/2014 09:11
Post(s): 201
Tout ce que je change, c'est la quantité de particules. Pas de renderlayer séparé, non.

Contribution le : 18/11/2014 22:13
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
OverdOzed
Inscrit:
10/09/2009 15:36
De Angers
Post(s): 1758
Attention, car si tu suis le tutoriel que je crois que tu suis (j'en suis même sûr), ça mélange plein de notions :
- les particules
- un explode
- de la fumée
- des collisions...

Bref, ce n'est peut être pas juste les particules qui sont en jeu. Pas de piste sérieuse à creuser, c'est juste pour chercher autre part, ton problème est bizarre.

Pierre

Contribution le : 18/11/2014 23:18
_________________

DeviantArt | Sheepit!
Créer un fichier PDF de la contribution Imprimer


Re: [Cycles] - Pas de rendu en GPU.
Fou Furieux du Clan
Inscrit:
27/04/2014 09:11
Post(s): 201
Oui, c'est effectivement un tutoriel sur Youtube. Il y a bien un explode, des particules et des collisions (mais pas de fumée).

Après, ce n'est pas bien grave, je le faisais surtout pour m'entraîner, apprendre de nouvelles techniques, etc, et c'est surtout pour savoir où j'ai pu faire une bêtise et pour comprendre la logique du calcul que je pose la question. :)

Contribution le : 19/11/2014 00:24
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
The Blender Clan 'tchat Architecture / squelette du futur BC2.0    [1][2][3]...[5] 48 2698 Aujourd'hui 15:51:53
meltingman 
[WIP] et travaux terminés [WIP] La gabarre '' Le Gros Ventre''    [1][2][3] 28 1145 Aujourd'hui 15:14:35
Guiu 
Questions & Réponses wireframe 9 68 Aujourd'hui 14:55:06
maddjex 
[WIP] et travaux terminés [terminé] Imprimante à jet d'encre industrielle    [1][2] 13 2617 Aujourd'hui 14:05:22
dj3dim 
Questions & Réponses Fonction appareil photo qui ne prend pas de photos 5 90 Aujourd'hui 05:03:08
meltingman 
Questions & Réponses Bool Tool et le le modificateur Subdivise 3 83 Hier 16:57:40
Guiu 
[WIP] et travaux terminés [WIP] Coming Home (Animation de Noël)    [1][2][3] 20 589 Hier 16:27:04
Bibi09 
The Blender Clan 'tchat Benchmark EEVEE    [1][2][3][4] 35 2932 Hier 10:50:39
Bibi09 
Hors Sujet !! Tutoriels "Bonhomme de neige avec EEVEE" 9 159 Hier 10:27:13
Bibi09 
Questions & Réponses Animation 2D débutant 9 133 03/12 21:05:42
BailandIbelin 
[WIP] et travaux terminés [WIP] BUDY3000 prochain tuto spécial : modélisation semi mécanique    [1][2] 10 301 03/12 13:58:42
Guiu 
Python & Plugins ajouter plusieurs fois le même objet avec le même retard 1 49 03/12 13:25:46
meltingman 
Hors Sujet !! Comment se servir du Vertex Group- créer une fiole sans déplacer un vertex 0 61 03/12 12:32:01
meltingman 
Questions & Réponses [WIP] Typo 6 195 02/12 22:45:30
Laorz 
Questions & Réponses [physique] patte à modeler 2 51 02/12 22:00:39
prometheusx 
The Blender Clan 'tchat Blender 2.8x : Actus, tests, feedback..    [1][2][3]...[7] 66 38033 02/12 19:10:37
lucky 
Questions & Réponses Particules qui tombent puis restent collées à la surface 3 89 02/12 13:17:11
Bibi09 
[WIP] et travaux terminés [WIP] Les wips à Chikin    [1][2] 11 2572 01/12 19:24:49
chikin 
Python & Plugins script python pour dupliquer un objet et fusionner le tout    [1][2] 14 345 01/12 18:15:17
neonclignote 
Questions & Réponses Je perds sans arrêts mes shaders! 9 103 01/12 16:59:53
titisteph 

Qui est en ligne
197 utilisateur(s) en ligne (dont 132 sur Forums)

Membre(s): 1
Invité(s): 196


Rimpotche, plus...
Nouveaux membres
AdrieneRan 5/12/2020
LGZGladis 5/12/2020
MyrtleDomi 5/12/2020
bvkhpjMend 5/12/2020
maddjex 4/12/2020
porcinet49 4/12/2020
kerju2002 2/12/2020
bugsheep 29/11/2020
gto37 29/11/2020
Augustus_Strix 28/11/2020
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Dec 29
Anniversaire d'ebrain
Jan 9
BUG de Lyon
Fev 15
Anniversaire de Dany
plus 263 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445