(1) 2 »


Problème sur servo control
Clan Afficionado
Inscrit:
03/07/2009 08:49
Post(s): 54
Bonsoir tout le monde,

J'ai un soucis sur un jeu que je créée avec Blender 2.76b,
c'est que le mode de déplacement servo control ne fonctionne pas sur une armature, le personnage ne bouge pas ....
Pourtant servo control fonctionne sur un objet non armaturé, donc je ne vois pas ce qui peut clocher.

Pouvez-vous m'aider ?

Merci d'avance

Contribution le : 26/03/2016 20:48
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
OverdOzed
Inscrit:
19/03/2016 15:30
De Belgique
Post(s): 1653
Bonsoir Ruto14,

Tu viens de répondre toi-même à ta question .

Une armature est strictement utilisée pour animer un objet. Pas pour un déplacement.

Contribution le : 26/03/2016 21:16
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
OverdOzed
Inscrit:
21/06/2012 19:50
De Sud-Ouest de la France
Post(s): 385
Je viens de tester d'utiliser une armature pour déplacer un objet avec un Servo Control. Et ça marchait (enfin le résultat n'était pas terrible... ). Par contre cela ne marche que si l'on met les Physics de l'armature en Rigid Body ou en Dynamic.

Mais sinon, il est vrai qu'il ne faut pas utiliser une armature pour déplacer un objet. Il vaut mieux utiliser une hitbox (une "boîte" qui englobe ton personnage) qui est parent de l'armature. Tu peux ainsi mettre des Physics sur ta hitbox et gérer déplacements et collisions plus facilement.

Contribution le : 27/03/2016 16:46
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
Clan Afficionado
Inscrit:
03/07/2009 08:49
Post(s): 54
Merci pour vos réponses, je vais essayer ça.

Contribution le : 27/03/2016 17:24
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
Clan Afficionado
Inscrit:
03/07/2009 08:49
Post(s): 54
Ca ne fonctionne toujours pas

Contribution le : 27/03/2016 17:28
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
Clan Afficionado
Inscrit:
03/07/2009 08:49
Post(s): 54
En fait, j'arrive à faire bouger une armature uniquement en simple motion, mais ça ne m'arrange pas car les collisions ne sont pas gérées dans ce mode ....

Contribution le : 27/03/2016 18:11
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
OverdOzed
Inscrit:
21/06/2012 19:50
De Sud-Ouest de la France
Post(s): 385
Justement Redstar et moi nous te disons de ne pas utiliser l'armature pour déplacer l'objet.

Je t'ai dit d'utiliser une hitbox pour déplacer ton personnage. En fait tu crée une "boîte" qui enveloppe ton personnage. Tu fais en sorte qu'elle soit parent de ton armature. Ton personnage et son armature doivent être en No Collision. Tout ce qui est de la physique et des mouvements doit se faire au niveau de la hitbox.

Contribution le : 27/03/2016 19:03
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
Clan Afficionado
Inscrit:
03/07/2009 08:49
Post(s): 54
Ça ne fonctionne toujours pas
En fait, en faisant comme ça, mon personnage ne bouge pas, et ne tombe pas (pourtant, seule la hitbox est en dynamique.)
Merci quand même d'avoir essayé de m'aider

Contribution le : 03/04/2016 12:34
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
OverdOzed
Inscrit:
21/06/2012 19:50
De Sud-Ouest de la France
Post(s): 385
Citation :
Ça ne fonctionne toujours pas En fait, en faisant comme ça, mon personnage ne bouge pas, et ne tombe pas (pourtant, seule la hitbox est en dynamique.)


Alors là je ne comprends plus rien, il faudrait que tu mettes un blend parce que tu t'es planté quelque part ou tu as déréglé un truc.

C'est bien la hitbox qui gère les mouvements au moins?

Contribution le : 03/04/2016 16:29
Créer un fichier PDF de la contribution Imprimer


Re: Problème sur servo control
OverdOzed
Inscrit:
19/03/2016 15:30
De Belgique
Post(s): 1653
J'imagine que c'est un problème de parentage:

La hitbox dois être le parent, c'est à dire l'objet principal sur lequel l'armature et tout autres objets doivent être liés.

Si tu as un objet parenté à l'armature, c'est pas un problème tant que l'armature est liée à la hitbox (et pas l'inverse).

Les briques logiques doivent être sur la hitbox à l’exception de la brique "action" qui sert à jouer l'animation pour l’armature et doit donc être dans l'armature et pas dans la hitbox.

Contribution le : 03/04/2016 19:58
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
[WIP] et travaux terminés [terminé] Scène de Pti dej à la Française - EVEE a donf - 2.9 Blender    [1][2][3] 23 225 Aujourd'hui 02:57:29
meltingman 
Questions & Réponses [WIP] Problème Rétopo 5 31 Hier 22:37:06
Laorz 
[WIP] et travaux terminés image couteau dans caillou qui saigne 1 17 Hier 22:19:25
meltingman 
Questions & Réponses Placer sa camera sur un HDRI    [1][2] 10 297 Hier 21:32:01
meltingman 
[WIP] et travaux terminés [terminé] Chaussures Très Réalistes (.bend disponible) 5 122 Hier 21:23:47
Crocodile_13 
Le coin des geeks gain de fluidité viewport entre ryzen 3900X et 3950X    [1][2][3] 28 1327 Hier 15:45:54
papillon 
Questions & Réponses hdri en mode ombrage 2 103 Hier 10:27:06
kimlicrea 
Questions & Réponses Modifier les attribue de plusieurs objet en même temps (lumière) 3 62 Hier 10:21:47
kimlicrea 
[WIP] et travaux terminés [terminé] Moderno 404    [1][2] 13 482 23/10 20:26:41
moonboots 
Questions & Réponses Lissage de face 4 77 23/10 19:43:53
Maxence34 
Mes premières images sous Blender (débutants) Première réalisation    [1][2] 15 8980 23/10 02:13:26
Talason 
The Blender Clan 'tchat Addon convertisseur d'images en courbes 2 72 22/10 20:29:31
Rimpotche 
The Blender Clan 'tchat Pour les arboriculteurs 3D 1 75 22/10 18:05:18
moonboots 
Hors Sujet !! Faire parler son personnage en 5 minutes - tutoriel Francais - Blender 2.9 4 133 22/10 13:03:28
meltingman 
GIMP Faire un drégradé selon la forme sous gimp 9 105 22/10 12:49:57
Thewada 
Questions & Réponses [résolu] Perte des Vertex lors d'un Separate 7 103 21/10 21:45:05
debutant 
[WIP] et travaux terminés [terminé] Pantin articulé    [1][2] 12 6767 21/10 18:53:51
meltingman 
Hors Sujet !! Une citrouille en 13 clics - Tutoriel - Blender 2.9 2 165 19/10 23:40:15
meltingman 
Hors Sujet !! un banc de dauphin - tutoriel - workflow sculpte > bake - 2.9    [1][2] 12 467 19/10 23:36:41
meltingman 
Questions & Réponses [résolu] Particule réaliste pour un sprite    [1][2] 12 687 19/10 13:39:34
Redstar 

Qui est en ligne
193 utilisateur(s) en ligne (dont 90 sur Forums)

Membre(s): 0
Invité(s): 193


plus...
Nouveaux membres
NBVLatonya 25/10/2020
Mel46E969 25/10/2020
CathyGrims 25/10/2020
KayVergara 25/10/2020
RegenaDene 25/10/2020
Sina 25/10/2020
MaddisonCo 25/10/2020
ElenaChick 25/10/2020
SonyaBidme 24/10/2020
ShawnRolph 24/10/2020
Dernier Ajout
mirages-preview~0.jpg

Evènements à venir
Nov 18
Anniversaire de RichDeg
Dec 29
Anniversaire d'ebrain
Jan 9
BUG de Lyon
plus 264 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445