Transparence dynamique et textures
Touriste
Inscrit:
06/08/2016 18:12
Post(s): 6
Bonsoir à vous,

En fin d'études vétérinaire, j'ai réalisé un projet 3D pour ma thèse, il s'agit d'une application destinée à une meilleure compréhension du genou du chien et de son fonctionnement.
Pour cela, j'ai modélisé le système ligamentaire et osseux du membre postérieur, ainsi que quelques muscles important dans la biomécanique de cette articulation. J'ai ensuite créé une application exclusivement avec le game blender engine, contenant un menu et plusieurs scènes à thème, montrant différentes animations du genou. Un lecteur a été réalisé pour mettre en play/pause et sélectionner différents marqueurs importants dans ces animations. Mon projet est en cours de finalisation, malheureusement, quelques dysfonctionnement persistent dont un particulièrement gênant.

En effet, pour une meilleure compréhension, j'ai créé une texture image sous photoshop, mimant un effet de muscle. Cette texture n'est pas animée. J'ai donc assigné cette texture au matériau, en mode UV. L'objectif pour moi était qu'au cours de l'animation, les muscles soient affichés avec une transparence plus ou moins marquée. J'ai donc procédé comme pour les matériaux "simple" en activant la transparence, et en faisant varier l'alpha de l'objet color dans une action.
Pour le paramétrage, je suis en mode multitexture, les paramètres "material" et "texture" sont en screen ci-dessous.
http://pasteall.org/pic/967672664c697cc1b54d6a1ad9ff9dec[
http://pasteall.org/pic/f2066df88af5aa15c0803f68de2b5459

Le problème que je rencontre est assez étrange et dépasse très largement mes connaissances en Blender. Lorsque je lance le standalone player (ou le fichier .exe) avec en première scène, la scène contenant cette animation, tout fonctionne. (Voir screen ci-dessous)
http://pasteall.org/pic/6b68a14089a43b05f9b36da1fba21b6f

Les muscles sont semi-transparents, ce que je souhaitais. Par contre lorsque je lance l'application depuis une autre scène, typiquement : la scène du menu principal et que j'accède à la scène de l'animation, la transparence ne fonctionne plus du tout. (Screen ci-dessous)
http://pasteall.org/pic/bdbb0960d61d815b5e2c8d3291e77b72

Comme vous le constatez, pas de transparence.

Lorsque je lance l'application depuis la scène animée, que je change de scène et retourne sur celle-ci, pas de problème non plus, la transparence fonctionne.

Je ne comprends absolument pas d'où ce problème vient. J'ai copier l'intégralité des paramètres "scène" sur toutes mes scènes pour que ceux-ci soient homogènes. Après avoir bricolé avec à peu prêt tous les paramètres, et fouillé sur les forums (je suis peut être passé à côté de la solution), je me tourne vers vous. Je sais pas si certains d'entre vous ont déjà rencontré ce problème, et réussis à le résoudre, mais cela m'aiderait énormément.
Pour des raisons de confidentialité, je ne peux pas vous mettre en lien le fichier .blend, par contre si besoin je peux vous donner toutes les informations nécessaires.

Je vous remercie par avance.

Bonne soirée à vous.

Contribution le : 08/08/2018 00:41
Créer un fichier PDF de la contribution Imprimer


Re: Transparence dynamique et textures
OverdOzed
Inscrit:
16/05/2012 14:18
De Paris, Toulouse et le TGV entre les 2
Post(s): 548
Salut,

Effectivement, pour ce genre de souci, sans le .blend, ça va être chaud de t'aider... (Même si d'un point de vue confidentialité, je comprends que tu ne balances pas ta thèse comme ça sur internet)

Au niveau des paramètres de scene justement, tu n'aurais pas un souci du genre le menu en GLSL et l'animation en Multitexture ou l'inverse ?

Ou alors dans le viewport shading en bas, l'un en mode texture et l'autre en mode material ?


@+
Tricotou

Contribution le : 10/08/2018 09:25
_________________
"Vis aujourd'hui comme si c'était ton dernier jour,
Et fais des projets comme si tu étais là pour l'éternité"

mon portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Transparence dynamique et textures
Touriste
Inscrit:
06/08/2016 18:12
Post(s): 6
Salut à toi !

Alors au niveau des paramètres de scènes, ils étaient identiques sur toutes les scènes, tout était en Multitexture. Pas de modification du viewport shading non plus. Je pensais que c'était réellement un bug pendant un moment, mais c'est bizarre que celui-ci se produise systématiquement dans les mêmes situations.

En fait, j'ai l'impression qu'il s'agissait d'un problème soit au niveau du menu principal lui même, soit au niveau du changement de scène du menu principal vers cette scène d'animation, car je rencontrais ce problème systématiquement lorsque j'activais à un moment donné le menu principal.

Franchement, aucune idée d'où venait le problème. J4ai rencontré d'autres bugs également avec une seconde scène contenant des textures dans ce style. Un problème de chargement des fichiers textures ? Je ne sais pas.
Quoi qu'il en soit, j'ai sauté le pas hier de passer en mode GLSL, et par miracle, ça fonctionne ! Un peu de boulot pour retravailler l'éclairage de toutes mes scènes, mais au moins j'ai le résultat que je voulais!
Malheureusement je ne pense pas que ce topic puisse réellement aider quelqu'un qui souhaite faire ce genre de choses en mode multitexture, mais sait-on jamais.

Je te remercie beaucoup pour ta réponse en tout cas, je touche au but ! =)

Contribution le : 11/08/2018 10:43
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses [non résolu] Problème IK : pied qui tourne au lieu d'être fixé au sol 4 63 Aujourd'hui 18:09:00
mly 
Questions & Réponses appliquer une animation NLA 1 21 Aujourd'hui 16:16:13
prometheusx 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Date de sortie 1er juillet 2020    [1][2][3]...[51] 504 87070 Aujourd'hui 13:08:43
Hook 
Questions & Réponses affichage progressif bevel de courbe 5 108 Aujourd'hui 10:25:23
jlf 
The Blender Clan 'tchat Free addon Modélisation procédurale par nodes 1 53 Aujourd'hui 08:47:52
WinZs 
[WIP] et travaux terminés [WIP] Alpaga in love 7 166 Aujourd'hui 00:20:08
Bibi09 
Questions & Réponses Problème de rendu (débutant) 1 51 Hier 16:16:59
Rimpotche 
Questions & Réponses Grosse différence d'éclairage sur le rendu final VS le mode Rendered 9 153 29/05 21:42:20
Crocodile_13 
Questions & Réponses Problème avec le nodes Color Ramp 5 180 29/05 20:59:01
JaAlVir657 
Python & Plugins Comment renommer "Key" ? (le chef des shapekeys)    [1][2] 18 470 29/05 19:06:29
lucky 
Questions & Réponses [résolu] théorie lowpoly / highpoly 3 74 29/05 17:53:57
moonboots 
Moteur de jeu GameBlender et alternatives hARMful engine    [1][2][3]...[7] 65 6336 29/05 16:40:53
Bibi09 
[WIP] et travaux terminés Les fonds de mes rendus 4 158 29/05 14:05:18
Crocodile_13 
Python & Plugins [résolu] obtenir un résultat fixe suite au déplacement souris 1 108 28/05 14:28:07
Bibi09 
Moteurs de rendu rendu Povray sous Blender 2.6 + trace de log 7 12117 28/05 00:25:30
MauriceRaybaud 
Questions & Réponses [non résolu] Personnage et CAT5 - VRCHAT 0 84 27/05 22:31:10
Muffet 
Questions & Réponses Conseils pour modéliser un corps 4 180 27/05 17:48:43
moonboots 
Questions & Réponses Comment dupliquer une face autour d'un axe? 1 88 26/05 19:05:12
moonboots 
Questions & Réponses Comment faire une boucle infinie (animation) 9 178 26/05 13:00:46
3dlone 
Moteur de jeu GameBlender et alternatives [WIP] Jeu "Iron Man Collapsing"    [1][2][3] 27 8875 26/05 01:39:39
Bibi09 

Qui est en ligne
53 utilisateur(s) en ligne (dont 39 sur Forums)

Membre(s): 0
Invité(s): 53


plus...
Nouveaux membres
PERMAFROST 31/5/2020
Samux 30/5/2020
titisteph 29/5/2020
Muffet 27/5/2020
MadK 26/5/2020
Osziy_ 26/5/2020
Elliott42 25/5/2020
Ben3D 25/5/2020

Octopus
24/5/2020
aguqaf 23/5/2020
Dernier Ajout
mirages-preview~0.jpg

Evènements à venir
Jui 30
Anniv des Jedi :-D
Jui 11
BUG de Lyon
Jui 23
Anniv du BlenderClan !
plus 270 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445