Sequencer très lent (Blender 2.80)
OverdOzed
Inscrit:
23/02/2006 18:10
De Alpes-Maritimes
Post(s): 2573
Bonjour,
Je souhaite faire un montage vidéo après avoir filmé un événement dans ma ville - projet perso - mais je me heurte à un souci de taille avec Blender 2.8 (version officielle).

Le Sequencer est super méga lent alors que j'importe une vidéo sans aucun filtre ou quoi dessus. Juste drag and drop puis "Play".

Les vidéos enregistrées avec mon APN sont enregistrées au format MOV en 1080p @50Hz. Pourtant, la preview du Sequencer ne peut pas tourner à plus de 10FPS... Au démarrage de Blender, j'ai choisi le mode Video Editing qui m'amène logiquement à une interface dédiée au montage vidéo.

Niveau hardware, il gère suffisamment avec 2xGTX970 en SLI et un i7 5930K (12 threads). Donc ce point peut, a priori, être exclu !
J'ai testé sous Windows 10 uniquement. Mes drivers fonctionnent bien pour les applications 3D exigeantes, type jeux vidéo ou CUDA.

J'ai changé quelques paramètres du color manager pour le Sequencer après avoir lu ce bug report :
https://developer.blender.org/T56755

C'était encore pire...
Je suis assez déçu car j'espérais faire un montage sympa avec la dernière version de Blender. Je crains de devoir m'orienter vers une autre solution libre. A moins de revenir sur la 2.79, mais je n'ai pas testé si elle fonctionnait mieux. En général, c'est laborieux car le son ne colle presque jamais à l'image, d'où la volonté de voir si la 2.80 était plus apte au montage vidéo.

Est-ce que quelqu'un est déjà arrivé à faire du montage vidéo avec la 2.80 de façon fluide ? J'ai peut-être raté quelque chose ?

Contribution le : 04/08/2019 09:58
_________________
Venez tester notre projet de Blender Clan 2.0 + Tchat (en cours de développement) !
Pourquoi ? Retrouver un forum fonctionnel.
Créer un fichier PDF de la contribution Imprimer


Re: Sequencer très lent (Blender 2.80)
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2564
Salut, Bibi.

Je suis en train, depuis plusieurs jours, de faire du montage vidéo avec la 2.80 et je peux te dire que ça fonctionne très bien et ma bécane n'est pas aussi bien équipée que la tienne.

Pour faire du montage pas trop compliqué, le VSE suffit. Il montre vite ses limites cependant car manquant de fonctions importantes.

Pour le décalage audio, ce doit être une question de fréquence différente entre ton projet et ta séquence importée. Je te renvoie vers ce topic.

La fréquence d'affichage est souvent bien plus lente que la vidéo à cause des calculs, c'est normal. Tu peux essayer de créer un proxy qui va te faire des images plus petites qui seront affichées à la place de tes images réelles, ce qui accélérera le monitoring sans rien détruire dans tes images originales.

J'espère que je t'aurai aidé un peu.
Bon dimanche.

Contribution le : 04/08/2019 12:08
Créer un fichier PDF de la contribution Imprimer


Re: Sequencer très lent (Blender 2.80)
OverdOzed
Inscrit:
23/02/2006 18:10
De Alpes-Maritimes
Post(s): 2573
Hello Rimpotche,
Merci pour ta réponse. Ca me sera utile pour d'autres montages plus petits. :)

J'ai choisi d'utiliser un autre logiciel plus poussé pour le montage (Shotcut, que j'ai découvert à cette occasion). En effet, Blender est assez limité pour le montage et la 2.80 n'a pas évolué à ce niveau.

J'avais près de 7Go de vidéo que je voulais couper en petits morceaux pour avoir un peu de rythme, et surtout beaucoup de bouts à retirer... Ca aurait été une vraie galère avec ou sans ces ralentissements.

J'ai testé avec des PNG dans le Sequencer pour réaliser une transition dans la vidéo (exportée en ffmpeg/PNG pour avoir une vidéo transparente), je tournais là encore à 10-15fps.
Donc ça m'a conforté dans l'idée de changer de logiciel même si je ne connais pas la cause de ces performances médiocres.

Bonne journée !

Contribution le : 05/08/2019 12:52
_________________
Venez tester notre projet de Blender Clan 2.0 + Tchat (en cours de développement) !
Pourquoi ? Retrouver un forum fonctionnel.
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
The Blender Clan 'tchat Avenir du blender clan    [1][2][3]...[13] 129 8664 Aujourd'hui 20:33:40
Hook 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Nouvelle mise à jour Steam    [1][2][3]...[63] 623 105510 Aujourd'hui 20:28:17
Hook 
Questions & Réponses comment subdiviser sur un point précis ? 1 22 Aujourd'hui 18:07:45
Rimpotche 
Hors Sujet !! Meltingman le retour :D    [1][2][3][4] 30 1557 Aujourd'hui 17:54:11
Rimpotche 
Questions & Réponses Figer objets dans la scène 3 46 Aujourd'hui 16:22:22
stigmamax 
[WIP] et travaux terminés [terminé] Rendu super ultra rapide Workbench    [1][2] 16 124 Hier 18:20:06
meltingman 
Questions & Réponses Rendu image très lent    [1][2] 19 74 Hier 17:44:37
Bibi09 
Hors Sujet !! Tutoriel - Un petit renard - 2.9 - Solidify Shrinkwarp 0 36 Hier 17:33:38
meltingman 
[WIP] et travaux terminés [terminé] La mare aux canards    [1][2][3] 26 382 Hier 16:29:43
meltingman 
Questions & Réponses Pb de reflet sur polygones 6 84 Hier 15:57:15
mrpix 
[WIP] et travaux terminés [WIP] Teeny Tiny - Story    [1][2][3]...[12] 110 8035 Hier 10:16:48
Bibi09 
Questions & Réponses application de texture procédurale 4 114 Hier 02:26:26
meltingman 
Questions & Réponses Problème textures lors de rendu (lignes blanches) 3 54 29/09 21:28:00
Rimpotche 
Questions & Réponses [résolu] L'herbe s'enfonce sous le sol 2 164 29/09 13:51:45
Nashoba 
Questions & Réponses Associer des textes à un objet 3 123 27/09 18:21:52
meltingman 
Questions & Réponses NLA, équivalent metastrip sur plusieurs objets 2 96 26/09 14:45:29
CBY 
Questions & Réponses [non résolu] Simulation Tissu Temps Reel    [1][2] 17 400 26/09 09:50:21
moonboots 
The Blender Clan 'tchat Benchmark EEVEE    [1][2][3] 24 922 25/09 14:37:08
Bibi09 
[WIP] et travaux terminés Différents rendus 2.91 9 227 25/09 12:05:20
Bibi09 
Questions & Réponses Render Layers qui n'apparaissent pas    [1][2] 10 322 25/09 11:02:12
HarDrive 

Qui est en ligne
85 utilisateur(s) en ligne (dont 60 sur Forums)

Membre(s): 0
Invité(s): 85


plus...
Nouveaux membres
KristiQeg8 1/10/2020
PeteKimbre 1/10/2020
KinaPlante 1/10/2020
QBLChristi 1/10/2020
DewayneKul 1/10/2020
Akatag7 1/10/2020
jeremyj96 29/9/2020
wouguy 29/9/2020
NeoS 27/9/2020
golgot76 25/9/2020
Dernier Ajout
mirages-preview~0.jpg

Evènements à venir
Nov 18
Anniversaire de RichDeg
Dec 29
Anniversaire d'ebrain
Jan 9
BUG de Lyon
plus 264 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2020 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445