Rigging occasionne des bugs avec automatic weight

Posté par Patrickletare le 25/3/2021 12:06:19
Bonjour,

Continuant mon petit bout de chemin, je viens de modéliser mon premier character.

J'avais pas mal de questionnement pour rigger ses habits, puis j'ai pensais utiliser l'armature sur le coprs puis les habits, qu'en pensez-vous ?

Malheureusement avant d'en arriver là j'ai rencontré des souscis, je suis donc revenus au base, j'ai retiré le miror, et je ne tente plus que de rigger le corps.

Souci, le automatic weight fait n'importe quoi, il attribut peux de "force" et de manière très diffuse...
Qui plus est, lorsque je reprends moi même la weight map j'ai beau le faire au mieux, en bougeant le bras, par exemple, les jambe me font pleins de bugs bizarre...

Il y a pas mal de topic en anglais là dessus mais j'aurais voulus voir avec vous la source du problème pour l'éviter à l'avenir et tenter de corriger au mieux sans trop faire de patch et de modifier supplémentaire...

Le maillage me semble pas trop sale, eventuellement recalculer les normals ? Mais il y a beaucoup d'options et je ne vois pas trop laquelle conviendrait...

Enfin passons aux images:

Le modèle
https://nsa40.casimages.com/img/2021/03/25/210325120547715744.png

La vue en tranche
https://nsa40.casimages.com/img/2021/03/25/210325120547564407.png

Weight de l'avant dernier bones
https://nsa40.casimages.com/img/2021/03/25/210325120547967494.png

Weight du dernier bones
https://nsa40.casimages.com/img/2021/03/25/210325120548235684.png


Tout semble bon et pourtant lorsque j'articule le bras :

https://nsa40.casimages.com/img/2021/03/25/210325120548508761.png


Je ne comprends vraiment pas :/ Je vous remercie d'avance les amis

Cette contribution était de : http://blenderclan.tuxfamily.org/html/newbb/viewtopic.php?forum=1&topic_id=50610&post_id=588376