Re: Projet Tales & Legends - phase test 2

Posté par Matpi le 12/4/2017 18:26:21
Concernant tes erreurs:

Error, region type <blabla> missing in...

Cela est dû à une région (p.ex. 3D View, UV Editor, Properties, etc.) de ton fichier .blend qui pour une raison obscure n'est pas reconnue par Blender. Cela pourrait éventuellement arriver si tu as des fichiers .blend provenant de versions différentes de Blender. (qu'utilises-tu comme version? master/build ou officielle?)

Ce n'est a priori pas important, et comme tu le vois cela n'arrive pas durant le jeu, mais à l'ouverture d'un .blend par Blender.

Si tu tiens à avoir plus de précisions, tu peux me passer le .blend en MP et je peux tenter d'y jeter un coup d'oeil.

libpng error: bad adaptive filter value

Apparemment tu dois avoir une image .png (qui semble être packée dans ton .blend, si ça peut t'aider) soit corrompue, soit non complètement supportée par la version de libpng de Blender.

Je ne sais guère quoi te conseiller, sachant que d'autres programmes par exemple pourraient très bien être capable de lire ou d'écrire cette image, même si Blender te l'indique problématique. Tu pourrais essayer d'isoler l'image qui bugge et ensuite de la réenregistrer dans un quelconque programme (voire Blender lui-même).

Commence peut-être par vérifier si toutes les textures s'affichent correctement dans ton jeu.

Il pourrait également y avoir un très léger risque qu'une image ait l'extension .png avec un autre format de données.

Cette contribution était de : http://blenderclan.tuxfamily.org/html/newbb/viewtopic.php?forum=5&topic_id=45758&post_id=565065