(1) 2 »


Problème d'affichage Blender Ubuntu ATI
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Salut à tous,

je suis à peu près certain que la question a déjà été posée, mais impossible de remettre la main sur le thread...

Donc voilà, je viens d'installer Ubuntu (Feisty) sur un portable, et lorsque je lance Blender j'ai des bugs graphiques monstrueux, à savoir que tout s'affiche vraiment n'importe comment, les menus les uns sur les autres, le rafraichissement ne se fait pas partout...

Ma CG est une ATI mobility, les drivers semblent bien installés (GLXGears fonctionne très bien), OpenGl semble fonctionner (glxinfo | grep direct affiche "direct rendering: Yes")... J'ai essayé l'utilitaire "drivers proprio" de Feisty, qui me dit que je n'ai pas besoin de drivers proprios...

Merci de me dépanner !

Contribution le : 01/10/2007 13:02
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
OverdOzed
Inscrit:
05/11/2003 23:53
De Cordelle
Post(s): 2069
Même problème, ati radeon 7300.
Aucune solution trouvée à ce jour, à part d'utiliser Blender en static.
En cherchant sur le net, j'ai trouvé pas mal de topic sur ce problème, aucun résolus.
Si tu trouves, tu feras un heureux

Contribution le : 01/10/2007 13:59
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Malheureusement, j'ai le même problème avec la version Static. J'ai oublié de préciser que j'ai deux erreurs dans la console :
tibo@tibo-laptop:~/Desktop/blender-2.45-linux-glibc236-py25-i386-static$ blenderguessing 'blender-bin' == '/usr/bin/blender-bin'
Compiled with Python version 2.4.
Checking for installed Python... got it!
Ignoring Xlib error: error code 169 request code 145
Ignoring Xlib error: error code 169 request code 145


Je vais continuer à chercher mais si quelqu'un a une idée...

Contribution le : 01/10/2007 19:53
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
...au fait, avant qu'ebrain ne me le réclame , voici mon xorg.conf :

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"oss"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"stylus"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"eraser"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"cursor"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc Radeon Mobility M6 LY"
	Driver		"ati"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc Radeon Mobility M6 LY"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice     "stylus"	"SendCoreEvents"
	InputDevice     "cursor"	"SendCoreEvents"
	InputDevice     "eraser"	"SendCoreEvents"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Contribution le : 01/10/2007 20:12
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
Ze Grand Manitou
Inscrit:
24/07/2003 14:50
De la Région Parisienne
Post(s): 21822
En effet tu ne peux pas faire grand chose, il s'agit d'un bug lié à ubuntu et blender .

Peut-être que ça changera avec la Gutsy, censée sortir le 18 de ce mois (voire un peu plus tard, en vue des bugs rencontrés sur la BETA que je teste et qui n'est pas tout à fait au point... con pour une version vouée à être une LTS ).

Je pense qu'il y a de fortes chances que ce problème soit résolu, notamment grâce à l'update du xorg vers une version 7.3 (enfin encore officiellement 7.2 mais il ne manque plus grand chose).

@+

Contribution le : 01/10/2007 20:21
_________________

Mickaël Guédon | Site pro : www.mickaelguedon.com | Fondateur du Blender Clan : www.blenderclan.org
Auteur de Formations Blender chez Elephorm
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
OverdOzed
Inscrit:
05/11/2003 23:53
De Cordelle
Post(s): 2069
Moi ma carte vidéo c'est une ati M7, donc ce n'est pas exactement pareil...
Pas sur que ça avance à grand chose ce que je dis

Contribution le : 01/10/2007 20:23
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
Ze Grand Manitou
Inscrit:
24/07/2003 14:50
De la Région Parisienne
Post(s): 21822
Citation :
Moi ma carte vidéo c'est une ati M7, donc ce n'est pas exactement pareil...


Le M7 est de mémoire un chip Radeon7200 (et dérivés), donc tu as droit aux mêmes drivers que _tibo_, et donc logiquement le même bug .

@+

Contribution le : 01/10/2007 20:28
_________________

Mickaël Guédon | Site pro : www.mickaelguedon.com | Fondateur du Blender Clan : www.blenderclan.org
Auteur de Formations Blender chez Elephorm
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
J'ai peut être une solution ici, si j'ai bien compris il s'agirait de compiler une version plus récente de Mesa.

Je teste quand j'ai le temps et je vous tiens au courant ! J'espère que ça va m'éviter de devoir attendre Gutsy...

Contribution le : 02/10/2007 12:23
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Bon bin j'ai essayé, et ça ne résoud rien du tout. Je crois que je vais me résigner... et espérer que Gutsy résolve le problème.

Sinon, est-ce qu'il est possible de revenir à une version plus ancienne des drivers puisqu'elle semble fonctionner ?

Contribution le : 03/10/2007 00:48
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: Problème d'affichage Blender Ubuntu ATI
Touriste
Inscrit:
06/06/2007 14:51
Post(s): 19
je confirme le probleme sur radeon mobility 7000,

en fait, en chargeant les drivers radeon ça résoud le problème pour blender, mais à l'inverse, c'est gnome et le bureau qui partent en live...

la version ou j'ai ces problème est une ubuntu studio (dérivée donc de feisty)...

à tester donc avec une gutsy ...

Contribution le : 03/10/2007 15:01
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant
(1) 2 »




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Graphisme alternatif faire de la bd avec blender 5 98 Hier 20:02:12
blend74 
Python & Plugins [terminé] City pack Cars pour Blender 1 46 Hier 18:07:21
meltingman 
Hors Sujet !! les tutos de Moonboots    [1][2][3]...[15] 143 9782 Hier 10:12:37
yawdpwal 
Questions & Réponses prb tuto crash car/rigid body    [1][2] 12 132 17/06 18:54:54
belomaker 
The Blender Clan 'tchat Avenir du blender clan    [1][2][3]...[23] 222 25979 17/06 10:34:03
Riggelm 
Graphisme alternatif Un court-métrage apocalyptique en 2D ! 3 2231 16/06 18:23:28
moonboots 
Dessin traditionnel Dessins - BlendX 8 14216 16/06 16:41:23
blend74 
Graphisme alternatif Monster Mash    [1][2] 15 311 16/06 16:22:01
blend74 
Questions & Réponses [résolu] Placer mon world 7 82 16/06 09:13:57
Lylo 
Questions & Réponses [non résolu] animation : décalage d'un objet avec "Follow path"    [1][2] 12 128 16/06 05:57:44
blendinfos 
Questions & Réponses Different move value for parent or child - Distances différentes pour un parent ou un enfant 0 101 16/06 04:12:14
Gazpart 
Questions & Réponses Probleme Papercraft sous Blender 6 105 15/06 16:25:42
pinockenstein 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Version alpha disponible + discord    [1][2][3]...[67] 667 138842 15/06 08:58:37
Hook 
Questions & Réponses [non résolu] Plusieurs object qui avance sur une ligne trajectoire 9 534 14/06 18:29:34
blendinfos 
Questions & Réponses [non résolu] animer 2 objets ensemble, puis les séparer 2 52 14/06 11:43:57
blendinfos 
[WIP] et travaux terminés modelisation et animation de petits persos 9 245 14/06 10:20:03
blend74 
[WIP] et travaux terminés [terminé] invitation pour l'avant première de "BRUMES"    [1][2] 15 945 14/06 04:30:41
meltingman 
The Blender Clan 'tchat Blender 2.8x : Actus, tests, feedback..    [1][2][3]...[10] 91 46962 14/06 04:29:58
meltingman 
Moteur de jeu GameBlender et alternatives [BGE]comment faire varier la vitesse d'animation par appui d'une touche? 0 58 12/06 22:12:47
neonclignote 
Questions & Réponses [résolu] Problème Bake 5 1450 12/06 16:16:53
Me 

Qui est en ligne
174 utilisateur(s) en ligne (dont 146 sur Forums)

Membre(s): 0
Invité(s): 174


plus...
Nouveaux membres

Nemo
11/3/2021
qingjie 10/3/2021
Kask909 9/3/2021
marie-antoinette 7/3/2021
Bugs 7/3/2021
lolorogli75 4/3/2021
Flagiel 4/3/2021
thedeathclown 1/3/2021
Littlespoon 28/2/2021
luxperpetua 27/2/2021
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Jui 30
Anniv des Jedi :-D
Jui 10
BUG de Lyon
Jui 23
Anniv du BlenderClan !
plus 255 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445