[Weight paint] Problème d'affichage
Clan Afficionado
Inscrit:
06/05/2014 18:47
Post(s): 46
Bonjour,

J'ai un soucis très handicapant sous Blender actuellement.
J'essaye de rigger un personnage tout simple. Au début, tout marchait bien. Le rig est terminé et quand j'ai commencé à attaquer le skinning en mode "Weight paint", j'avais bien les couleurs rouges pour les vertex avec une influence à 100% et une couleur bleue pour les influence à 0%.

Cependant, depuis un bon moment, tous mes vertex apparaissent en bleu.
Au début, j'avais pensé à un problème pour ajouter des influences sur mon personnage, mais non. Quand je bouge un bone (par exemple un bras), le mesh suit très bien ce bone en fonction de l'influence qui lui a été donné automatiquement, mais quand je clique sur le vertex group, la couleur reste désespérément bleue, comme s'il n'y avait aucune influence !

Edit: J'ai également pu constater qu'en réalité, toute l'influence de mes vertex, selon l'affichage de mon weight paint, viendrait des bones pour le mollet gauche et pour le pied gauche... Quand je clique sur ces 2 vertex groupe, l'un montre tout le corps en jaune, l'autre tout le corps en vert. Pourtant, vous l'avez constaté avec ce que je fais avec les bones du bras dans l'image sta.sh, mais ça ne peut pas être ça. Le weight paint m'affiche en fait de fausses influences... =/

Voici un aperçu de ce que j'ai, si ça peut vous aider : http://sta.sh/01flq2z2q97q
Au besoin, vous pouvez télécharger mon fichier .blend ici : http://www.mediafire.com/download/4j8zvyde2ppm8q5/Advanced_Stickman_v9_Tests2.blend

J'ai tenté de toucher à quelques outils dans les panneaux de gauche et de droite dans la 3D view, de débloquer le système en mettant une weight paint personnalisée dans les user preferences et même tenté de retirer l'influence de l'armature du mesh et de le remettre (en faisant Alt + P sur le mesh et de nouveau Ctrl + P sur le mesh et l'armature).

Rien n'y fait.

Quelqu'un pourrait-il m'aider, SVP ?



Explication de la nomenclature de mes bones dans le .blend, si besoin :
- SK_********* = Skin (il s'agit des bones qui sont censé avoir une influence sur les vertex de mon mesh.
- **_SP_****** = Spines (la colonne vertébrale)
- **_Lg_****** = Leg (les jambes)
- **_Am_****** = Arm (les bras)
- **********.l = partie gauche
- **********.r = partie droite

Contribution le : 10/06/2015 15:42
Créer un fichier PDF de la contribution Imprimer


Re: [Weight paint] Problème d'affichage
OverdOzed
Inscrit:
31/07/2005 20:03
De île-de-France
Post(s): 1234
Salut,
Grâce à toi, je viens d'apprendre une nouvelle option
Si on sélectionne un bone qui a une influence, lorsqu'on peint, ça ne dépasse pas la zone déjà en place. Donc si tu as un bone sans influence, tout restera bleu.

Pour débloquer ça, tu vas dans option et décoche restrict :)
Ensuite, n'oublie pas que tu as des bones dans des calques non activés.

Contribution le : 11/06/2015 13:09
_________________
mon blog
Créer un fichier PDF de la contribution Imprimer


Re: [Weight paint] Problème d'affichage
Clan Afficionado
Inscrit:
06/05/2014 18:47
Post(s): 46
Uuuum... Je ne suis pas certain de voir ce que tu as compris, mais bon. Je suis content de voir que j'ai pu t'aider indirectement à comprendre une fonctionnalité de Blender... =)

Pour ce qui est des influences, je connais déjà très bien le code couleur. Bleu pour 0%, vert ou jaune pour 50%, rouge pour 100%.

Mais le problème ne vient pas du fait que mes bones sélectionnés n'ont pas d'influence sur les vertex, mais du fait que mes bones sélectionnés ont de l'influence sur des vertex qui restent désespérément affichés en bleu. Par ailleurs, je peux changer leur influence en weight paint, peindre pour ajouter ou retirer des influences, mon mesh restera bleu quoi qu'il en soit.

En fait, d'après l'affichage de mon weight paint, les seuls bones qui influencent mon mesh sont les bones du mollet gauche et ceux du pied gauche, qui montre mon mesh totalement jaune pour l'un et totalement vert pour l'autre.

Bref, je pense vraiment qu'il s'agit d'un problème d'affichage plus qu'autre chose... =/

(Et j'ai essayé en désactivant "restrict" dans les options, mais le problème persiste. ')

Contribution le : 11/06/2015 16:38
Créer un fichier PDF de la contribution Imprimer


Re: [Weight paint] Problème d'affichage
RegulatorZ
Inscrit:
23/05/2004 07:11
De Metz
Post(s): 11301
Salut,
ça fonctionne bien chez moi, sur différents ordis/OS/versions de Blender. Et chez Mly aussi on dirait. Donc oui, ça ressemble à un problème d'affichage sur ta machine.

Quelle version de Blender utilises-tu ? Essaye avec la dernière ?

Quel est ton OS ? (linux Mint on dirait ?) Est-ce qu'il est à jour ? Tu as la possibilité d'essayer avec un autre (un live-usb) ?

Quelle est ta carte graphique ? Les drivers sont-ils à jour ?

Et si tu as l'occasion, essaye ton fichier sur une machine totalement différente.

Contribution le : 11/06/2015 17:02
_________________
Portfolio
Créer un fichier PDF de la contribution Imprimer


Re: [Weight paint] Problème d'affichage
Clan Afficionado
Inscrit:
06/05/2014 18:47
Post(s): 46
Ah mince !
Oui, ben, je me doutais un peu que le problème pourrait venir de là, et ça semble se confirmer, ça doit être un problème de machine... =/

Pour ce qui est de ma version Blender, c'est déjà la dernière : la 2.74 (64 bits). Je me mets fréquemment à jour.

Pour l'OS, Linux Mint 17.1 avec Cinnamon - 64 bits.

Pour la carte graphique, j'ai peur que c'est là que ça foire. Je laisse Linux Mint s'en charger complètement, étant donné que je ne peux pas installer de drivers sur ma carte graphique sans que mon OS plante (carte graphique trop vieille apparemment : AMD ATI Radeon HD 4650 : http://www.commentcamarche.net/forum/affich-30866701-pilotes-ati-radeon-linux-mint-17-pour-rendus-gpu-blender ). Mon ordinateur date après tout de Septembre 2010 et ne supporte plus trop Windows (je suis pourtant sur Windows 7 et non cette bouse de Windows 8 ').

Quant à tester sur une autre machine, je pourrais, mais seulement pour tester, pas pour continuer mon projet... =/

Bref, je suppose que la meilleure solution serait que je me trouve vite un emploi pour m'acheter un nouveau PC puissant avec une carte graphique N-Vidia et sans Windows 8 pour continuer mes projets, je suppose ? '


Enfin, en tout cas, merci beaucoup pour vos aides mly, _tibo_ !
Je pense que je peux mettre le sujet en résolu du coup. Si vous me dites que ça marche chez vous, le problème doit venir de ma machine et je ne peux rien faire.
Je tenterais peut-être quand même sur mon bon vieux Windows 7 comme je l'ai toujours en dual boot.

Encore merci ! =)

Contribution le : 11/06/2015 18:04
Créer un fichier PDF de la contribution Imprimer


Re: [Weight paint] Problème d'affichage
Clan Afficionado
Inscrit:
06/05/2014 18:47
Post(s): 46
Hum... En revanche, je ne peux ni éditer mes messages ni les marquer comme "résolu"... =X

Contribution le : 11/06/2015 18:10
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Hors Sujet !! Sinoceratops project - Ateliers suivies de A à l'Animation 8 133 Hier 22:29:38
meltingman 
Questions & Réponses [non résolu] [Blender 2.9] Halo de type star ? 2 19 Hier 19:00:28
JDragonB 
Graphisme alternatif faire de la bd avec blender    [1][2][3] 24 420 Hier 17:57:17
blend74 
Questions & Réponses [résolu] Définir la résolution d'un curve converti en mesh    [1][2] 10 98 Hier 10:13:48
Arielboid 
Questions & Réponses Plan de découpage 2D à partir d'un low poly ? 5 54 22/06 17:06:08
pinockenstein 
Hors Sujet !! les tutos de Moonboots    [1][2][3]...[15] 144 10243 21/06 15:30:37
moonboots 
[WIP] et travaux terminés Nature - Court-métrage    [1][2] 15 700 21/06 06:21:39
Bibi09 
Questions & Réponses [résolu] Probleme Papercraft sous Blender 7 198 19/06 21:44:21
Larryon 
Python & Plugins [terminé] City pack Cars pour Blender 1 108 18/06 18:07:21
meltingman 
Questions & Réponses prb tuto crash car/rigid body    [1][2] 12 248 17/06 18:54:54
belomaker 
The Blender Clan 'tchat Avenir du blender clan    [1][2][3]...[23] 222 26426 17/06 10:34:03
Riggelm 
Graphisme alternatif Un court-métrage apocalyptique en 2D ! 3 2291 16/06 18:23:28
moonboots 
Dessin traditionnel Dessins - BlendX 8 14297 16/06 16:41:23
blend74 
Graphisme alternatif Monster Mash    [1][2] 15 444 16/06 16:22:01
blend74 
Questions & Réponses [résolu] Placer mon world 7 151 16/06 09:13:57
Lylo 
Questions & Réponses [non résolu] animation : décalage d'un objet avec "Follow path"    [1][2] 12 248 16/06 05:57:44
blendinfos 
Questions & Réponses Different move value for parent or child - Distances différentes pour un parent ou un enfant 0 242 16/06 04:12:14
Gazpart 
Moteur de jeu GameBlender et alternatives [WIP] DeadSigns FPS horreur - Version alpha disponible + discord    [1][2][3]...[67] 667 139619 15/06 08:58:37
Hook 
Questions & Réponses [non résolu] Plusieurs object qui avance sur une ligne trajectoire 9 605 14/06 18:29:34
blendinfos 
Questions & Réponses [non résolu] animer 2 objets ensemble, puis les séparer 2 96 14/06 11:43:57
blendinfos 

Qui est en ligne
136 utilisateur(s) en ligne (dont 92 sur Forums)

Membre(s): 0
Invité(s): 136


plus...
Nouveaux membres

Nemo
11/3/2021
qingjie 10/3/2021
Kask909 9/3/2021
marie-antoinette 7/3/2021
Bugs 7/3/2021
lolorogli75 4/3/2021
Flagiel 4/3/2021
thedeathclown 1/3/2021
Littlespoon 28/2/2021
luxperpetua 27/2/2021
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Jui 30
Anniv des Jedi :-D
Jui 10
BUG de Lyon
Jui 23
Anniv du BlenderClan !
plus 255 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445