Problème rendu d'animation sur 2.83 et 2.92
Fou Furieux du Clan
Inscrit:
14/10/2018 19:50
Post(s): 173
Bonjour à tous,

Je viens solliciter votre aide pour un problème survenue sur les versions 2,80 à 2.92.
Je m'explique.

Je voudrais refaire le rendu d'une animation déjà effectuer avec la version 2,79, mais une erreur se glisse dans l'animation de mon personnage, qui est un insecte. Une des pattes pas forcément la même, ne suit pas le mouvement qui lui a été dédier. Ce qui n'avait pas lieu lors du précédent rendu. Cette erreur n'est provoqué que lors du rendu en animation et pas si je fais un rendu d'une image seul.Pas non plus forcément au même endroit de l'animation et pas non plus sur deux pc différent, c'est en fait complètement aléatoire. J'ai cherché de quoi cela pouvait venir, mais sans résulta.

Je vous mets en ligne deux images montrant l'erreur en question, le .blend de l'animation est trop volumineux pour être mis sur pasteall.org, mais en cas de besoin je peu le mettre sur un autre hébergeur.

Rendu fixe

Rendu d'animation

Merci par avance de vos réponses

Contribution le : 21/03 10:19:57
Créer un fichier PDF de la contribution Imprimer


Re: Problème rendu d'animation sur 2.83 et 2.92
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2826
Also... Zara !

En général, il est prudent de sortir l'animation d'abord en images fixes (par exemple PNG qui est lossless) et ensuite de les assembler facilement en anim dans le Sequencer.

Si l'erreur semble aléatoire, et si les images fixes sont bonnes, suis cette méthode. Et au cas où une image est erronée, rends-la à nouveau jusqu'à ce qu'elle soit correcte.

Contribution le : 21/03 11:52:26
_________________
Des soucis, un SOUCI !
Créer un fichier PDF de la contribution Imprimer


Re: Problème rendu d'animation sur 2.83 et 2.92
Fou Furieux du Clan
Inscrit:
14/10/2018 19:50
Post(s): 173
Bonjour Rimpotche,

Je me suis mal fait comprendre, je n'ai pas rendu en fichier vidéo, mais image par image, en PNG.
Le fait est que lorsque je fais un "rendu image" (F12) pas de problème, mais si je fais un "rendu animation" (Ctrl F12) alors là est l'erreur.

Je n'ai pas essayé en "fichier vidéo où AVI" peut que je devrais ?

Contribution le : 21/03 12:46:14
Créer un fichier PDF de la contribution Imprimer


Re: Problème rendu d'animation sur 2.83 et 2.92
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2826
Ah bon,

Mais alors toutes les images sont fausses ou seulement quelques unes ?
Est-ce que tu rends toujours la même image en solo ?
Ce que j'ai remarqué, c'est que la patte fautive est juste à l'envers. Donc une image-clé ou un scale -1 en Z quelque part ?

Contribution le : 21/03 17:55:45
_________________
Des soucis, un SOUCI !
Créer un fichier PDF de la contribution Imprimer


Re: Problème rendu d'animation sur 2.83 et 2.92
Fou Furieux du Clan
Inscrit:
14/10/2018 19:50
Post(s): 173
Je ne sais pas.

Ce que je garde à l'esprit c'est qu'il n'y avait pas d'erreur sur la version 2.79 !
Qu'est-ce qui a changé depuis la version 2.80, point de vue IK ?

Contribution le : 21/03 18:49:46
Créer un fichier PDF de la contribution Imprimer


Re: Problème rendu d'animation sur 2.83 et 2.92
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2826
Je ne sais pas, mais en attendant mieux, pourquoi ne rends-tu pas avec la 2.79 ?

Contribution le : 21/03 20:11:38
_________________
Des soucis, un SOUCI !
Créer un fichier PDF de la contribution Imprimer


Re: Problème rendu d'animation sur 2.83 et 2.92
Fou Furieux du Clan
Inscrit:
14/10/2018 19:50
Post(s): 173
Une foi le ficher enregistrer sur supérieure à la 2.79, plus possible de revenir en arrière.

Et évidement je n'ai pas fais de copie

Contribution le : 21/03 21:06:08
Créer un fichier PDF de la contribution Imprimer


Re: Problème rendu d'animation sur 2.83 et 2.92
OverdOzed
Inscrit:
22/03/2010 12:13
De Gard du Nord
Post(s): 2826
La meilleure politique pour les blends c'est de faire Projet01.blend, Projet02.blend, etc... chaque fois qu'on fait un changement important. En informatique, il faut être très organisé.

Dans ton cas, il te reste un peu d'espoir :
1) Tu pourrais essayer de tout recharger en "Append" dans la 2.79. Il se peut que quelques éléments du projet renâcleront, mais ça vaut la peine de faire quelques essais.

2) Dans les préférences, cherche où se trouve ton répertoire temporaire.
Il doit y avoir plein de fichiers à 4 chiffres (du genre 1642.blend). Grâce à la date de création, tu pourrais retrouver ton fichier.

Contribution le : 22/03 08:43:36
_________________
Des soucis, un SOUCI !
Créer un fichier PDF de la contribution Imprimer


Re: Problème rendu d'animation sur 2.83 et 2.92
Fou Furieux du Clan
Inscrit:
14/10/2018 19:50
Post(s): 173
Merci du conseil, je ferai plus attention la prochaine fois, mais pour le coup je n'aurais pas besoin d'en faire plus.

La solution c'est présenter à moi, le problème venait bien de l'IK. Le solveur était sur "itasc" au lieu de "standard", chose que je ne saurais comprendre car le fichier n'a pas été changer depuis son utilisation sous la 2.79. Il me semble bien me souvenir qu'à l'époque il m'avait fallu utiliser ce solveur pour que mon animation tienne la route.

Quelque chose à été modifier entre les deux versions ou je me trompe ?

Contribution le : 22/03 10:42:58
Créer un fichier PDF de la contribution Imprimer



 Haut   Précédent   Suivant




Enregistrer votre réponse
Compte*
Nom   Mot de passe   Authentification
Message:*



[Recherche avancée]



Sujets récemment répondus
Forums Sujets Réponses Lus Dernières contributions
Questions & Réponses [résolu] Problème Bake 5 1363 Aujourd'hui 16:16:53
Me 
Graphisme alternatif Monster Mash    [1][2] 14 107 Hier 22:34:10
Lylo 
The Blender Clan 'tchat Avenir du blender clan    [1][2][3]...[19] 185 25078 Hier 16:32:14
Bibi09 
Graphisme alternatif Un court-métrage apocalyptique en 2D ! 1 2146 Hier 09:37:52
Lylo 
The Blender Clan 'tchat Blender 2.8x : Actus, tests, feedback..    [1][2][3]...[10] 90 46453 Hier 09:04:19
lapineige 
Questions & Réponses [résolu] Un objet visible avec l'ombre d'un autre (et ce dernier invisible) 6 205 10/06 23:03:57
mcBlyver 
Questions & Réponses [non résolu] Bake et taches noires au rendu 0 38 10/06 15:11:00
Gizmil 
Questions & Réponses [non résolu] Header / Flip to bottom - position fixe 1 44 10/06 13:19:32
moonboots 
Le coin des geeks Amd vs Nvidia    [1][2][3]...[7] 62 6490 10/06 13:16:17
Bibi09 
Inkscape Séparer des noeuds et en faire des objets. 0 35 10/06 11:48:28
Redstar 
Python & Plugins [BGE+python] incrémenter une variable par appui d'une touche 1 74 10/06 08:09:05
Redstar 
Moteur de jeu GameBlender et alternatives [BGE]impossible de jouer l'animation 1 53 10/06 08:06:37
Redstar 
Questions & Réponses animer des courbes de bezier? 9 148 09/06 20:15:55
blend74 
[WIP] et travaux terminés modelisation et animation de petits persos 4 138 08/06 14:19:55
blend74 
Hors Sujet !! les tutos de Moonboots    [1][2][3]...[14] 138 9272 07/06 18:00:15
debutant 
[WIP] et travaux terminés [WIP] La gabarre '' Le Gros Ventre''    [1][2][3]...[7] 66 10558 07/06 13:49:33
Guiu 
Python & Plugins dLoc. dRot 1 79 07/06 11:20:03
Redstar 
[WIP] et travaux terminés [terminé] invitation pour l'avant première de "BRUMES"    [1][2] 14 764 06/06 16:50:22
blend74 
The Blender Clan 'tchat Thème 2.7 pour Blender 2.8x, 2.9x 1 87 05/06 18:53:58
lucky 
The Blender Clan 'tchat Adieu pour moi, le Blender du futur    [1][2][3] 24 2589 05/06 18:40:52
lucky 

Qui est en ligne
139 utilisateur(s) en ligne (dont 111 sur Forums)

Membre(s): 0
Invité(s): 139


plus...
Nouveaux membres

Nemo
11/3/2021
qingjie 10/3/2021
Kask909 9/3/2021
marie-antoinette 7/3/2021
Bugs 7/3/2021
lolorogli75 4/3/2021
Flagiel 4/3/2021
thedeathclown 1/3/2021
Littlespoon 28/2/2021
luxperpetua 27/2/2021
Dernier Ajout
2020-09-24.jpg

Evènements à venir
Jui 30
Anniv des Jedi :-D
Jui 10
BUG de Lyon
Jui 23
Anniv du BlenderClan !
plus 255 plus d'élément(s)
 Par Mickaël Guédon [ebrain] © 2003-2021 The Blender Clan - hébergé par TuxFamily - Site déclaré à la CNIL sous le numéro 1155445